VirtualBox

Ticket #1881 (closed defect: worksforme)

Opened 10 years ago

Last modified 8 years ago

Huge syslog (R0 assertion pgmPoolTracDerefGCPhys)

Reported by: DawnLight Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 1.6.2 Keywords:
Cc: dawnlight@… Guest type: other
Host type: Linux

Description

Hello.

I've found that I've a 1.7G syslog, kern.log and messages so I took a look and saw the message repeating:

Jul 28 15:33:35 box0 kernel:
Jul 28 15:33:35 box0 kernel: !!R0-Assertion Failed!!
Jul 28 15:33:35 box0 kernel: Expression: <NULL>
Jul 28 15:33:35 box0 kernel: Location  : /home/formorer/michael/virtualbox-ose-1
.6.2-dfsg/src/VBox/VMM/VMMAll/PGMAllPool.cpp(2738) void pgmPoolTracDerefGCPhys(P
GMPOOL*, PGMPOOLPAGE*, RTHCPHYS, RTGCPHYS)

Attachments

VBox.log.3 Download (39.4 KB) - added by DawnLight 10 years ago.
linux guest
konq-snapshot17.jpg Download (48.4 KB) - added by DawnLight 10 years ago.
This is the cause of the syslog messages…
VBox.2.log Download (36.8 KB) - added by frank 10 years ago.
VBox.log Download (39.3 KB) - added by frank 10 years ago.
VBox.log.1 Download (36.2 KB) - added by frank 10 years ago.
VBox.log.2 Download (41.9 KB) - added by frank 10 years ago.
VBox.log.2.2 Download (41.9 KB) - added by frank 10 years ago.
VBox.log.2.1 Download (36.2 KB) - added by frank 10 years ago.
VBox.log.2.3 Download (42.9 KB) - added by frank 10 years ago.
VBox.log.3.3 Download (42.9 KB) - added by frank 10 years ago.
vbox_logs_Murz.tar.gz Download (17.3 KB) - added by Murz 10 years ago.
Logs for machine "test" with errors.

Change History

Changed 10 years ago by DawnLight

linux guest

comment:1 Changed 10 years ago by DawnLight

host's uname -a: Linux box0 2.6.18-6-amd64 #1 SMP Mon Jun 16 22:30:01 UTC 2008 x86_64 GNU/Linux the host is Debian etch. It has the virtualbox-ose and virtualbox-ose-source packages installed from backports.org.

the guest linux is also a Debian etch. Linux debian 2.6.18-6-486 #1 some date i686 GNU/Linux

The guest windows xp is SP3.

The linux guest has a segfault sometimes at early boot up. I didn't check to see that this is what generates the messages. When it happens, i just reset the guest and it doesn't happen the next boot up.

comment:2 Changed 10 years ago by michael

Is this or #1882 the "correct" report?

comment:3 Changed 10 years ago by DawnLight

I've reported this and then added additional information as a comment; if this is what you're asking.

comment:4 follow-up: ↓ 5 Changed 10 years ago by michael

You created two separate reports, this one and #1882 (follow that link). Could you please make sure that one of the two contains all the information so that I can close the other? Just to keep things clean in our bugtracker :) Thanks!

comment:5 in reply to: ↑ 4 Changed 10 years ago by DawnLight

Replying to michael:

You created two separate reports, this one and #1882 (follow that link). Could you please make sure that one of the two contains all the information so that I can close the other? Just to keep things clean in our bugtracker :) Thanks!

Ah, sorry. Yes. well, I've apparrently made two accidentally. One has the comment with the further information and the other has the log files... I'll be more careful next time.

Changed 10 years ago by DawnLight

This is the cause of the syslog messages...

comment:6 Changed 10 years ago by frank

  • Component changed from other to VMM
  • Summary changed from Huge syslog to Huge syslog (R0 assertion pgmPoolTracDerefGCPhys)

Changed 10 years ago by frank

Changed 10 years ago by frank

Changed 10 years ago by frank

Changed 10 years ago by frank

Changed 10 years ago by frank

Changed 10 years ago by frank

Changed 10 years ago by frank

Changed 10 years ago by frank

comment:7 Changed 10 years ago by frank

How easy can you reproduce this bug? Do these R0 assertions occur on every boot?

comment:8 Changed 10 years ago by DawnLight

Trying to reproduce it, I've rebooted the guest several times until it happened again. Now the guest is paused; I will keep it at this state should you want anything from it.

comment:9 Changed 10 years ago by frank

Thanks but we have to reproduce this bug locally somehow. Therefore we need a good testcase.

comment:10 Changed 10 years ago by DawnLight

Is there anything I can do to help except sending you my system?

comment:11 Changed 10 years ago by Murz

Confirm error like this on my system too. System is Debian Lenny AMD64. Virtualbox version is 1.6.4-33808_Debian_etch # uname -a Linux srv 2.6.25-2-amd64 #1 SMP Mon Jul 14 11:05:23 UTC 2008 x86_64 GNU/Linux

With smaller image size (6gb) all works good (Virtual system in WinXP 32Bit). But when I create new image with 12gb size and try to boot from iso (GParted) for copy partition from 6gb to 12gb, I got this errors (on time booting gparted system) in syslog and 100% load of CPU:

Aug 22 09:51:15 srv kernel: [  521.957618] Expression: <NULL>
Aug 22 09:51:15 srv kernel: [  521.957619] Location  : /home/vbox/vbox-1.6/src/VBox/VMM/VMMAll/PGMAllPool.cpp(2738) void pgmPoolTracDerefGCPhys(PGMPOOL*, PGMPOOLPAGE*, RTHCPHYS, RTGCPHYS)
Aug 22 09:51:15 srv kernel: [  521.957629]
Aug 22 09:51:15 srv kernel: [  521.957630] !!R0-Assertion Failed!!
Aug 22 09:51:15 srv kernel: [  521.957631] Expression: <NULL>
Aug 22 09:51:15 srv kernel: [  521.957631] Location  : /home/vbox/vbox-1.6/src/VBox/VMM/VMMAll/PGMAllPool.cpp(2738) void pgmPoolTracDerefGCPhys(PGMPOOL*, PGMPOOLPAGE*, RTHCPHYS, RTGCPHYS)
Aug 22 09:51:15 srv kernel: [  521.957642]
Aug 22 09:51:15 srv kernel: [  521.957643] !!R0-Assertion Failed!!
Aug 22 09:51:15 srv kernel: [  521.957644] Expression: <NULL>
Aug 22 09:51:15 srv kernel: [  521.957644] Location  : /home/vbox/vbox-1.6/src/VBox/VMM/VMMAll/PGMAllPool.cpp(2738) void pgmPoolTracDerefGCPhys(PGMPOOL*, PGMPOOLPAGE*, RTHCPHYS, RTGCPHYS)

comment:12 Changed 10 years ago by Murz

I have vbox system with one IDE (12gb file, Fixed-size image) and CDRom from iso file (gparted-live-0.3.6-5.iso). Host system and another computers boot normally with this iso (if I write it to CD). In Virtualbox virtual system Gparted boots but got errors on the place:

Begin: Loading essential drivers... ...
Done.
Begin: Running /scripts/init-premount ...

And after that systems goes to working very-very slow and posting errors in syslog and uses 100% of cpu. After that GParted system writes:

SCSI subsystem initialized
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot: 000:00:01.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xc000-0xc007, BIOS settings: hda: pio, hdb:pio
    ide1: BM-DMA at 0xc008-0xc00f, BIOS settings: hdc: DMA, hdd:pio
hdc: VBOX CD-ROM, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x357 on irq 15
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:0d.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
ahci 0000:00:0d.0: AHCI 0001.0100 32 slots 1 ports 3 Gps 0x1 impl SATA mode
ahci 0000:00:0d.0:  flags: 64bit ncq ilck stag only
scsi0 : ahci
ata1: SATA max UDMA/133 cmd 0xf8820100 ctl 0x00000000 bdma 0x00000000 irq 11
ata1: SATA link down (SStatus 0 Scontrol 300)
Clocksource tsc unstable (delta = -194421953 ns)
Time: acpi_pm clocksource has been installed.
hdc: ATAPI 32X DVD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20

And after thats systems stop loading, but errors goes to syslog and 100% cpu load is staying. When I pause the virtual system, errors in syslog stop going but 100% cpu load is staying here. And I can use Virtualbox interface and stops the system (Poweroff), but after that errors in syslog stop going but 100% cpu load is staying here.

comment:13 Changed 10 years ago by Murz

After exiting Virtualbox 100% CPU use process "/usr/sbin/famd -T 0". If I restart fam service with command:

# /etc/init.d/fam  restart
Stopping file alteration monitor: FAM.
Starting file alteration monitor: FAM.

All works good with normal CPU load.

comment:14 Changed 10 years ago by Murz

when virtualbox is working, his proseeses eat 100 of cpu:

  PID USER     PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command
 4674 qseo      20   0  393M  100M 16200 S 89.4  2.6  0:09.91 /usr/lib/virtualbox/VirtualBox -comment apache_test -startvm 4e7a08c2-fbad-4d73-5a9b-94b6222a7605
 4684 qseo      20   0  393M  100M 16200 R 88.7  2.6  0:09.70 /usr/lib/virtualbox/VirtualBox -comment apache_test -startvm 4e7a08c2-fbad-4d73-5a9b-94b6222a7605

comment:15 Changed 10 years ago by frank

We still need a better testcase. Murz, is your .iso home-brewn or do you use something like an Ubuntu LiveCD (which contains gparted)?

comment:16 Changed 10 years ago by Murz

I have use a gparted livecd from here:  http://gparted.sourceforge.net/livecd.php Version is: gparted-live-0.3.6-5.iso

Now I try to turn off "Enable VT-x/AMD-V" option and turn on "Enable PAE/NX" option, after that I create all disks again and install fresh windows and now I didn't see this errors when booting gparted from ISO with windows drives. And now all works good without errors like in my earlier messages.

comment:17 Changed 10 years ago by frank

Ok, can you attach a VBox.log file of a VM session? I want to have a look at your configuration. Thanks.

comment:18 Changed 10 years ago by frank

  • Component changed from VMM to VMM/HWACCM

Changed 10 years ago by Murz

Logs for machine "test" with errors.

comment:19 Changed 10 years ago by Murz

I have created a new machine with 2 hdd and one cd image (gparted-live-0.3.6-5.iso) and try to boot. And see the errors again. Logs is attached.

comment:20 Changed 10 years ago by umeboshi

Sorry for the duplicate bug report. I made the new one, because I thought this was closed somewhere around 1.6.4 .

comment:21 Changed 9 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Please retry with 2.1.4 and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use