VirtualBox

Ticket #2298 (closed defect: worksforme)

Opened 6 years ago

Last modified 6 years ago

Unreadable shared folder leads to broken Machine XML

Reported by: njw Owned by:
Priority: major Component: shared folders
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

One of my VirtualBox shared folders is a samba mount, and at times is not connected. Upon opening VirtualBox, presumably after it had been previously running when the samba mount was unreadable, I found that it complained that my Virtual Machine XML description was invalid, as the required attribute "name" was not present for the shared folders for the latest snapshot. It turned out that the line in question was changed from: <SharedFolder hostPath="/mnt/monster-shared" name="shared" writable="true"/> to <SharedFolder writable="true"/>

Changing it back worked fine.

Therefore presumably upon finding that the shared folder was inaccessible VirtualBox tried to remove the SharedFolder entry, but didn't quite do it right.

VirtualBox version 1.5.6_OSE on Ubuntu 8.04

Change History

comment:1 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Please try to reproduce this on 2.0.2 and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use