VirtualBox

Ticket #2225 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Shared folders doesn't work with Win2003 x64 and WinXP x64 -> fixed in SVN/2.1.4

Reported by: MrX1980 Owned by:
Priority: critical Component: shared folders
Version: VirtualBox 2.1.2 Keywords: shared folders x64 winxp 2003 server
Cc: Guest type: Windows
Host type: Windows

Description

Host:
WinXP x64 SP2 english

Guests:

  • WinXP x64 SP2 german
  • Win2003 R2 x64 SP2 english

Windows Explorer hangs (in the guest) if I try to open the shared folder.
See the Screenshot VirtualBox_Error_001.jpg

Attachments

VirtualBox_Error_001.jpg Download (103.1 KB) - added by MrX1980 6 years ago.
VBox_Win2003_x64_001.log Download (49.7 KB) - added by MrX1980 6 years ago.
VBox_WinXP_x64_001.log Download (49.7 KB) - added by MrX1980 6 years ago.
install.log Download (48.4 KB) - added by MrX1980 6 years ago.
install_ui.log Download (3.1 KB) - added by MrX1980 6 years ago.
VBox_Win2003_x64_002.log Download (42.4 KB) - added by MrX1980 5 years ago.
Win2003x64eng with VB 2.1.2
VBoxSF.sys Download (240.3 KB) - added by sunlover 5 years ago.
VBoxSF.sys shared folders guest driver for 64 bit Windows guests and VirtualBox 2.1.2
VBox.log Download (60.9 KB) - added by ElQuia 5 years ago.
log after trying new vboxsf.sys in Win7

Change History

Changed 6 years ago by MrX1980

Changed 6 years ago by MrX1980

Changed 6 years ago by MrX1980

comment:1 follow-ups: ↓ 2 ↓ 3 Changed 6 years ago by pentagonik

Did you also try a "net use s: \vboxsrv\SharedFolder" in the command line? Does your user in the VM have admin rights or is it a restricted user?

Please try to install the Guest Additions again, this time with the parameter "/l" (enables debug logging). You'll find the logs ("install.log" and install_ui.log) in the installation directory (usually under C:\Program Files\Sun\...).

comment:2 in reply to: ↑ 1 Changed 6 years ago by mas912

I have the same behaviour on 2.0. After updating vbox to 2.0.2 and it's guest additions shared folders work again.

Host: WinXP x64 SP2, guest: WinXP SP3.

Changed 6 years ago by MrX1980

Changed 6 years ago by MrX1980

comment:3 in reply to: ↑ 1 Changed 6 years ago by MrX1980

Replying to pentagonik:

Did you also try a "net use s: \vboxsrv\SharedFolder" in the command line? Does your user in the VM have admin rights or is it a restricted user?

This did not work too. Then every start of windows explorer freezes.

Please try to install the Guest Additions again, this time with the parameter "/l" (enables debug logging). You'll find the logs ("install.log" and install_ui.log) in the installation directory (usually under C:\Program Files\Sun\...).

The logs I have added. I hope it helps.
I work always as a local admin (host&guest).

comment:4 Changed 6 years ago by miguelgl

I'm experiencing the same on Linux x64 host with XP x64 guest...

comment:5 Changed 6 years ago by Loibisch

I'm having the exact same problem with a 64-bit Gentoo as host system and Windows XP x64 SP2 (US) as guest.

If I try to add the shared folders by browsing then explorer just hangs as soon as I select the share itself. If I add the network drive by specifying the path directly without trying to browse the share then it actually maps the drive. But as soon as ANY access to the drive and share is done explorer hangs again. And with "any" access I mean it's even enough to just open "My Computer" which tries to list all your drives, tries to access the network drive and will end up hanging while displaying a blank page.

comment:6 Changed 5 years ago by Loibisch

This problem has been fixed for me with the installation of Vitualbox 2.0.4. Shared folders work fine again in the same virtual machine that had problems before.

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:8 follow-up: ↓ 9 Changed 5 years ago by Loibisch

  • Status changed from closed to reopened
  • Resolution fixed deleted

It looks like I spoke too soon on this matter (or rather the ticket was closed too soon without waiting for confirmation from other people that had the problem.

I have since used all versions of VirtualBox (now at version 2.1.0) and while access to shared folders works *sometimes*, it usually only works for a single session (at most). This means that I must not leave the shared folder connected at system reboot, because on the next restart it will be inaccessible with the symptoms mentioned above.

Right now I tried 2.1.0 again with the latest VirtualBox Guest Additions and the problem was back right away when I connected the shared folder.

Unfortunately this issue is far from being fixed. :|

comment:9 in reply to: ↑ 8 Changed 5 years ago by xmsater

Replying to Loibisch:

It looks like I spoke too soon on this matter (or rather the ticket was closed too soon without waiting for confirmation from other people that had the problem.

I have since used all versions of VirtualBox (now at version 2.1.0) and while access to shared folders works *sometimes*, it usually only works for a single session (at most). This means that I must not leave the shared folder connected at system reboot, because on the next restart it will be inaccessible with the symptoms mentioned above.

Right now I tried 2.1.0 again with the latest VirtualBox Guest Additions and the problem was back right away when I connected the shared folder.

Unfortunately this issue is far from being fixed. :|

I have exactly the same problem. Connecting shared folders works for one session only. If I leave the shared folders to connect after reboot, then after rebooting, accessing them in any way (ie. just opening "My Computer") freezes the guest OS and leaves the host CPU working at 100%.

Host OS: Ubuntu Intrepid (32bit) Guest OS: Windows XP (32bit)

It happens on two different machines, one is AMD Turion 64 X2 laptop, the other is AMD Athlon X2 6000, both with AMD-V enabled.

comment:10 Changed 5 years ago by xmsater

 http://www.virtualbox.org/ticket/2764 This seems to be the same problem. The attached VBoxSF.sys solved the problem for me.

comment:11 Changed 5 years ago by paulc_6969

HOST = Windows XP 32 bit SP3

GUEST= Windows XP 64 SP1

VBox 2.1.0, latest aditions

========== same problem, works in command prompt

========== exporer, My Computer and IE all hang.

comment:12 Changed 5 years ago by sunlover

Please retest with 2.1.2. A similar issue has been fixed there. Do not forget to update the guest additions.

comment:13 Changed 5 years ago by pdumon

Still same problem with 2.1.2 and 2.1.2 guest additions Host: Ubuntu x86_64 Guest: WinXP 64

In command prompt, everything seems to work: net use, changing to the drive, dir, even copying a file and even opening a .doc file by just typing its name at the command prompt.

But explorer, my compuyter, and opening file dialogs (e.g. in Office) all hang

comment:14 Changed 5 years ago by sunlover

pdumon, please attach the VBox.log file for a VM run where you've got the hang.

comment:15 Changed 5 years ago by MrX1980

I have still the same Problem with Win2003x64eng and VirtualBox 2.1.2 (VBox_Win2003_x64_002.log)

Changed 5 years ago by MrX1980

Win2003x64eng with VB 2.1.2

comment:16 Changed 5 years ago by edibile

Host:

Win Vista SP1 x32 Italian

Guest:

Win XP SP2 x64 English - no Win Updates at the time

every access to shared folders hangs explorer process, and any other process trying access them.

When we should expect stable support of shared folders in x64 guests? I think it's a major issue..

comment:17 Changed 5 years ago by edibile

UPDATE FROM PREVIOUS POST:

  1. I forgot to mention my VBox version, it's 2.1.2
  2. Only some Explorer Shell APIs hangs when invoked, programs like total commander works fine, you can copy, launch and whatever you want on shared folders.

And text based commands works fine too (net use, cd, copy, etc.)

Changed 5 years ago by sunlover

VBoxSF.sys shared folders guest driver for 64 bit Windows guests and VirtualBox 2.1.2

comment:18 Changed 5 years ago by sunlover

  • Priority changed from major to critical
  • Version changed from VirtualBox 2.0.2 to VirtualBox 2.1.2

Please try the attached VBoxSF.sys driver. Copy it to the guest \Windows\system32\drivers directory (make a backup copy of existing VBoxSF.sys). The new driver contains a fix for 64 bit guests.

comment:19 Changed 5 years ago by MrX1980

Thanks.
For me it works with Win2003 x64 eng guest on WinXP x64 eng host.
WinXP x64 eng guest not yet tested.
VirtualBox v2.1.2

comment:20 Changed 5 years ago by sunlover

Ticket #3154 has been marked as a duplicate of this one.

comment:21 Changed 5 years ago by 4o66

Confirmed working for WinXP x64 guest on Ubuntu 8.10 x64 Guest Thanks!

comment:22 Changed 5 years ago by sandervl73

  • Summary changed from Shared folders doesn't work with Win2003 x64 and WinXP x64 to Shared folders doesn't work with Win2003 x64 and WinXP x64 -> fixed in SVN/2.1.4

comment:23 Changed 5 years ago by sunlover

Thanks for testing. The fix will be included in the next VBox version.

Changed 5 years ago by ElQuia

log after trying new vboxsf.sys in Win7

comment:24 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use