VirtualBox

Ticket #2224 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

After screen saver starts on Win Vista host - vboxsvc consumes 100% cpu

Reported by: ByteEnable Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords: vboxsvc, 100%, Vista, screen, saver
Cc: Guest type: other
Host type: Windows

Description

VBOXSVC consumes 100% cpu after screen saver starts on host. VBOXSVC remains at 100% cpu until VM is exited. Running an openSUSE 11.0 guest seamless under Windows Vista Enterprise.

Change History

comment:1 Changed 6 years ago by ByteEnable

I resolved this by renabling the Power Management daemon in GNOME sessions. I had disabled this thinking it was not needed.

comment:2 Changed 6 years ago by JRRousseau

I think this is a DUP of #1299.

I'm seeing the same behavior with a Windows Vista Ultimate SP 1 64-bit host and a Fedora Core 9 64-bit guest. I have 2 cores and I see VBoxSvc.exe pegging one of them. Even if I suspend/pause the FC9 guest, VBoxSVC.exe still pegs the CPU. Only fix once I'm in this state is to shut down the guest, exit VB and start it again.

comment:3 Changed 6 years ago by vvsiz

I'm seeing the very same problematic behavior on Windows Vista x64 (host) and Ubuntu 8.04 Server (guest), in *CONSOLE*, when in goes blank.

So, VirtualBox 2.0.2 works fine UNTIL the text console in Ubuntu Server goes blank, then vBoxSvc.exe consumes entire CPU and never goes away, until I close the VM.

comment:4 Changed 6 years ago by zigguratt

I have the same issue: VBoxSVC pegs one CPU at 100% after the computer revives from a suspend. WinXP SP2 host on Centrino Duo (T5600) running Ubuntu 8.04 (server) as guest. The only way to stop it is to shut down the guest. Ubuntu is running nothing but an SSH server. nginx web server and memcached are also running, but nothing is using them so they're completely idle.

comment:5 Changed 6 years ago by zigguratt

I forgot to mention the VirtualBox version: 2.02. I just tried a test with WinXP Pro as guest on the same WinXP host. I suspended the host machine and when it came back, VBoxSVC didn't steal a processor. Of course, I didn't wait very long to revive the host. The problem described above occurred after an overnight suspension.

comment:6 Changed 6 years ago by zigguratt

I did an overnight suspension test running a WinXP VM in the same WinXP host. When the host came back to life, VBoxSVC maxed out one of my processors.

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Most likely a duplicate of #2212. Try again with 2.0.4 and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use