VirtualBox

Opened 19 months ago

Last modified 12 months ago

#21169 new enhancement

Deprecation of libIDL on Linux

Reported by: ceamac Owned by:
Component: other Version: VirtualBox 7.0.0
Keywords: Cc:
Guest type: other Host type: Linux

Description

Hi,

libIDL has been deprecated 8 years ago and some distributions (i.e., Gentoo) are trying to drop it. VirtualBox still depends on it (it is the only dependency left in the tree).

Please consider finding a non-deprecated replacement.

Thank you!

https://gitlab.gnome.org/Archive/libidl

Change History (3)

comment:1 by galitsyn, 19 months ago

Hi ceamac,

Official VirtualBox 7.0.0 Linux packages do not depend on libidl from what I can see. What exactly do you mean?

comment:2 by ceamac, 19 months ago

Hi galitsyn,

It is a build time dependency. I cannot build from sources without having libidl installed. It is used by out/linux.amd64/release/bin/xpidl

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use