VirtualBox

Ticket #21139 (closed defect: fixed)

Opened 4 months ago

Last modified 3 weeks ago

Quickly mouse click-move generates a double click.

Reported by: tutralex Owned by:
Component: guest control Version: VirtualBox 6.1.40
Keywords: Cc:
Guest type: Windows Host type: all

Description

A quick click and movement of the mouse generates a double click. This bug appeared in version 6.1.40 for Windows and Linux and was not observed in version 6.1.38. Tested in guest OS Windows 10 and windows 11.

Change History

comment:1 Changed 4 months ago by tutralex

The bug does not appear in all programs, but is 100% noticeable when you quickly click and move around the desktop: the selection frame appears only after a short pause before moving the cursor.

comment:2 Changed 4 months ago by tutralex

After downgrading to 6.1.38, even with 6.1.40r154048 Guest Additions, there is no problem with the mouse.

comment:3 follow-up: ↓ 5 Changed 4 months ago by galitsyn

Hi tutralex,

Do you observe the issue if you select either PS/2 or USB Mouse as an input Pointing Device in VM settings?

Have you tried VirtualBox 7 in this regard?

comment:4 Changed 4 months ago by rc31

I can confirm this behavior, and going back 6.1.38 fixes this issue.

One of the effects is I cannot rearrange the slides' order with the mouse in Powerpoint. Just tried with VirtualBox 7 and it works fine.

Could this problem in 6.1.40 be caused by: in 6.1.40: Main: Provide guest's absolute pointing mouse device with buttons state when mouse integration is ON?

comment:5 in reply to: ↑ 3 Changed 4 months ago by tutralex

Replying to galitsyn:

Hi tutralex,

Do you observe the issue if you select either PS/2 or USB Mouse as an input Pointing Device in VM settings?

Have you tried VirtualBox 7 in this regard?

  1. I used a USB-mouse in the settings, PS/2 did not check;
  2. VirtualBox 7 does not suit me, it has its own bugs. For example, 3D acceleration does not work correctly with Windows 11 guest. And others...

comment:6 Changed 4 months ago by Vgatto22

I also have the same issue with 6.1.40. Host is Linux Mint 20.3, guest is Windows 10.

comment:7 Changed 4 months ago by galitsyn

I just closed #21162 and #21166 as a duplicate issues of this one. Let's discuss it at one place.

This issue is indeed a regression introduced in 6.1.40. We will come up with the fix in the next 6.1 release.

For now, could you please tell if the issue also is not reproducible with PS/2 mouse selected in VM config? If so, this can be a temporary workaround until final fix. If not, we can provide a test build (signed) which can be used until final fix will be landed.

comment:8 Changed 4 months ago by RendyT

I tested it with PS/2 mouse and it worked. Thx for this workaround.

comment:9 Changed 3 months ago by mgrzegor

I have not observed the double-click bug with PS/2 mouse, either, however I do observe bug #21162 (doubled mouse scroll wheel events) with PS/2 mouse selected in VM config.

With USB tablet selected in VM config (the setting I used in previous VB versions with no trouble), mouse wheel behaves so erratically as to be unusable.

VB 6.1.40, Windows 10 host, Linux guest with xfwm4 window manager.

comment:10 Changed 3 weeks ago by galitsyn

  • Status changed from new to closed
  • Resolution set to fixed

Hello,

We just released VirtualBox 7.0.6 and 6.1.42. This issue should be fixed in these versions. You can download it from https://www.virtualbox.org/wiki/Downloads (or https://www.virtualbox.org/wiki/Download_Old_Builds_6_1 for 6.1 build).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use