VirtualBox

Opened 2 years ago

Closed 8 months ago

Last modified 8 months ago

#20630 closed defect (duplicate)

Sound disappears after second change from Speaker to Bluetooth Headphones on the host

Reported by: boxer01 Owned by: pentagonik
Component: audio Version: VirtualBox 6.1.28
Keywords: sound Bluetooth Cc:
Guest type: Windows Host type: Windows

Description

This is a duplicate of the ticket #20431. The description and the analysis of the issue is already there. The error is here since 4 versions (was caused by the another refactor of sound backend back in the March 2021). It still here in the version 6.1.28 147628 and 6.1.29 147791, so I opened this duplicate.

Quick description here: after the host output device changes from Speaker to Bluetooth, then back to Speaker and then once again to BT, the sound output from VBox is lost. Other application from the host still can use the BT as output, but VBox can only use the Speaker after that. The only remedy is to restart or to save and restore the VM, but this only gives one single more short for the BT. After that the whole situation repeats itself.

Change History (9)

comment:1 by PavloUnn, 2 years ago

@boxer01, it looks like the issue is not bound specifically to Bluetooth devices. It's for any detachable device. I've opened #20723, just in case.

comment:2 by boxer01, 10 months ago

#21517 is followup for version 6.1 and 7.

comment:3 by boxer01, 9 months ago

It's still here in the 6.1.45-158079.

comment:4 by boxer01, 9 months ago

Still here in the 6.1.45-158243.

comment:5 by boxer01, 9 months ago

Still here in the 6.1.46.

comment:6 by boxer01, 8 months ago

Still here in 6.1.47-158685.

comment:7 by pentagonik, 8 months ago

Owner: set to pentagonik
Status: newassigned

comment:8 by pentagonik, 8 months ago

Resolution: duplicate
Status: assignedclosed

Duplicate of #20431.

comment:9 by pentagonik, 8 months ago

Uploaded a new Windows test build 158794 which should contain a fix here [1].

Please let me know if this fixes the issue for you.

[1] https://www.virtualbox.org/download/testcase/VirtualBox-7.0.11-158794-Win.exe

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use