VirtualBox

Opened 15 months ago

Closed 10 months ago

Last modified 10 months ago

#21517 closed defect (duplicate)

Sound not arrive to the second host audio output device after the second change to this second device in version 7.

Reported by: boxer01 Owned by: pentagonik
Component: audio Version: VirtualBox-7.0.6
Keywords: audio lost Cc:
Guest type: Windows Host type: Windows

Description (last modified by boxer01)

I quickly describe the error circumstances: if the host changes from one audio output device to another device and the back to the first one, then after the second change from the first to the second device the sound is lost. In my case from speakers to Bluetooth headphones, but this could be another devices; it's only important, that this should be different host devices. Everything looks fine in the VM, the audio stream is running further, but one can't hear anything. Only after the change back to the first device, the sound can be heard.

This is an old error from 6.1, the tickets with analysis of the error source are already here (#20431, #20723), but the troubles are still present, even in the 7th version. So I open a new ticket for the new version with a hope, that somebody would fix this last issue after the audio backend rewrite about 2 years ago.

I put some current logs here, so it should be clear, what happens in the VM.

This is a followup for #20630.

Attachments (2)

Vbox_7.0.97-155973_Audio.7z (41.9 KB ) - added by boxer01 15 months ago.
Logs of VM with VBox 7, audio should be inside
VBox_7.0.9-158223_aud.7z (230.9 KB ) - added by boxer01 11 months ago.
Logs from version 7.0.9-158223

Download all attachments as: .zip

Change History (19)

by boxer01, 15 months ago

Attachment: Vbox_7.0.97-155973_Audio.7z added

Logs of VM with VBox 7, audio should be inside

comment:1 by boxer01, 15 months ago

Still here in 7.0.97-156054.

comment:2 by boxer01, 15 months ago

Still here in 7.0.7-156262 and 7.0.97-156271. And 6.1.43-156228

comment:3 by boxer01, 15 months ago

See #21545 also.

comment:4 by boxer01, 14 months ago

Still here in 6.1.43-156565.

comment:5 by boxer01, 14 months ago

Still here in 7.0.7-156678 and 7.0.97-156683.

comment:6 by boxer01, 12 months ago

Still here in 7.0.9-157689 and 7.0.97-157682.

Last edited 12 months ago by boxer01 (previous) (diff)

comment:7 by boxer01, 12 months ago

Still here in current 1577xx / 1578xx test builds.

Last edited 12 months ago by boxer01 (previous) (diff)

comment:8 by boxer01, 11 months ago

Description: modified (diff)

comment:9 by pentagonik, 11 months ago

Owner: set to pentagonik
Status: newassigned

comment:10 by boxer01, 11 months ago

It's still here in the 6.1.45-158079, 7.0.9-158070 and 7.0.97-158051.

comment:11 by boxer01, 11 months ago

Still here in 7.0.9-158223 and 6.1.45-158243. I put my current debug logs here. The audio data is here

by boxer01, 11 months ago

Attachment: VBox_7.0.9-158223_aud.7z added

Logs from version 7.0.9-158223

comment:12 by boxer01, 10 months ago

Still here in the 6.1.46 and 7.0.10.

in reply to:  9 comment:13 by boxer01, 10 months ago

Replying to pentagonik:

I put the comment into another ticket (#20431) about possible corrections of this bug. At the end, it isn't some new information, just more detailed information about already known situation. ;-)

comment:14 by boxer01, 10 months ago

Still here in 6.1.47-158685 and 7.0.11-158681.

comment:15 by pentagonik, 10 months ago

Thank you all for the analysis and the detailed reports. This issue has not been forgotten. I'll have a look at this as soon as time permits.

comment:16 by pentagonik, 10 months ago

Resolution: duplicate
Status: assignedclosed

Duplicate of #20431.

comment:17 by pentagonik, 10 months ago

Uploaded a new Windows test build 158794 which should contain a fix here [1].

Please let me know if this fixes the issue for you.

[1] https://www.virtualbox.org/download/testcase/VirtualBox-7.0.11-158794-Win.exe

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use