VirtualBox

Ticket #20627 (new defect)

Opened 11 months ago

Last modified 3 months ago

Failed to load R0 module C:\Program Files\Oracle\VirtualBox/VMMR0.r0: SUP_IOCTL_LDR_OPEN failed (VERR_LDR_GENERAL_FAILURE).

Reported by: ap31415 Owned by:
Component: other Version: VirtualBox 6.1.28
Keywords: Cc:
Guest type: other Host type: Windows

Description

On a Windows 10 Pro host with build 19043.1288, I installed VirtualBox-6.1.28-147628-Win.exe. Trying to run any VM results in the error:

Failed to load R0 module C:\Program Files\Oracle\VirtualBox/VMMR0.r0: SUP_IOCTL_LDR_OPEN failed (VERR_LDR_GENERAL_FAILURE).

Reverting to VirtualBox-6.1.26-145957-Win.exe, everything works fine.

Change History

comment:1 Changed 11 months ago by AndyC

Is this the same as ticket https://www.virtualbox.org/ticket/20624 ?

comment:2 Changed 11 months ago by joejoseph00

I confirm this bug, windows 10 installed v6.1.28 , nothing would work, our windows systems are handicapped and amd-vx is not available for us, not sure if that makes a difference.

I tried disabling all the options, nothing worked with v6.1.28 no virtual machines that I exported from v6.1.26 on an Ubuntu build would work in windows v6.1.28

Solution was found, to downgrade to version v6.1.26 , so I uninstalled v6.1.28 and installed v6.1.26 , since installing v6.1.26 it is working as expected although I still have a limitation of not being able to use amd-vx because someone who set up and locked down the windows build I'm using has the very triste "Memory integrity" option enabled which unfortunately affects amd-vx capabilities , core isolation security features just above that in Windows Security mention this "This setting is managed by your administrator."

The solution for us has been to uninstall Virtualbox v6.1.28 and install Virtualbox v6.1.26

Thank you, I hope this helps others.

comment:3 Changed 10 months ago by Mark2021

I confirm this bug as well. Core isolation is activated by our system administrators and can't be deactivated.

Version 6.1.26 works fine, 6.1.28 and 6.1.30 not.

So if this bug won't be fixed by VirtualBox I got no other chance than using Hyper-V in future...

Replying to AndyC:

Is this the same as ticket https://www.virtualbox.org/ticket/20624 ?

No, this seems not to be the same error.

Last edited 10 months ago by Mark2021 (previous) (diff)

comment:4 Changed 10 months ago by Myron

Same problem here.

comment:5 follow-up: ↓ 6 Changed 10 months ago by fth0

The Windows Hypervisor-enforced Code Integrity (HVCI) feature rejects the VirtualBox component VMMR0.r0 (*). A workaround is to disable HVCI aka Memory integrity as follows:

On your Windows host, go to Start > Settings > Update & security > Windows Security > Device security > Core isolation details, turn off Memory integrity and reboot the Windows host.

(*) In the Windows Event Log, under Applications and Service Logs\Microsoft\Windows\CodeIntegrity\Operational, an event with ID 3111 ("The file under validation did not meet the hypervisor-protected code integrity (HVCI) policy.") is logged.

comment:6 in reply to: ↑ 5 Changed 10 months ago by Mark2021

I know that disabling this feature is a workaround. Unfortunately we cannot disable this feature because it is enabled by our administrators.

And I really don't understand why 6.1.26 doesn't have this problem while in 6.1.28 and 6.1.30 the error occurs; without any changes by Microsoft!

Anyway: I really don't want to change to Hyper-V, but if the problem persist in VirtualBox I got no other possibility...

Last edited 10 months ago by klaus (previous) (diff)

comment:7 Changed 9 months ago by joejoseph00

we're still having this issue with 6.1.30, as mentioned by the others above, our administrators have disabled our ability to change the core isolation settings.

The only solution for our situation is to downgrade to virtualbox 6.1.26

so both 6.1.28 and 6.1.30 have this bug

6.1.26 works when configured correctly. No configuration option was working in 6.1.30 or 6.1.28 due to our core isolation settings being locked by administrators.

comment:8 Changed 9 months ago by Mark2021

Because problem still persists and no one seems to find a solution I changed to Hyper-V. If you got Windows as host-system I strongly recommend to do the same. Among other things the performance is much better...

comment:9 Changed 8 months ago by bird

6.1.32 should work better. Please try.

comment:10 Changed 8 months ago by ap31415

I can confirm that this bug is solved for me when using 6.1.32.

comment:11 follow-up: ↓ 12 Changed 3 months ago by adrelanos

Is this done? Should this ticket be closed?

comment:12 in reply to: ↑ 11 Changed 3 months ago by fth0

Replying to adrelanos:

Is this done? Should this ticket be closed?

Yes. Yes. :)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use