VirtualBox

Ticket #20624 (closed defect: fixed)

Opened 13 months ago

Last modified 12 months ago

VirtualBox v6.1.28 shows "Failed to open a session for the virtual machine ... Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED). Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}" in 64-bit W10...

Reported by: Ant Owned by:
Component: other Version: VirtualBox 6.1.28
Keywords: Cc:
Guest type: all Host type: Windows

Description

Others and I are seeing this in my detailed  https://forums.virtualbox.org/viewtopic.php?f=6&t=104175 forum thread with logs and comments. We had no problems in v6.1.26. VB kept showing this after starting a guest VM:

"Failed to open a session for the virtual machine ...

Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}".

They last worked on a couple days ago too in v6.1.26 before upgrading to v6.1.28. I already tried rebooting, repairing, etc. I was forced to downgrade back to v6.1.26. Attached and  http://zimage.com/~ant/temp/AntsVirtualBox6.1.zip for my VB settings and logs.

Thank you for reading and hopefully answering soon. :)

Attachments

AntsVirtualBox6.1.zip Download (86.0 KB) - added by Ant 13 months ago.

Change History

Changed 13 months ago by Ant

comment:1 Changed 13 months ago by AndyC

VB version update:

VB 6.1.29r147791 has the issue. VB 6.1.97r147788 now has the issue. VB 6.1.97r147373 does not exhibit the issue.

So now all of the stable and test builds are failing.

comment:2 Changed 13 months ago by Dominiquini

comment:3 Changed 13 months ago by Nicol Gong

I have the same problem when I upgrade to 6.1.28, so I back to 6.1.26. I guess the bug is very common and is critical.

comment:4 follow-ups: ↓ 11 ↓ 12 Changed 13 months ago by Huub

Have seen the issue before. It must have been late 2019 / early 2020

When Microsoft released WSL on windows10. I wanted to play around with that also. Can't help it since I started with Unix in 1976 or so. So I enabled the Microsoft way the VM, did some other instructions and loaded Ubuntu in WSL. Experimented with an X11-server and got commands like gedit and firefox working.

Then I wanted to update my Ubuntu platform inside Virtual box which I did run in Windows 10. Then some error like this occured. Conclusion at that time: WSL and Virtual Box cannot run concurrently on Windows 10!

When I wanted to run WSL (with Ubuntu) I had to instruct Windows with 'bcdedit /set hypervisorlaunchtype auto' and reboot my computer. When I wanted to work with VirutalBox (ubuntu) I had to run 'bcdedit /set hypervisorlaunchtype off'.

Many people reported the issie and a few months later a new version of VirutalBox appeared and I could run WSL and VirtualBox concurrently! With the upgrade last week to VirtualBox 6.1.28 I (again) cannot use both concurrently! Ultimately I downgraded to 6.1.26 as you can imagine.

My laptop is a Asus X580VD i70-7700HQ with GTX1050 graphics and 16Gb RAM. Standard OS is Windows 10 21H1 fully loaded with all patches/updates.

comment:5 follow-up: ↓ 6 Changed 13 months ago by riramar

Same problem here. Disabling the Hyper-V wouldn't turn the VMs very slow?

comment:6 in reply to: ↑ 5 Changed 13 months ago by Huub

Replying to riramar:

Same problem here. Disabling the Hyper-V wouldn't turn the VMs very slow?

It is a bit slower. Primarily starting up, once Ubuntu is booted (in VirtualBox) I really don't notice a big loss in performance. My pc has an i7-7700HQ CPU and 16Gb RAM along SSD disk.

Last edited 13 months ago by Huub (previous) (diff)

comment:7 Changed 13 months ago by effrafax

Same here with 6.1.28 r147628 The version I had before, worked well together with WSL

comment:8 Changed 13 months ago by repe

I have the same problem after updating from 6.1.26 to 6.1.28 I revert back to 6.1.26 to keep using my vms 6.1.28 has the bug I do not recommend you to update until the issue is reported as fixed

comment:9 Changed 13 months ago by RikoNaka

Same problem here. When will the new version come out?

comment:10 Changed 13 months ago by klaus

The fix is available in the latest 6.1 test build. Please read the note in section "Installing Windows test builds" regarding secure boot.

comment:11 in reply to: ↑ 4 Changed 13 months ago by nosni

Replying to Huub:

When I wanted to run WSL (with Ubuntu) I had to instruct Windows with 'bcdedit /set hypervisorlaunchtype auto' and reboot my computer. When I wanted to work with VirutalBox (ubuntu) I had to run 'bcdedit /set hypervisorlaunchtype off'.

This also worked for me right now. Sadly I will also have to downgrade as Virtualbox does not work with WSL :(

comment:12 in reply to: ↑ 4 Changed 13 months ago by nosni

Replying to Huub:

When I wanted to run WSL (with Ubuntu) I had to instruct Windows with 'bcdedit /set hypervisorlaunchtype auto' and reboot my computer. When I wanted to work with VirutalBox (ubuntu) I had to run 'bcdedit /set hypervisorlaunchtype off'.

This also worked for me right now. Sadly I will also have to downgrade as Virtualbox does not work with WSL :(

comment:13 Changed 13 months ago by jimbar

Same issue for me. Back to 6.1.26 I couldnt even start VMs after disabling hyper-v and WSL and reinstalling 6.1.28

comment:15 follow-up: ↓ 17 Changed 13 months ago by twini

Just downloaded the 6.1.29-148084 version and still got the error. I tried with many different settings on "Paravirtualization interface" but still fails...

3638.3494: Error opening VBoxDrvStub: STATUS_OBJECT_NAME_NOT_FOUND 3638.3494: supR3HardenedWinReadErrorInfoDevice: NtCreateFile -> 0xc0000034 3638.3494: Error -101 in supR3HardenedWinReSpawn! (enmWhat=3) 3638.3494: NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries)

Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help. 1b7c.1458: supR3HardenedWinCheckChild: enmRequest=2 rc=-101 enmWhat=3 supR3HardenedWinReSpawn: NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries)

Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help. 3638.3494: KiUserExceptionDispatcher: 0xc0000005 (0000000000000001, 0000000000000024) @ 00007ffb282d3416 (flags=0x0)

rax=0000000000000000 rbx=00007ffb283da3c0 rcx=00007ffb283da3c0 rdx=00000000fffffffa rsi=0000000000000000 rdi=00007ffb283da000 r8 =0000000000000000 r9 =00007ffb283da300 r10=0000000000000000 r11=00000000004f8e80 r12=0000000000000000 r13=000000000036f000 r14=0000000000000001 r15=0000000000000000 P1=0000000000000000 P2=0000000000000000 rip=00007ffb282d3416 rsp=00000000004f8ce0 rbp=00000000ffffff00 ctxflags=0010005f cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b eflags=00010213 mxcrx=00001f80

P3=0000000000000000 P4=0000000000000000 P5=0000000000000000 P6=0000000000000000

dr0=0000000000000000 dr1=0000000000000000 dr2=0000000000000000 dr3=0000000000000000 dr6=0000000000000000 dr7=0000000000000000 vcr=0000000000000000 dcr=0000000000000000 lbt=0000000000000000 lbf=0000000000000000 lxt=0000000000000000 lxf=0000000000000000

When i try to run the service with :

sc start vboxdrv

i got an error that says that windows can't verify the signature so he won't start the service.

I went to the bios and got disabled "secure boot" and now it works, finally. Guess it's a build test issue and the release build will fix this, cause i can't permanently disable secure boot.

Thanks.

comment:16 follow-up: ↓ 18 Changed 13 months ago by ThribsClube

  • Status changed from new to awaitsfeedback

Had the same problem trying to fire up a Windows 11 VM. Can't disable Hyper-V because of WSL2. Downgrading to 6.1.26 solved it. Hoping it gets fixed soon.

comment:17 in reply to: ↑ 15 Changed 13 months ago by AndyC

Replying to twini:

Just downloaded the 6.1.29-148084 version and still got the error. I tried with many different settings on "Paravirtualization interface" but still fails...

3638.3494: Error opening VBoxDrvStub: STATUS_OBJECT_NAME_NOT_FOUND 3638.3494: supR3HardenedWinReadErrorInfoDevice: NtCreateFile -> 0xc0000034 3638.3494: Error -101 in supR3HardenedWinReSpawn! (enmWhat=3) 3638.3494: NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries)

Next time please read the original bug post as this is a different BUG.

comment:18 in reply to: ↑ 16 Changed 13 months ago by AndyC

Replying to ThribsClube:

Had the same problem trying to fire up a Windows 11 VM. Can't disable Hyper-V because of WSL2. Downgrading to 6.1.26 solved it. Hoping it gets fixed soon.

Next time please post in the forum if your issue is not directly related to the original bug reported.

comment:19 follow-up: ↓ 20 Changed 13 months ago by AdamPressman

The VirtualBox-6.1.97-148162-Win.exe build worked for me to get past the error. at https://www.virtualbox.org/download/testcase/VirtualBox-6.1.29-148164-Win.exe

comment:20 in reply to: ↑ 19 Changed 12 months ago by mareks

Replying to AdamPressman:

The VirtualBox-6.1.97-148162-Win.exe build worked for me to get past the error. at https://www.virtualbox.org/download/testcase/VirtualBox-6.1.29-148164-Win.exe

I can confirm too, I had the original error with 6.1.28, testbuild 148164 fixed it for me. Thanks!

Last edited 12 months ago by mareks (previous) (diff)

comment:21 Changed 12 months ago by klaus

Thanks for the confirmations... hope we can tick this off soon in an official release.

comment:22 Changed 12 months ago by AndyC

BTW the 6.1.97-148372 is now usable on my setup and also has the fix. Previous 6.1.97 versions ran like a dog on my setup.

comment:23 Changed 12 months ago by klaus

6.1.97 are development versions of the "after 6.1" time, so the "use with caution" rule applies. Normally it's better to use a 6.1 test build.

comment:24 Changed 12 months ago by klaus

  • Status changed from awaitsfeedback to new

comment:25 Changed 12 months ago by Huub

Just downloaded and installed Version 6.1.30 r148432 (Qt5.6.2) and can confirm now that things do work as expected again. Great work Vbox team! Thanks very much resolving this.

comment:26 Changed 12 months ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use