VirtualBox

Ticket #19885 (closed defect: fixed)

Opened 16 months ago

Last modified 14 months ago

Virtual Box 6.1.14 crashes as soon as microphone is captured by the guest

Reported by: TheMinstrel Owned by:
Component: audio Version: VirtualBox 6.1.14
Keywords: crash microphone capture sound Cc:
Guest type: Windows Host type: Mac OS X

Description

Hi there!

I am running Virtual Box version 6.1.14 with a Windows 10 guest and Mac OS 10.15.6 as the host on a MacBook Pro 2020. As soon as I open any app which requires the guest to capture sound from the microphone, the entire virtual machine crashes. I was able to reproduce the bug easily by opening Audacity in the guest as well as a conference chatting software called Teamtalk. However, it also crashes if I open up the Sounds pain in Windows Control Panel and navigate to the recording tab. Doing so is meant to activate the microphone in order to show a VU meter showing how the sound levels are. I found a similar bug report, ticket #19758 which spoke of a crash which happens when the webcam does not ask for permission from the host to be captured, and I will post a link which takes you to the Apple Developers page which shows how to properly ask for permission for microphone capture. I believe doing this will solve the crash issue.

 https://developer.apple.com/documentation/avfoundation/cameras_and_media_capture/requesting_authorization_for_media_capture_on_macos

Thank you for reading, and I hope this will help you solve the issue. If anything else is required of me, I look forward to providing assistance and more information. Attached below, (assuming I can figure out how to do it) will be a log in which I started up the VM and navigated to Control Panel and opened up the recording tab in the Sounds pain.

Best regards, Mario

Attachments

Mario's Windows 10 Home-2020-09-06-20-57-46.log Download (93.8 KB) - added by TheMinstrel 16 months ago.
In this log, I started my virtual machine, typed in my password for my windows guest, typed "Control Panel" into the start menu search box, and navigated to "Sound." As soon as I navigated to the "Recording" tab, the virtual machine crashed.

Change History

Changed 16 months ago by TheMinstrel

In this log, I started my virtual machine, typed in my password for my windows guest, typed "Control Panel" into the start menu search box, and navigated to "Sound." As soon as I navigated to the "Recording" tab, the virtual machine crashed.

comment:1 Changed 14 months ago by paulson

  • Status changed from new to closed
  • Resolution set to fixed

You've run into a regression in VirtualBox 6.1.14 which affects macOS hosts which is related to audio input permissions. This last line in the VBox.log is one of the key indicators:

00:02:44.342181 CoreAudio: macOS 10.14+ detected, checking audio input permissions

The root cause is the same as the issue described in ticket #19758. The good news is that this has been fixed now in VirtualBox 6.1.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use