VirtualBox

Ticket #19884 (closed defect: fixed)

Opened 15 months ago

Last modified 8 months ago

Ubuntu 20.04 GUI does not start with Hyper-V backend and 3D acceleration => fixed SVN/next maintenance

Reported by: tysonite Owned by:
Component: 3D support Version: VirtualBox 6.1.14
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

After a fix made in https://www.virtualbox.org/ticket/19695#comment:22, VirtualBox test build 6.1.15 r140284 succesfully installs Ubuntu 20.04 (3D acceleration disabled), and it can be started and running well.

If on a previously installed VM, enable 3D accelaration - Ubuntu 20.04 boots up, but GUI does not start, only text console is available.

dmesg contains general protection fault of vmwgfx_dri.so. See attached picture.

Environment:

  • Host: Windows 10 Pro, 2004, Build = 19041.508
  • Paravirtualizarion Interface: Hyper-V
  • Guest: Ubuntu 20.04

Attachments

protection_fault.png Download (35.5 KB) - added by tysonite 15 months ago.
DriverProtection fault
vboxhardening.log Download (398.4 KB) - added by tysonite 15 months ago.
vbox.log Download (85.7 KB) - added by tysonite 15 months ago.
vbox.log.1 Download (186.6 KB) - added by tysonite 15 months ago.

Change History

Changed 15 months ago by tysonite

DriverProtection fault

Changed 15 months ago by tysonite

Changed 15 months ago by tysonite

Changed 15 months ago by tysonite

comment:1 Changed 15 months ago by aeichner

  • Summary changed from Ubuntu 20.04 GUI does not start with Hyper-V backend and 3D acceleration to Ubuntu 20.04 GUI does not start with Hyper-V backend and 3D acceleration => fixed SVN/next maintenance

Will be fixed in the next maintenance release, thanks for the report!

comment:2 Changed 15 months ago by klaus

The Testbuilds page has Windows packages which include the fix since today (r140351 and later).

comment:3 Changed 15 months ago by klaus

  • Status changed from new to awaitsfeedback

comment:4 Changed 15 months ago by tysonite

It works with 140351. Thanks!

comment:5 Changed 13 months ago by arudnev

  • Status changed from awaitsfeedback to closed
  • Resolution set to fixed

Fixed in 6.1.16

comment:6 Changed 10 months ago by sergiomb

comment:8 Changed 8 months ago by sergiomb

We (Fedora people) found a big regression on mesa-20.3.x and mesa-21.0.x , as VirtualBox use vmware video drive by default , also applies to VirtualBox guests vms on Linux .

About Bi-directional Copy/Paste also I'm seeing problems but I don't know what is it .

 https://src.fedoraproject.org/rpms/mesa/c/5e07467adaf8ecdc4c2b783171f4c357c99dd8db?branch=f33

 https://bodhi.fedoraproject.org/updates/?packages=mesa

  • Mon Feb 22 2021 Dave Airlie <airlied@…> - 21.0.0~rc5-2
  • fix sddm/vmware regression
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use