VirtualBox

Ticket #190 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Virtualbox crash in glibc memory corruption

Reported by: tonyric Owned by:
Priority: critical Component: other
Version: VirtualBox 1.3.6 Keywords:
Cc: Guest type: other
Host type: other

Description

I have experienced this problem regularly when running a WindowsXP guest hard. This will typically happen when I am syncing my ipod with iTunes.

System: Dell Latitude D820 2GHz Core Duo 4GB RAM 100GB 7200RPM HDD Broadcom GigE Network Intel 3945 wireless (K)Ubuntu Edgy 6.10 fully patched with both the 2.6.17-10 and the 2.6.17-11 kernels

tony@charlie:~$ * glibc detected * /opt/VirtualBox-1.3.6/VirtualBox: malloc(): memory corruption (fast): 0x0838633f * ======= Backtrace: ========= /lib/tls/i686/cmov/libc.so.6[0xb643c88f] /lib/tls/i686/cmov/libc.so.6(malloc+0x7f)[0xb643d83f] /usr/lib/libqt-mt.so.3(_ZN7QGArrayC2Ei+0x8e)[0xb7cfeba0] /usr/lib/libqt-mt.so.3(_ZN9QMemArrayI5QRectEC1Ei+0x27)[0xb796a323] /usr/lib/libqt-mt.so.3(_ZN14QRegionPrivateC1ERK5QRect+0x28)[0xb796a360] /usr/lib/libqt-mt.so.3(_ZN7QRegionC1ERK5QRectNS_10RegionTypeE+0x135)[0xb79697b1] /usr/lib/libqt-mt.so.3(_ZN7QWidget6updateEiiii+0xc5)[0xb796ed35] /opt/VirtualBox-1.3.6/VirtualBox[0x8150676] /opt/VirtualBox-1.3.6/components/VBoxC.so(_ZN7Display19handleDisplayUpdateEiiii+0xdd)[0xb4e6647d] /opt/VirtualBox-1.3.6/components/VBoxC.so(_ZN7Display15VideoAccelFlushEv+0x18c)[0xb4e666cc] /opt/VirtualBox-1.3.6/VBoxDD.so[0x9307a4b5] /opt/VirtualBox-1.3.6/VBoxVMM.so[0xb681f7cb] /opt/VirtualBox-1.3.6/VBoxVMM.so(TMR3TimerQueuesDo+0x73)[0xb681f883] /opt/VirtualBox-1.3.6/VBoxVMM.so(VMR3WaitHalted+0x70)[0xb681b090] /opt/VirtualBox-1.3.6/VBoxVMM.so(EMR3ExecuteVM+0x76b)[0xb683b54b] /opt/VirtualBox-1.3.6/VBoxVMM.so(_Z19vmR3EmulationThreadP11RTTHREADINTPv+0xb1)[0xb681af41] /opt/VirtualBox-1.3.6/VBoxRT.so(rtThreadMain+0x41)[0xb75ee0f1] /opt/VirtualBox-1.3.6/VBoxRT.so[0xb75f694c] /lib/tls/i686/cmov/libpthread.so.0[0xb7621504] /lib/tls/i686/cmov/libc.so.6(clone+0x5e)[0xb64a251e] ======= Memory map: ======== 08048000-081dd000 r-xp 00000000 08:01 9847322 /opt/VirtualBox-1.3.6/VirtualBox 081dd000-081e0000 rw-p 00195000 08:01 9847322 /opt/VirtualBox-1.3.6/VirtualBox 081e0000-0895a000 rw-p 081e0000 00:00 0 [heap] 9180e000-91890000 rw-p 9180e000 00:00 0 91890000-91912000 rw-p 91890000 00:00 0 91912000-91994000 rw-p 91912000 00:00 0 91994000-91a16000 rw-p 91994000 00:00 0 91a16000-91a98000 rw-p 91a16000 00:00 0 91a98000-91c7e000 rw-s 00000000 00:08 883982338 /SYSV00000000 (deleted) 91c7e000-91ece000 rw-p 91c7e000 00:00 0 91ece000-91ee9000 rw-p 91ece000 00:00 0 91ee9000-91f00000 ---p 91ee9000 00:00 0 91f00000-92100000 rw-p 91f00000 00:00 0 92100000-9213a000 rw-p 92100000 00:00 0 9213a000-92141000 rw-p 9213a000 00:00 0 92141000-92200000 rw-p 92141000 00:00 0 92272000-92273000 ---p 92272000 00:00 0 92273000-92293000 rwxp 92273000 00:00 0 92293000-922bc000 rw-p 92293000 00:00 0 922bc000-92328000 r--p 00000000 08:01 10813573 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf 92328000-92351000 rw-p 92328000 00:00 0 92351000-92352000 ---p 92351000 00:00 0 92352000-92372000 rwxp 92352000 00:00 0 92372000-92f76000 rw-p 92372000 00:00 0 92f76000-92f7b000 r-xp 00000000 08:01 9847319 /opt/VirtualBox-1.3.6/VBoxSharedFolders.so 92f7b000-92f7c000 rw-p 00005000 08:01 9847319 /opt/VirtualBox-1.3.6/VBoxSharedFolders.so 92f7e000-92f7f000 ---p 92f7e000 00:00 0 92f7f000-92f9f000 rwxp 92f7f000 00:00 0 92f9f000-93021000 rw-p 92f9f000 00:00 0 93021000-93042000 r-xp 00000000 08:01 9847328 /opt/VirtualBox-1.3.6/VBoxDD2.so 93042000-93043000 rw-p 00020000 08:01 9847328 /opt/VirtualBox-1.3.6/VBoxDD2.so 93043000-930c2000 r-xp 00000000 08:01 9847321 /opt/VirtualBox-1.3.6/VBoxDD.so 930c2000-930c5000 rw-p 0007f000 08:01 9847321 /opt/VirtualBox-1.3.6/VBoxDD.so 930c5000-9310e000 rw-p 930c5000 00:00 0 9310e000-9314b000 rw-p 9310e000 00:00 0 9314b000-9314c000 rwxp 9314b000 00:00 0 9314c000-93191000 rw-p 9314c000 00:00 0 93191000-93399000 rw-p 93191000 00:00 0 93399000-9339b000 rwxs 00000000 00:08 76910 /dev/zero (deleted) 9339b000-9339c000 ---p 9339b000 00:00 0 9339c000-9341c000 rwxp 9339c000 00:00 0 9341c000-9343d000 rw-p 9341c000 00:00 0 9343d000-93540000 rw-p 9343d000 00:00 0 93540000-b36c3000 rw-p 93540000 00:00 0 b36c3000-b36c4000 rwxp b36c3000 00:00 0 b36c4000-b36f9000 rw-p b36c4000 00:00 0 b36f9000-b377b000 rw-p b36f9000 00:00 0 b377b000-b379b000 rwxs 00000000 00:08 76909 /dev/zero (deleted) b379b000-b379d000 rwxs 00000000 00:08 76908 /dev/zero (deleted) b379d000-b37a0000 rwxs 00000000 00:08 76907 /dev/zero (deleted) b37a0000-b37a1000 rwxs 00000000 00:08 76906 /dev/zero (deleted) b37a1000-b37a2000 rwxs 00000000 00:08 76905 /dev/zero (deleted) b37a2000-b37a3000 rwxs 00000000 00:08 76904 /dev/zero (deleted) b37a3000-b38e5000 rw-p b37a3000 00:00 0 b38e5000-b38e6000 ---p b38e5000 00:00 0 b38e6000-b39e6000 rwxp b38e6000 00:00 0 b39e6000-b3a00000 rwxs 00000000 00:08 76903 /dev/zero (deleted) b3a00000-b3a98000 rw-p b3a00000 00:00 0 b3a98000-b3aaa000 rw-p b3a98000 00:00 0 b3aaa000-b3abd000 rw-p b3aaa000 00:00 0 b3abd000-b3acf000 rw-p b3abd000 00:00 0 b3acf000-b3ae9000 rw-p b3acf000 00:00 0 b3ae9000-b3af4000 rw-p b3ae9000 00:00 0 b3af4000-b3b00000 ---p b3af4000 00:00 0 b3b10000-b3b11000 ---p b3b10000 00:00 0 b3b11000-b3b91000 rwxp b3b11000 00:00 0 b3b91000-b3b9a000 r-xp 00000000 08:01 2326614 /lib/tls/i686/cmov/libnss_files-2.4.so b3b9a000-b3b9c000 rw-p 00008000 08:01 2326614 /lib/tls/i686/cmov/libnss_files-2.4.so b3b9c000-b3ba4000 r-xp 00000000 08:01 2326618 /lib/tls/i686/cmov/libnss_nis-2.4.so b3ba4000-b3ba6000 rw-p 00007000 08:01 2326618 /lib/tls/i686/cmov/libnss_nis-2.4.so b3ba6000-b3bad000 r-xp 00000000 08:01 2326610 /lib/tls/i686/cmov/libnss_compat-2.4.so b3bad000-b3baf000 rw-p 00006000 08:01 2326610 /lib/tls/i686/cmov/libnss_compat-2.4.so b3bdb000-b3c5d000 rw-p b3bdb000 00:00 0 b3c5d000-b3cce000 r--p 00000000 08:01 10813577 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf b3cce000-b3cf8000 r-xp 00000000 08:01 10571530 /usr/lib/libkdefx.so.4.2.0 b3cf8000-b3cf9000 rw-p 00029000 08:01 10571530 /usr/lib/libkdefx.so.4.2.0 b3cf9000-b3d17000 r-xp 00000000 08:01 10650303 /usr/lib/kde3/plugins/styles/plastik.so b3d17000-b3d18000 rw-p 0001e000 08:01 10650303 /usr/lib/kde3/plugins/styles/plastik.so b3d18000-b3d42000 r-xp 00000000 08:01 10569670 /usr/lib/liblcms.so.1.0.15 b3d42000-b3d43000 rw-p 00029000 08:01 10569670 /usr/lib/liblcms.so.1.0.15 b3d43000-b3d46000 rw-p b3d43000 00:00 0 b3d46000-b3db1000 r-xp 00000000 08:01 10569701 /usr/lib/libmng.so.1.1.0.9 b3db1000-b3db4000 rw-p 0006a000 08:01 10569701 /usr/lib/libmng.so.1.1.0.9 b3db6000-b3dc8000 r-xp 00000000 08:01 2326608 /lib/tls/i686/cmov/libnsl-2.4.so b3dc8000-b3dca000 rw-p 00011000 08:01 23266

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by sandervl73

What about 1.3.8?

comment:2 in reply to: ↑ 1 Changed 7 years ago by tonyric

Replying to sandervl73:

What about 1.3.8?

Crash happens in 1.3.8 as well. What I have found is that the crash does not occur using VBoxSDL.

Tony

comment:3 Changed 7 years ago by michael

Using certain KDE styles is known to produce similar crashes - I get it when the Plastik style and Crystal window decorations are selected (the default in (K)Ubuntu). Try changing those and seeing if the crash still occurs.

comment:4 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #173.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use