VirtualBox

Ticket #173 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Termination of VM - glibc - malloc(): memory corruption

Reported by: pablo Owned by:
Priority: critical Component: other
Version: VirtualBox 1.3.6 Keywords: memory corruption malloc() glibc openSUSE 10.2
Cc: Guest type: other
Host type: other

Description

Occasionally my VM will crash with a "memory corruption" error.

I've had the termination while working in the VM (say surfing) or when it's been sitting idle on a different desktop.

Environment ===========

  • openSUSE 10.2
  • 2.6.18.2-34-default
  • kernel compiled with: CONFIG_USB_DEVICEFS=y

Attachments

VBoxSVC.log Download (17.7 KB) - added by pablo 7 years ago.
VBoxSVC.2.log Download (17.7 KB) - added by pablo 7 years ago.
second abort
VBoxSVC.3.log Download (21.4 KB) - added by JackR 7 years ago.

Change History

Changed 7 years ago by pablo

comment:1 Changed 7 years ago by pablo

Howdy,

I had another abort this morning, I'm uploading the log file in case it's helpful.

I won't upload any more unless requested.

Changed 7 years ago by pablo

second abort

Changed 7 years ago by JackR

comment:2 Changed 7 years ago by JackR

Hi,

I get these crashes also (using host Ubuntu with the 1.3.8 Edgy binary and Win 2000 and XP guests). It makes VirtualBox very unstable, crashing about 4 times a day here. I hope this problem can be fixed.

Cheers!

comment:3 Changed 7 years ago by michael

Thanks for the error reports. Could you try to reproduce the crashes using the VBoxSDL front end and/or another KDE style plugin?

comment:4 Changed 7 years ago by pablo

Hi Michael,

I've started a test with VBoxSDL. I'll post results within a few days.

Thank you.

comment:5 Changed 7 years ago by JackR

Thanks Michael. No crashes at all today running with VBoxSDL. I'll keep a close eye over the coming days.

comment:6 Changed 7 years ago by pablo

Just an update, using VBoxSDL, I haven't had a problem with core dumps.

comment:7 Changed 7 years ago by michael

Pablo,

Would you also be able to try with other KDE style plugins (i.e. the Plastik, Keramik, KDE Classic things)? Thanks!

comment:8 Changed 7 years ago by pablo

Hi Michael,

I think you're asking to try 'VirtualBox' in the other styles and see if it works okay? I did switch styles earlier in the week but was continuing to use VBoxSDL'

Let me know.

Cheers

comment:9 Changed 7 years ago by michael

That's what I meant. Sorry that I wasn't clear enough. Cheers there.

comment:10 Changed 7 years ago by pablo

Hi Michael,

No problem. English is so ambiguous! :)

I'm starting the test now.

Cheers

comment:11 Changed 7 years ago by sdennie

I've been having this problem as well. On a newly installed Ubuntu 6.10 machine (using the .deb from this site), I was getting aborts about once an hour. Using, VBoxSDL shows that the software is actually rock solid (and very, very fast) but, the fact that the default gui causes it to crash randomly randomly in the UI lib (QT) is frustrating. Is there any way I can help? I'd include a bug report but, I believe it to be nearly identical to what has already been posted. I'm going to test it out in KDE rather than gnome and will post the details if that helps at all.

comment:12 Changed 7 years ago by pablo

Hi Sdennie,

I have been meaning to update this bug; ever since changing to a different them (plastik), I have not had the problem.

Cheers,

comment:13 Changed 7 years ago by michael

#190 is a duplicate of this bug.

comment:14 Changed 7 years ago by michael

#197 is probably a duplicate of this bug.

comment:15 follow-up: ↓ 16 Changed 7 years ago by OxoTnicK

I have the same problem. host ubuntu7.04, guest winXP

comment:16 in reply to: ↑ 15 Changed 7 years ago by michael

Again, try changing your default Qt/KDE style as mentioned above in the bug. There is a tool (I can't remember its name) to do this if you are using a Gnome desktop. I'm pretty sure that this is a bug in the default style installed by Ubuntu.

comment:17 Changed 7 years ago by frank

We believe we fixed this issue in svn. Please retry with svn or with the next release of VirtualBox (1.4.2).

comment:18 Changed 7 years ago by sdennie

I just had this happen to me again with a fairly recent svn version (about 1 week old). It doesn't crash often but, it still appears to be crashing based on widget styles. I downloaded kcontrol and changed the KDE theme to Plastik long ago and still have the problem (This is Ubuntu 7.04 with XP host). The memory map section of the core dump doesn't look very interesting but I can post it as well if you want.

* glibc detected * /home/sdennie/src/vbox/out/linux.x86/release/bin/VirtualBox: malloc(): memory corruption (fast): 0x083bde2e * ======= Backtrace: ========= /lib/tls/i686/cmov/libc.so.6[0xb58716fc] /lib/tls/i686/cmov/libc.so.6(libc_malloc+0x7e)[0xb587260e] /usr/lib/libqt-mt.so.3(_ZN7QGArrayC2Ei+0x8e)[0xb7d23ae8] /usr/lib/libqt-mt.so.3(_ZN9QMemArrayI5QRectEC1Ei+0x27)[0xb798f1fb] /usr/lib/libqt-mt.so.3(_ZN14QRegionPrivateC1ERK5QRect+0x28)[0xb798f238] /usr/lib/libqt-mt.so.3(_ZN7QRegionC1ERK5QRectNS_10RegionTypeE+0x135)[0xb798e689] /usr/lib/libqt-mt.so.3(_ZN7QWidget6updateEiiii+0xc5)[0xb7993c0d] /home/sdennie/src/vbox/out/linux.x86/release/bin/VirtualBox[0x81927e6] /home/sdennie/src/vbox/out/linux.x86/release/bincomponents/VBoxC.so[0xb40d7705] /home/sdennie/src/vbox/out/linux.x86/release/bincomponents/VBoxC.so[0xb40d79e8] /home/sdennie/src/vbox/out/linux.x86/release/bincomponents/VBoxC.so[0xb40d89f9] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxDD.so[0xb32c6dc5] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxVMM.so[0xb5d60e2b] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxVMM.so(TMR3TimerQueuesDo+0x194)[0xb5d61004] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxVMM.so[0xb5d5a27a] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxVMM.so(VMR3WaitHalted+0xde)[0xb5d59fde] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxVMM.so(EMR3ExecuteVM+0x5df)[0xb5d7e61f] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxVMM.so[0xb5d59c5d] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxRT.so[0xb76c91e1] /home/sdennie/src/vbox/out/linux.x86/release/bin/VBoxRT.so[0xb76d220a] /lib/tls/i686/cmov/libpthread.so.0[0xb5bf531b] /lib/tls/i686/cmov/libc.so.6(clone+0x5e)[0xb58d857e]

comment:19 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Retry with 1.5.0 please. This report is too old.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use