VirtualBox

Ticket #1891 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

VB doesn't handle custom keyboard layouts (xmodmap) -> duplicate of #2595

Reported by: Decroix Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.2 Keywords: keyboard input xmodmap
Cc: Guest type: other
Host type: Linux

Description

VirtualBox cannot handle a custom keyboard layout by xmodmap. When entering characters, "abcde..." becomes "anihd...". Attached is the VBox log and the xmodmaprc I'm using. If xmodmap is not invoked, everything is peachy.

Attachments

VBox.log Download (35.1 KB) - added by Decroix 6 years ago.
xmodmaprc Download (9.4 KB) - added by Decroix 6 years ago.
X11 keyboard layout
VBox.2.log Download (36.3 KB) - added by Decroix 6 years ago.
1.6.4 log file
VBox.3.log Download (34.2 KB) - added by Decroix 6 years ago.
1.6.4 log file, no xmodmap
.Xmodmap Download (924 bytes) - added by jon_eliot 4 years ago.
xmodmap, causes malfunction on Ubuntu Karmic 64bit

Change History

Changed 6 years ago by Decroix

Changed 6 years ago by Decroix

X11 keyboard layout

comment:1 follow-up: ↓ 2 Changed 6 years ago by michael

Please retry with VirtualBox 1.6.4.

comment:2 in reply to: ↑ 1 Changed 6 years ago by Decroix

Replying to michael:

The problem persists in 1.6.4.

comment:3 follow-up: ↓ 4 Changed 6 years ago by michael

Could you include a log file from 1.6 please?

Changed 6 years ago by Decroix

1.6.4 log file

comment:4 in reply to: ↑ 3 Changed 6 years ago by Decroix

Replying to michael:

Could you include a log file from 1.6 please?

I certainly can. Log attached.

comment:5 follow-up: ↓ 6 Changed 6 years ago by michael

Are you using any non-standard keyboard setup? In this case, non-standard means anything other than a PC keyboard used locally on a PC compatible machine. And was the log you posted with or without your custom layout? If it was with it, could you please post a log taken using your normal layout? Thanks very much!

comment:6 in reply to: ↑ 5 Changed 6 years ago by Decroix

Replying to michael:

Are you using any non-standard keyboard setup?

No, it's a pretty standard Logitech USB cordless something on a regular PC.

And was the log you posted with or without your custom layout?

With custom layout. Clean log coming up.

Changed 6 years ago by Decroix

1.6.4 log file, no xmodmap

comment:7 Changed 6 years ago by Decroix

Btw, does it only happen to me ? I figured, as this is new software (at least it is to me) that there were some kinks that wasn't quite ironed out yet ..... but is that actually the case ?

comment:8 follow-up: ↓ 9 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from VB doesn't handle custom keyboard layouts (xmodmap) to VB doesn't handle custom keyboard layouts (xmodmap) => fixed in next version

Your layout reversed Ctrl and Caps. This should be fixed in the next version.

comment:9 in reply to: ↑ 8 Changed 6 years ago by Decroix

Replying to michael:

Your layout reversed Ctrl and Caps. This should be fixed in the next version.

That is awesome, I'll be looking forward to that ! Thanks a lot for your attention !

comment:10 Changed 6 years ago by jon

  • Status changed from closed to reopened
  • Resolution fixed deleted

After updating to VirtualBox 2.0 this is not working for me anymore. I have a the Ctrl and Caps key switched on my keyboard using xmodmap on Ubuntu 8.04-Host, the behavior in VirtualBox now is that both, Caps-lock and Ctrl are placed at the Ctrl-key. I assume the Caps-lock function is taken from the Host OS, which is there placed at the Ctrl key, and the Guest (Windows XP) is interpreting the Ctrl-key itself, with it's original meaning, ignoring the layout set in xmodmap.

comment:11 Changed 6 years ago by robm

I'm not sure if this is related or not, but I have a similar problem in 2.0 when using setxkbmap and a custom dvorak-style layout. I added my log file and the keymap at #2052

comment:12 Changed 5 years ago by MrX1980

Please try it with v3.0.0 again.

comment:13 Changed 5 years ago by frank

No response, closing.

comment:14 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:15 Changed 4 years ago by schmir

  • Status changed from closed to reopened
  • Resolution fixed deleted

It does *not* work with 3.0.12 on a 64 bit linux host with w2k.

here's my xmodmap

clear Shift
clear Lock
clear Control
clear Mod1

!keycode 117= Multi_key

keysym semicolon = colon semicolon colon semicolon colon semicolon
keysym quotedbl = quotedbl apostrophe quotedbl apostrophe quotedbl apostrophe
keycode  49 = asciitilde grave asciitilde grave asciitilde grave
keycode  65 = space space space NoSymbol space

!keysym Caps_Lock = Escape
keycode 66 = nabla
add Shift = Shift_L
add Shift = Shift_R

add Mod1 = Alt_L
add Mod1 = Alt_R

add Control = Control_R
add Control = Control_L

colon, semicolon, apostrophe and quotedbl do not work.

comment:16 Changed 4 years ago by frank

  • Summary changed from VB doesn't handle custom keyboard layouts (xmodmap) => fixed in next version to VB doesn't handle custom keyboard layouts (xmodmap)

comment:17 Changed 4 years ago by invsblduck

I also experience this behavior on 3.1 (3.1.2-56127_Ubuntu_karmic to be exact). I xmodmap my us-dvorak layout in Xorg and it affects the vanilla QWERTY layout in my Windows 7 guest. :)

Thank you. I love this software.

Changed 4 years ago by jon_eliot

xmodmap, causes malfunction on Ubuntu Karmic 64bit

comment:18 Changed 4 years ago by jon_eliot

Confirmed a very similar malfunction on Ubuntu Karmic 64bit. Virtualbox Version 3.1.4 r57640 installed from development repository. Without xmodmap the keyboard maps perfectly. With xmodmap all characters are mismapped except the letter 'a'. uname -a Linux nn.uninett.no 2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 02:39:34 UTC 2010 x86_64 GNU/Linux

Apart from this virtualbox is excellent. Running in a separate login without keyboard remapping and doing precisely what I need.

comment:19 Changed 4 years ago by Technologov

If this is Ubuntu bug, then it is worth closing here...

comment:20 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Summary changed from VB doesn't handle custom keyboard layouts (xmodmap) to VB doesn't handle custom keyboard layouts (xmodmap) -> duplicate of #2595

This is not an Ubuntu bug, it is a genuine issue in VirtualBox. This is now fixed in our development repository. I will close this as a duplicate of ticket #2595 since I handled the issue there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use