VirtualBox

Ticket #1892 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

vbox0 interface doesn't start when Virtual Box loads => documented in 1.6.6

Reported by: mattanders40 Owned by:
Priority: major Component: network
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Well, were to start. I'm running Opensuse 11.0. I'm having to constantly (after every startup of the host system) put the "sudo VBoxAddIf vbox0 user br0" command in to fire up the vbox0 interface. After doing so, the Virtual Box system will network and have internet connection. If someone can tell me how to get the vbox0 interface to load on startup of host I would not have any problems with Virtual Box. I have spent many hours trying to resolve this and again, if the vbox0 interface would just load at either the host boot or Virtual box Boot I would be set.

Any suggestions would be helpful. Oh ya, take it easy on me, I'm a Linux noobe.

Yes, I have followed the instructions several times and have come to the conclusion that all I need is the vbox0 interface to load at startup of Host or Virtual Box.

Attachments

XP Professional-2008-08-04-11-11-15.log Download (36.8 KB) - added by mattanders40 6 years ago.
log

Change History

comment:1 Changed 6 years ago by frank

I assume that somehow the startup script /etc/init.d/vboxnet is either not executed or in the wrong order. We have to verify this here. Does version 1.6.4 make any difference?

Changed 6 years ago by mattanders40

log

comment:2 Changed 6 years ago by mattanders40

Frank, I went into the yast/online update looking for to 1.6.4 with no avail. I do have the Virtualbox in my repositories so I was hoping that maybe 1.6.4 would have done it. I have attached a log file. I hope that it will help. As of today, I can walk through the instructions and get Virtualbox to work using the host interface method for workgroup networking and as soon as I restart/shutdown the host I will loose me vbox0 interface. Again, if I use the sudo VBoxAddIF vbox0 <user> br0 command, my vbox0 will show in ifconfig and Virtualbox will work again. I have considered creating a script but have no idea how to create one. I was thinking that I could execute this script at startup of host and now I wouldn't have to worry about this glitch in Virtualbox. Hope you can help.

comment:3 Changed 6 years ago by mattanders40

Well, I have tried Virtual Box 1.6.4 with no help getting vbox0 interface to start on startup of host.Please direct me to where or what I can do to resolve this.

comment:4 Changed 6 years ago by frank

I did some quick experiments here using an openSUSE11 VM. I somehow are not able to configure the bridge correctly. Neither creating such a ifcfg-br0 in /etc/sysconfig/network nor doing this task with YaST helps, the bridge just does not appear (activate on boot is selected). So I can currently not help but I really think that the calling order is broken, most probably /etc/init.d/vboxnet is called too early (that is, before the bridge was created).

comment:5 Changed 6 years ago by mattanders40

How can I change the calling order? I do see that when Suse loads the VBox entries are failing(I have caught a glimpse behind the green suse post screen). I have gone into the yast/services/runlevel and have confirmed that vboxnet and vboxdrv are starting at init 2,3,5. As far as the bridge, I set my up using yast/network devices/network settings add than choose bridge. This I have been able to complete and again when I put the sudo VBoxAddIF vbox0 user br0 it works but won't load on startup. If, after a boot, I go into ifconfig the vbox0 doesn't show. I put the sudo VBoxAddIF in and do an ifconfig than vbox0 will show and my VM will network and have internet. Please tell me how I can change the call order. Thanks again for you help.

comment:6 Changed 6 years ago by mattanders40

I have just reinstalled Opensuse 11.0 updated to kernel 2.6.25 and grabbed a all of the other updates. Installed Video Drivers just in case. Created/configured my bridge from the yast. Downloaded VirtualBox 1.6.4 from site and installed the rpm file after installing the pam-devel in software management. Than, I have installed XP Professional and after the install I went ahead and performed the sudo VBoxAddIF vbox0 user br0. I can get the VM to work with NAT, works if the VBoxAddIF command has been given before starting Virtual Box but I still can not get the vbox0 adapter to load when Opensuse restarts/starts. HELP!

comment:7 Changed 6 years ago by frank

The problem is SuSEfirewall2_setup. It somehow disables the vbox0 tap interface again after it was already enabled.

comment:8 Changed 6 years ago by frank

No, its not the firewall. The vbox0 interface just disappears some time after it was successfully created by the vboxnet script.

comment:9 Changed 6 years ago by frank

Actually the responsible service is udev. There is a udev rule

/etc/udev/rules.d/77-network.rules

which calls automatically ifup for an interface which was activate with ifconfig. This rule has some exceptions, among them tap* and tun*. So the solution is to name the interface just tap0 instead of vbox0 (edit /etc/vbox/interfaces manually to perform the change). Then reboot and that interface should be ready for use.

Note that I had to disable the network manager to create a bridge (NETWORKMANAGER=no in /etc/sysconfig/network/config) but this is not necessary if you already successfully created the bridge.

I will add this name constraint to the documentation. Please could you confirm that this actually works?

comment:10 Changed 6 years ago by mattanders40

Well, Frank, you have figured it out. From my last post, I had removed VBox and had VMWare up and running with no issues. So, I removed VMWare from the computers and went back to VirtualBox and BANG! the configuration stays and I'm able to network XP without having to put the sudo VBoxAddIF tap0 user br0 command in every time I start or restart the host. Here is what I have going. Workstation 1: Opensuse 11.0.1 64bit (kernel 2.6.25), Virtual Box 1.6.2 (XP Media Center) host networking using tap0 as my virtual adapter name. Workstation2 Opensuse 11.0.1 32bit (kernel 2.6.25), Virtual Box 1.6.2 (XP Professional) host networking using tap0 as my virtual adapter name. I did create my bridge using yast/network devices and assigned the eth0 the IP 0.0.0.0 255.255.255.0 (its all in the instructions as you know). Now, why I'm setting all of this up? Well, just so I can run Quickbooks (multiuser). My customer is sick and tired of having to pay for Antivirus, labor to remove infections, file maintenance, and will eventually rid Quickbooks as soon as he gets used to gnucash. I would like to thank Frank for taking the time to resolve this issue. I'm an independent computer service company pushing OpenSuse. I have sold five computers last month with Opensuse because customers are sick and tired of getting infected and are mad that they are being forced to use Vista. I'm sure the rest of the people are ready to free themselves too.

comment:11 Changed 6 years ago by frank

  • Summary changed from vbox0 interface doesn't start when Virtual Box loads to vbox0 interface doesn't start when Virtual Box loads => documented in 1.6.6

comment:12 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use