VirtualBox

Opened 5 years ago

Last modified 5 years ago

#18302 new defect

Can not install VirtualBox Guest Additions in CentOS 6.10

Reported by: reynierpm Owned by:
Component: guest additions Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

I am using Vagrant 2.2.3 and I have installed the latest VirtualBox 6 (VirtualBox-6.0.0-127566-Win). My Vagrantfile looks like follow:

  # -*- mode: ruby -*-
  # vi: set ft=ruby :

  Vagrant.configure("2") do |config|
    config.vm.box = "reynierpm/centos6"
    config.vm.box_version = "4"

    config.vm.provider :virtualbox do |vb|
      vb.customize ["modifyvm", :id, "--memory", 2048]
    end
  end

But VirtualBox Guest Additions won't install and fails with the following error:

VirtualBox Guest Additions: modprobe vboxsf failed

Have tried to install them manually and I got the same result:

# sh VBoxLinuxAdditions.run                                                          
Verifying archive integrity... All good.                                                                   
Uncompressing VirtualBox 6.0.0 Guest Additions for Linux........                                           
VirtualBox Guest Additions installer                                                                       
Removing installed version 6.0.0 of VirtualBox Guest Additions...                                          
vboxadd-service.sh: Stopping VirtualBox Guest Addition service.                                            
You may need to restart your guest system to finish removing the guest drivers.                            
Copying additional installer modules ...                                                                   
Installing additional modules ...                                                                          
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules.  This may take a while.
VirtualBox Guest Additions: To build modules for other installed kernels, run                              
VirtualBox Guest Additions:   /sbin/rcvboxadd quicksetup <version>                                         
VirtualBox Guest Additions: Building the modules for kernel 2.6.32-754.9.1.el6.x86_64.                     
																										   
VirtualBox Guest Additions: Look at /var/log/vboxadd-setup.log to find out what went wrong                 
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted      
VirtualBox Guest Additions: Starting.                                                                      
VirtualBox Guest Additions: modprobe vboxsf failed                                                         

Logs aren't helpful:

# cat /var/log/vboxadd-setup.log
Could not find the X.Org or XFree86 Window System, skipping.

Change History (5)

comment:1 by Socratis, 5 years ago

  1. It's usually better and faster, if issues get first addressed in the VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is not a bug and someone from the developers has to deal with it and close it as "Invalid".

But, Vagrant is not really supported, it has its own support channels. Unless you have this problem with a Vagrant-less setup, then we could continue this discussion...

And to address the "modprobe vboxsf failed" message, that's a red herring. It's a non-issue. Unless you have another indication of a failed Guest Additions (GAs) installation, that's not a problem.

  1. You were supposed to follow these steps when you filed the bug, and provide a VBox.log:

    Attach a (full) log file ("Machine" menu/"Show Log" in the main VirtualBox Manager window) straight away to save time for you and for us. The log file contains a lot of useful information about both the host andthe guest systems as well as information about what happened during a particular machine run. Please do not cut and paste it.

Last edited 5 years ago by Socratis (previous) (diff)

comment:2 by Akemi Yagi, 5 years ago

Duplicate of #18249 (filed against RHEL 6) and #18238 (filed against Oracle Linux 7).

comment:3 by Socratis, 5 years ago

@toracat
This is not the same issue. This one actually is a non-issue. I don't see any error messages at all, and I bet you that if the OP had included the VBox.log as requested, the GAs would be up and running with no problems.

Let me reiterate: the "modprobe vboxsf failed" message is bogus, a red herring.

comment:4 by Akemi Yagi, 5 years ago

@socratis

Take a look at the forum post from where #18249 was raised:

https://forums.virtualbox.org/viewtopic.php?f=3&t=90978

You'll find the same output, including "modprobe vboxsf failed".

VBox 6.0.0 + RHEL/CentOS 6 => failure of the vboxsf build => failure of modprobe

comment:5 by Socratis, 5 years ago

@toracat

I get the "modprobe vboxsf failed" on ALL of my guests. It means absolutely nothing on its own, it simply means that you already had a previous version of the "vboxsf" installed, and when the GAs installer found that module, it tried to load it, but it was the "bad" version.

Move along, nothing to see here folks...

And yes, I've been following the issue with the building of the GAs, from its genesis. In your #18249 ticket (and in #18238 as well) you had way more than just that message, and if you check closely, it is not the same output. Do not confuse the two issues...

But until we see a (long overdue) VBox.log from a complete VM startup/login/shutdown session, the whole discussion is moot...

Last edited 5 years ago by Socratis (previous) (diff)
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use