VirtualBox

Ticket #18238 (closed defect: fixed)

Opened 6 months ago

Last modified 2 months ago

vboxsf module (6.0.0) does not compile for kernel 3.10 -> fixed after (not in) 5.2.22/6.0.0 or in test builds

Reported by: the_source_him Owned by:
Component: shared folders Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: Linux Host type: Linux

Description

Can not compile vboxsf module during guest additions installation in Oracle Linux 7.2 guest (kernel 3.10.0-327.el7.x86_64) due to missing include in vboxsf/vfsmod.c (results in implicit declarations of functions seq_puts, seq_printf, seq_escape). To fix this I manually added #include <linux/seq_file.h> directive into file, after that module compiled successfully

Change History

comment:1 Changed 5 months ago by toracat

subscribed.

comment:2 Changed 5 months ago by toracat

comment:3 Changed 5 months ago by socratis

Either #18238 is a duplicate of #18249, or #18249 is a duplicate of #18238.

"This bugtracker isn't big for both of them!" :)

comment:4 Changed 5 months ago by toracat

You can mark #18249 as a dupe of #18238. The only difference is the guest OS (el7 vs. el6).

comment:5 Changed 5 months ago by michael

Please try the current test builds<1>.

  1. wiki:Testbuilds

comment:6 Changed 5 months ago by toracat

With VBoxGuestAdditions_6.0.1-128006, vboxsf builds fine on RHEL-6.

comment:7 Changed 5 months ago by michael

  • Summary changed from vboxsf module (6.0.0) does not compile for kernel 3.10 to vboxsf module (6.0.0) does not compile for kernel 3.10 -> fixed after (not in) 5.2.22/6.0.0 or in test builds

comment:8 Changed 5 months ago by the_source_him

Guest additions 6.0.2 compiled without problems in Oracle Linux 7.2 for 3.10 kernel.

comment:9 Changed 2 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use