VirtualBox

Ticket #18249 (closed defect: duplicate)

Opened 11 months ago

Last modified 10 months ago

Installation of GuestAddition 6 on RHEL6 fails -> duplicate of #18238

Reported by: toracat Owned by:
Component: guest additions Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: Linux Host type: all

Description

Building the vboxsf kernel module fails on RHEL6 guest.

/vboxsf/vfsmod.c: In function ‘sf_show_options’:
/vboxsf/vfsmod.c:509: error: dereferencing pointer to incomplete type
/vboxsf/vfsmod.c:515: error: implicit declaration of function ‘seq_printf’
/vboxsf/vfsmod.c:518: error: implicit declaration of function ‘seq_puts’
/vboxsf/vfsmod.c:519: error: implicit declaration of function ‘seq_escape’

This is due to missing header files:

 <linux/mount.h>
 <linux/seq_file.h>

It was reported in the following forum post:

 https://forums.virtualbox.org/viewtopic.php?f=3&t=90978

The attached patch fixes the errors.

Attachments

fix-vboxsf-build-error-for-rhel6.patch Download (992 bytes) - added by toracat 11 months ago.
Patch to fix vboxsf build errors on RHEL6

Change History

Changed 11 months ago by toracat

Patch to fix vboxsf build errors on RHEL6

comment:1 Changed 10 months ago by toracat

This issue was reported in bug #18238 as well.

comment:2 Changed 10 months ago by socratis

I thought I had seen that "seq_file.h" before, when I first looked at your ticket, I just couldn't remember where! ;)

Good eye!

comment:3 Changed 10 months ago by socratis

Either #18249 is a duplicate of #18238, or #18238 is a duplicate of #18249.

"This bugtracker isn't big for both of them!" :)

comment:4 Changed 10 months ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Installation of GuestAddition 6 on RHEL6 fails to Installation of GuestAddition 6 on RHEL6 fails -> duplicate of #18238

Marking this ticket as a duplicate. Please try the current test builds<1> and update #18238 if appropriate.

  1. wiki:Testbuilds

comment:5 Changed 10 months ago by toracat

I confirm the fix. With VBoxGuestAdditions_6.0.1-128006, vboxsf builds fine on RHEL-6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use