VirtualBox

Ticket #16170 (closed defect: fixed)

Opened 10 months ago

Last modified 3 weeks ago

Cracks in audio & slowdown after some time (Windows guest)

Reported by: dusek Owned by:
Priority: major Component: audio
Version: VirtualBox 5.1.8 Keywords: audio
Cc: Guest type: Windows
Host type: Mac OS X

Description

I am hitting an issue where audio in the VM begins fine, but after some usage of audio apps, it becomes choppy with cracks after a 1-2 minutes of varying use.

I have no exact repro, usually using audio apps naturally reproduces the issue within 2-3 minutes (I succeeded e.g. by playing YouTube video in firefox, pausing it, focusing other host app, refocusing the VM and playing the video again - the sound did not become slow immediately, but already exhibited "cracks" like when playing a dusty LP).

I will attach the VM log.

I will also attach 2 audio recordings:

  • one for the above VM log with audio completely slowed down and choppy (with VBox 5.1.9)
  • one for the same VM, just after restart using the very same program as in first recording, but before the audio becomes slow and choppy (to have a reference point for what the first recording should have roughly sounded like) (again with VBox 5.1.9)

Configuration:

  • VirtualBox versions:
    • happens on: 5.1.6, 5.1.8 and 5.1.9 (111785)
    • does not happen on: 5.0.28
  • Host: macOS 10.12.1 (16B2555)
  • Guest: Win 7 Pro x86 Czech FPP
  • Host audio: CoreAudio
  • Guest audio controller: hda (Intel HD Audio)

Note: I tried with Linux guest (Ubuntu 16.04 x64). I did not reproduce the problem, so I suppose the issue is connected to Windows guests.

Attachments

VBox.log Download (114.3 KB) - added by dusek 10 months ago.
VBox.log
System Audio 20161108 2040 2.mp3 Download (139.5 KB) - added by dusek 10 months ago.
Slow choppy audio (speaking: "US picks its next president, odkaz")
System Audio 20161108 2105.mp3 Download (142.6 KB) - added by dusek 10 months ago.
Normal audio of the same program (speech synthesizer)

Change History

Changed 10 months ago by dusek

VBox.log

Changed 10 months ago by dusek

Slow choppy audio (speaking: "US picks its next president, odkaz")

Changed 10 months ago by dusek

Normal audio of the same program (speech synthesizer)

comment:1 Changed 10 months ago by dusek

I also forgot one strange thing: sometimes things get so far that there is no audio at all; however when I hit the speaker button in systray, I can see that there is some audio activity - the green part of the bar moves ("waves") as it things there is some audio. If I quit the audio application and start it again, it again produces actual audible audio.

comment:2 Changed 8 months ago by Sy

I'm having the same issue which I believe was also reported 5 month ago (tickets Ticket #15848 and #15651) - the second one is unfortunately marked as fixed in 5.1.2!?.

I'm running the latest VirtualBox Version 5.1.12 r112440 (Qt5.6.2). running on a MacBook Pro Retina 13". My guest OS is a Windows 10. MacOS, Windows, and VirtualBox Guest Additions on the guest machine are all up to date. I have no slowness or any performance issues and it seems like a virtual sound driver issue.

The issue happens with any sound, whether from a video or music playback. It's almost as the Digital to Analog converter saturates at some peak levels creating the cracky or choppy sound that is being reported by multiple users.

If the development team reads this, please help fixing it. Many thanks in advance!

Last edited 8 months ago by Sy (previous) (diff)

comment:3 Changed 3 months ago by sbrunov

Hello, Everyone!

It seems that the defect still persists.

Agree with @Sy: it would be great to have this defect resolved.

Context

Hardware

Virtual machine settings:

  • CPU: 4 processors (of 8 processors in total), 100% execution cap.
  • RAM: 8192 Mb.
  • Audio:
    • Host Driver: CoreAudio.
    • Controller: Intel HD Audio.

Software

  • VirtualBox: 5.1.22 r115126.
  • Host OS: macOS 10.12.4 (16E195).
  • Guest OS: Microsoft Windows Server 2016 Standard 10.0.14393 N/A Build 14393 x64.

Best regards,
Sergey Brunov.

comment:4 Changed 3 months ago by pentagonik

There's a new 5.1 test build on the Testbuilds page (r115730) which should have audio improvements regarding HDA emulation in combination with Windows 10 AU (Anniversary Update) + CU (Creators Update) guests.

comment:5 Changed 3 months ago by pal1000

Unfortunately this test build reintroduced a common problem affecting Windows 7 guests - slow motion videos and noisy audio. It appears that the audio glitch confuses media players resulting in that slow motion. I am running Windows 10 CU with Windows 7 SP1 fully patched as guest. Only Intel HD Audio is affected.

comment:6 Changed 3 months ago by pentagonik

Thanks for the feedback -- did you also test other guests besides Win7, e.g. Win10 as a guest?

comment:7 Changed 3 months ago by pentagonik

@pal1000 Could you please give the latest test build 115786 (again available on the Testbuilds page) a try? The slow down issues should be resolved there. Thank you!

comment:8 Changed 3 months ago by pal1000

Excellent, test build r115786 fixed regression from r115730. I no longer have a Windows 10 guest due to it being in-optimal for my use case. Software rasterized desktop composition+a Direct3D application is more demanding than Windows 7 with Basic theme with Google Swiftshader running same Direct3D application. Actually both Direct3D and OpenGL Guest Addition drivers performance on Vista+ is so bad that software rasterizers are faster. WDDM being slower than XPDM even without desktop composition.

comment:9 Changed 2 months ago by pentagonik

@pal1000 Can you please elaborate further how audio works on your guest(s) using this test build? How's the audio output + recording quality there? Which guests are / were you testing with? Thanks!

comment:10 Changed 2 months ago by pal1000

Currently running r115966 and there are no issues with audio playback. I don't do recordings so I can't help you with that. I am still running Windows 10 CU as host and Windows 7 SP1 as the only guest, though I might consider returning to Windows 10 CU as guest as I figured out how to turn off transparency though I don't know when. Sorry that I don't have much else to say.

Last edited 2 months ago by pal1000 (previous) (diff)

comment:11 Changed 2 months ago by pentagonik

We currently need more feedback regarding Windows 10 CU / CA as a guest regarding audio, that's why I've been asking. Nevertheless, thanks for the update!

comment:12 Changed 2 months ago by pal1000

Tried Windows 10 CU as guest and seams to work really well. Didn't experience anything out of order regarding audio.

comment:13 Changed 4 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.24.

comment:14 Changed 3 weeks ago by Sy

Hi all,

Thanks @sbrunov for your endorsement and to the dev team for the recent attention you've given to the audio issue.

Here are my observations after the reported fix. I have updated to version 5.1.26 r117224 (Qt5.6.2) with the latest Guest addition. Host is still Macbook Pro retina 13" early 2015, Sierra OS 10.12.6 Guest is still the same VM as before with Windows 10 Pro with all latest patches.

Audio on its own no longer produces many cracking noises except for the occasional occurrence, very similar to popping sounds from old vinyl records. Overall audio by itself is much better.

The same audio track when overlaid on a video does still produce a lot of cracks to an extent where it's annoying. The video playback performance has also been degraded since before my upgrades and video shows pixelations and jumps in addition to the audio cracking sounds.

The media files don't have any problems and I have confirmed the qualities by playing them back on the host Mac.

I'm hesitating whether or not I should leave this ticket as closed or reopen it because I'm debating whether or not VM configurations and perhaps increasing video memory or something may now be able to resolve the issue after the VirtualBox fixes.

I would be interested in hearing from the dev or test team as well as other community member's observation which have reported or commented on this issue.

Thanks in advance!

Last edited 3 weeks ago by Sy (previous) (diff)

comment:15 Changed 3 weeks ago by pentagonik

@Sy Thanks for the feedback, appreciating it. You only did test on a Mac so far, right? Can you reproduce those video pixelations in combination with audio when e.g. running an intensive task on the host *or* guest?

The fixes needed for Windows 10 guests required to make audio running a lot more synchronous than before, and additional load could lead to such a behavior. In the next major version we do such processing in some asynchronous manner which (hopefully) should fix those issues.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use