VirtualBox

Ticket #15770 (closed defect: fixed)

Opened 23 months ago

Last modified 21 months ago

Anniversary update incompatibility / the instuction at ... referenced memory 0x0000000000000020. The memory could not be read

Reported by: frankb Owned by:
Priority: critical Component: VM control
Version: VirtualBox 5.1.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

A quick way of REPLICATING this (for me) on my W10/64bit host with anniversay update & VB up to version 5.1.3 /build 109780 is to simply close a vm window & then select "power off the machine" in the popup window. I tested with W7 & W8.1 vm's , even with freshly created vm's.

Under normal working circumstances the error occurs USUALLY when I shutdown a vm from within the vm itself (orderly shutdown)

I tried reverting to an older build as well (5.0.26) and it has the same issue so it must be an incompatibility caused by the W10 anniversary update I guess.

Attachments

VB screenshots.pdf Download (229.1 KB) - added by frankb 23 months ago.
screenshots
VBox.log Download (76.7 KB) - added by Paul B. 22 months ago.
VirtualBox log file
Thomas C. 2016-08-16-17-48-37.log Download (88.2 KB) - added by Thomas C. 22 months ago.
VirtualBox_Crash.png Download (8.0 KB) - added by Thomas C. 22 months ago.
Print screen
VirtualBox_Crash_log Download (100.6 KB) - added by Thomas C. 22 months ago.

Change History

Changed 23 months ago by frankb

screenshots

comment:1 Changed 23 months ago by frankb

I installed todays Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB3176495) but it does not change things.

I'm attaching a few screenshots taken when the error occured after I selected shutdown in the VM itself.

After the error the vm's are in an "aborted" state.

The visual studio debugger does not launch (invalid license ? See screenshot)

comment:2 Changed 22 months ago by frank

Sorry, but without an application crash dump there is nothing we can do.

Changed 22 months ago by Paul B.

VirtualBox log file

comment:3 Changed 22 months ago by Paul B.

I have almost same problem. Virtual Machine randomly crash but I haven't anniversary update.

VirtualBox 5.1.2r108956

Error message: The instruction at 0x00007FFB01CE278E referenced memory at 0x0000000000000010. The memory could not be read.

Host: Windows 10 Enterprise x64 10.0.10586 (without anniversary update)

Guest: Windows 10 Enterprise x64 10.0.10586 (without anniversary update)

comment:4 Changed 22 months ago by Thomas C.

I have the same problem. Virtual Machine randomly crash since i have update virtualBox to 5.1.2 and windows 10 to anniversary update.

VirtualBox 5.1.2 r108956

Error message: The instruction at 0x00007FFB01CE278E referenced memory at 0x0000000000000010. The memory could not be read.

Host: Windows 10 Pro x64 14393.51 (with anniversary update)

Guest: Crash with Win 7 Pro 64 bits et 32 bits

I have attach my log file.

Changed 22 months ago by Thomas C.

comment:5 Changed 22 months ago by frankb

v5.1.4 seems to remedy all my issues; THANK YOU!

comment:6 Changed 22 months ago by Thomas C.

I have updagre to 5.1.4 and i have the same issue. I have attach print screen and log. At next crash, i will try to give mini dump. I will also try with disable sound.

Changed 22 months ago by Thomas C.

Print screen

Changed 22 months ago by Thomas C.

comment:7 Changed 22 months ago by Thomas C.

After a crash, there is no mini dump generated. I think its normal because it's not VirtualBox which crash but the guest. Next test : i will disable sound.

comment:8 Changed 22 months ago by Thomas C.

Result with sound disable : One day past without crash.
I will continue testing with sound disable.

comment:9 Changed 22 months ago by Thomas C.

An other day without crash.
So it will appear that sound is the reason of this issue.

comment:10 Changed 22 months ago by frank

Please try the latest 5.1.x test build from here with audio enabled.

comment:11 Changed 21 months ago by Thomas C.

The isssue seems to be resolved with 5.1.6

comment:12 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thank you. I will close this ticket then. Please reopen if necessary.

comment:13 Changed 21 months ago by frankb

I continue to see the problem on a vm that uses the host usb port with a RS232 to usb converter; if I start the application that reads the RS232 data via USB all works well. If I shutdown the guest it errors out. I use 5.1.6 on W10Pro v1607. This used to work perfect on older OS , with older virtualbox version.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use