VirtualBox

Ticket #15771 (closed defect: fixed)

Opened 9 months ago

Last modified 8 months ago

alt key in guest stopped working -> possibly fixed in releases higher than 5.1.4

Reported by: ÄxxlForce Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

never had issues with the alt key and all of a sudden it's not working in the guest anymore (tested win8 and win10).

if i deactivate mouse integration the alt key works but it's not how i want to use the vm.

it does something though because when i hit alt+enter in my IDE on the guest system it does nothing instead of breaking the line which you would expect if it just ignored alt

Change History

comment:1 Changed 9 months ago by michael

Do you think this is a duplicate of #15745?

comment:2 Changed 9 months ago by ÄxxlForce

hard to say. windows key works for me within the guest.

btw i found out that i can use alt when i press windows key+alt

comment:3 Changed 8 months ago by ÄxxlForce

is the windows key+alt thing intended behaviour?

comment:4 Changed 8 months ago by michael

One change with 5.0 was in the way we do automatic keyboard capturing on Linux and X11-based host systems. Now we delay doing the actual keyboard grab until a key has been pressed (you can see this by looking at the keyboard icon on the right of the bottom status bar). This might explain what you are seeing - that if you press the windows key first, the keyboard is grabbed when you press Alt and the key press goes to the guest.

And yes, there were reasons for doing that - for example in 4.x key presses often went to both host and guest.

comment:5 Changed 8 months ago by ÄxxlForce

ok, but i have to press windows key+alt every time i want to use alt not just the very first time

comment:6 Changed 8 months ago by michael

  • Summary changed from alt key in guest stopped working to alt key in guest stopped working -> possibly fixed in releases higher than 5.1.4

Please give revision 110598 or later a try when it appears on the test builds page<1>.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:7 Changed 8 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use