VirtualBox

Ticket #15769 (closed defect: fixed)

Opened 12 months ago

Last modified 11 months ago

Kernel Panic after installing guest additions on 4.7.0 kernel -> fixed in releases higher than 5.1.2

Reported by: dekstroza Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.1.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

Can be reproduced both on Linux and Mac VirtualBox. Based on discussion here:  https://forums.virtualbox.org/viewtopic.php?f=3&t=79121 To reproduce:

  1. Install Centos 7.2 using centos-minimal iso ( http://ftp.heanet.ie/pub/centos/7/isos/x86_64/CentOS-7-x86_64-Minimal-1511.iso)

2.Then log into the guest, and do yum -y update && shutdown -r now 3.After reboot: curl -L -O  http://www.elrepo.org/elrepo-release-7.0-2.el7.elrepo.noarch.rpm && yum -y localinstall elrepo-release-7.0-2.el7.elrepo.noarch.rpm

  1. yum remove kernel-devel kernel-headers kernel-tools-libs
  2. yum --enablerepo=elrepo-kernel install kernel-ml kernel-ml-devel kernel-ml-headers kernel-ml-tools-libs gcc bzip2 make dkms perl
  3. Reboot into kernel 4.7.0
  4. On virtual box select Insert Guest Additions CD Image
  5. On guest as root: mkdir /mnt/cdrom && mount /dev/cdrom /mnt/cdrom && cd /mnt/cdrom && ./VBoxLinuxAdditions.run --nox11
  6. It should install fine and lsmod | grep vb should show two modules, also dmesg will show few lines when they are loaded
  7. Restart guest with shutdown -r now or reboot/power down/up with VirtualBox

12.Kernel Panic

Attachments

VirtualBox_Testos7_08_08_2016_15_20_21.png Download (17.0 KB) - added by dekstroza 12 months ago.
Kernel Panic
Testos7-2016-08-08-16-28-06.log Download (70.0 KB) - added by dekstroza 12 months ago.
Guest Log
Testos.log Download (42.6 KB) - added by dekstroza 12 months ago.
Detailed guest log including entire kernel panic output

Change History

Changed 12 months ago by dekstroza

Kernel Panic

Changed 12 months ago by dekstroza

Guest Log

Changed 12 months ago by dekstroza

Detailed guest log including entire kernel panic output

comment:1 Changed 12 months ago by dekstroza

Seems to be the same thing as reported here on 5.1.2:  https://bugs.mageia.org/show_bug.cgi?id=18946

comment:2 Changed 12 months ago by dekstroza

Kernel panic is caused by vboxvideo.ko, modprobe vboxvideo will do the trick. Same happens on VB test build of additions (5.1.3)

comment:3 Changed 12 months ago by dekstroza

To avoid kernel panic: dracut -o "vboxvideo" -f /boot/initramfs-$(uname -r) $(uname -r) && echo "blacklist xboxvideo" >> /etc/modprobe.d/blacklist-vboxvideo.conf

Rebooting works fine, lsmod shows other two vbox modules loaded, and sharing folder from host to guest works as expected. 100% problem is xboxvideo.ko (both 5.1.2 and 5.1.3 version of guest additions, linux or mac version of VirtualBox)

comment:4 Changed 12 months ago by michael

Please try the following:

1) Reinstall the latest Guest Additions test build in a clean state.

2) Modify the file /usr/src/.../vbox_ttm.c to add the lines:

    .lru_tail = &ttm_bo_default_lru_tail,
    .swap_lru_tail = &ttm_bo_default_swap_lru_tail,

underneath the line:

    .io_mem_free = &vbox_ttm_io_mem_free,

3) Execute "/sbin/rcvboxadd setup" as root.

4) Reboot the guest.

comment:5 Changed 12 months ago by dekstroza

That does the trick, with changes above, kernel will not panic when I do reboot or try modprobe vboxvideo.

Thanks michael!

comment:6 Changed 12 months ago by jbrownEP

Does anyone happen to have a VBoxGuestAdditions.iso which has these changes made on it?

comment:7 Changed 12 months ago by michael

  • Summary changed from Kernel Panic after installing guest additions on 4.7.0 kernel to Kernel Panic after installing guest additions on 4.7.0 kernel -> fixed in releases higher than 5.1.2

It was committed as revision 109930, so the current Guest Additions test build<1> has the fix.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:8 Changed 12 months ago by frank

Fix also part of the latest 5.0.x Guest Additions test build on that page.

comment:9 Changed 12 months ago by dekstroza

Thanks for help and the quick turn around, good to see its already in for the next version.

comment:10 Changed 11 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.4.

comment:11 Changed 11 months ago by badfd

I may be wrong, but there appears to be a typo in the [kernel panic] workaround suggested by dekstroza, above. Instead of 'blacklist xboxvideo', I suspect dekstroza wanted 'blacklist vboxvideo':

# dracut -o "vboxvideo" -f /boot/initramfs-$(uname -r) $(uname -r) && echo "blacklist vboxvideo" >> /etc/modprobe.d/blacklist-vboxvideo.conf

I successfully used 'blacklist vboxvideo' to get rid of the kernel panic, but it's probably the filename itself [rather than its content] that defines a blacklisted module.

Last edited 11 months ago by badfd (previous) (diff)

comment:12 Changed 11 months ago by badfd

Last edited 11 months ago by badfd (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use