VirtualBox

Ticket #14903 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 months ago

Second monitor loses mouse interaction -> duplicate of #14743

Reported by: MCon Owned by:
Component: other Version: VirtualBox 5.0.10
Keywords: mouse dual-monitor Cc:
Guest type: Linux Host type: Windows

Description

I have a dual monitor configuration (I actually have 4 monitors in my Host, I use two full-screen for this VM).

At random (I was unable to find a "Recipe to Reproduce") I would completely lose mouse on the second monitor. This means mouse clicks are not delivered to application windows on that monitor, while keyboard interaction remains normal. Mouse interaction on the first monitor remains normal and I never had any problems (i.e.: Defect shows only on second monitor)

In order to recover I have to completely shut down client and restart (VM save/restore is not enough).

I don't know if any of the following is relevant, but...:

  • Client is a fairly recent, up-to-date XUbuntu.
  • Cursor moves normally in guest monitor; only interaction (clicks and hovering) is missing.
  • I normally, when defect shows, close VM using "ACPI Shutdown"; when I do XUbuntu shows a confirmation dialog on the second, blocked, monitor and there interaction works (i.e.: I can click on the "Shutdown now" button).
  • Canceling shutdown operation does not restore mouse functionality.
  • Both monitors I allocate for this VM are connected to Intel HD Graphics 4600 integrated into my i7-4770 CPU.
  • Defect happens randomly with very low occurrence (days).
  • Defect happens even if I am interacting only with VM (no interaction with Host or other VMs, if present, is necessary to trigger bug).
  • Defect may appear even if this is the only VM active.
  • Defect might be related with #11813, despite differences behavior seems similar.

As You may imagine Defect is a major PITA despite its low frequency

Attachments

VBox.log Download (116.0 KB) - added by MCon 3 years ago.
Log of latest Defect appearence; I sut down VM shortly after bug showed
VBoxHardening.log Download (455.7 KB) - added by MCon 3 years ago.
I don't know if this is relevant

Change History

Changed 3 years ago by MCon

Log of latest Defect appearence; I sut down VM shortly after bug showed

Changed 3 years ago by MCon

I don't know if this is relevant

comment:1 Changed 3 years ago by agilis

I just started experiencing this same exact issue. Mouse functionality as far as mouse clicks are concerned no longer work on the second screen. Functionality still remains on the primary screen. Host OS is not affected.

I have tried to perform the following in hopes of resolving the issue:

  • Toggle full screen
  • Re-enable secondary screen
  • Use the Displays preference in the Guest OS

None of these worked.

I then took it a step further.

  1. I toggled out of full screen.
  2. Disabled the second screen.
  3. Toggled back into full screen.

Once I did this, I lost all functionality on the primary screen. Again, Host OS not affected.

Shutting down the GuestOS was the only way to recover.

  • Intel i5-4590
  • Intel HD Graphics 4600
  • VirtualBox 5.0.12 r104815
  • Host: Windows 7 Enterprise
  • GuestOS CentOS 6
  • Clicking of mouse lost on second screen
  • Keyboard functionality was never lost.
  • Defect seems to be occurring frequently.

comment:2 Changed 3 years ago by michael

You might take a look at the MouseInput wiki page for ideas about how to investigate this. In particular, "xinput query-state" will tell you where the guest thinks the mouse pointer is at a given time, and xrandr will tell you about the current guest-internal screen layout.

comment:3 Changed 3 years ago by neplatny.udaj

I'm experiencing exactly the same issue. Windows host, Linux guest. I use 3 display, 2 of which are used in fullscreen for the guest OS. This started happening about two months ago.

I have some observations probably not mentioned in the original ticket:

  • When I grab and hold the window on working screen, I'm able to grab it onto the defunct screen and move it around. Once I release the window, I cannot interact with the window any more using mouse(keyboard works).
  • Whn I run xev, move it's window between the screen and move the mouse from working desktop to the defunct desctop, the last event is this:
    LeaveNotify event, serial 38, synthetic NO, window 0x4c00001,
        root 0x17d, subw 0x0, time 14045868, (102,-7), root:(233,81),
        mode NotifyNormal, detail NotifyAncestor, same_screen YES,
        focus YES, state 16
    
    Nothing else. When doing the same thing when both screens are working, I get these events:
    LeaveNotify event, serial 38, synthetic NO, window 0x4c00001,
        root 0x17d, subw 0x0, time 14045868, (102,-7), root:(233,81),
        mode NotifyNormal, detail NotifyAncestor, same_screen YES,
        focus YES, state 16
    
    FocusOut event, serial 38, synthetic NO, window 0x4c00001,
        mode NotifyGrab, detail NotifyAncestor
    
    ConfigureNotify event, serial 38, synthetic YES, window 0x4c00001,
        event 0x4c00001, window 0x4c00001, (130,86), width 178, height 178,
        border_width 2, above 0x0, override NO 
    
  • I've also tried the xwininfo -tree command from the MouseInput wiki page(the IDs of the window are different than in the previous bullet, because it comes from different session.
    1. Working Screen:
      xwininfo: Window id: 0x4339e96 "#14903 (Second monitor loses mouse interaction) – Oracle VM VirtualBox - Mozilla Firefox"
      
        Root window id: 0x17e (the root window) (has no name)
        Parent window id: 0x161eeba (has no name)
           1 child:
           0x4339e97 (has no name): ()  1x1+-1+-1  +1919+21
      
    2. Defunct screen:
      xwininfo: Window id: 0xa00001 "VBoxClientWndDnD"
      
        Root window id: 0x17e (the root window) (has no name)
        Parent window id: 0x17e (the root window) (has no name)
           0 children.
      

I don't know what that means and how to fix this. Are there some other logs/command I could try to help in analysis?

  • Host: Windows 7 Entrerprise
  • Guest: LMDE Mate Edition (Linux Mint Debian edition)
  • CPU: Core-i7-2640M
  • GPU: AMD Radeon HD 6450M

comment:4 Changed 3 years ago by michael

Can you please try this? Do "ps -ax | grep VBoxClient" and kill the VBoxClient drag and drop processes. Then check to see if this makes a difference. If so this may be a duplicate of ticket #14743.

comment:5 Changed 3 years ago by MCon

Confirmed.

Killing the two processes

 1429 ?        S      0:00 /usr/bin/VBoxClient --draganddrop
 1430 ?        Sl     0:11 /usr/bin/VBoxClient --draganddrop

"cured" my system (mouse is working again).

I assume this may be marked as duplicate; I will follow development of ticket #14743.

comment:6 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Second monitor loses mouse interaction to Second monitor loses mouse interaction -> duplicate of #14743

As I can't subscribe you to that ticket you might want to add a "me too" comment so that you get notifications when it is updated.

comment:7 Changed 3 months ago by dimanne

Virtual box 6.0.0 the issue is still here.

comment:8 Changed 3 months ago by socratis

@dimanne

Please do not open long dead threads. It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of.

For all I know, you posted in two tickets (#14903 and #14743) with "mouse interaction" in the title. Maybe you're seeing the effects of ticket:

  • #18124: Mouse only usable within single application after mouse click on RHEL 7.6.

which is actually a RedHat kernel issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use