Opened 9 years ago

Last modified 3 years ago

#14743 new defect

X11 guests: Invisible drag-and-drop window blocks mouse interaction

Reported by: Stéphane Charette Owned by:
Component: guest additions Version: VirtualBox 5.1.6
Keywords: Cc: MCon, neplatny.udaj, markh, cbennett, frareinif, dabeah, JasonWhitener, darthMuzo, Sam Morris, dobesv, fsv, sancelot
Guest type: Linux Host type: Linux


I first noticed this in v5.0.6, but it just happened to me again in 5.0.8. After several days of using a guest, all of a sudden mouse clicks no longer work. Both left and right mouse clicks do nothing, as if the clicks are not making it to the guest. Moving the mouse works. Guest additions are installed.

When the clicks stop working, the mouse continues working correctly in the host and in other guests running on this host.

Rebooting the affected guest fixes the problem.

I looked through the log file, though I see nothing obvious. In this case, the timestamps in the log indicate the guest was only running for 37 hours and 29 minutes. I'd guess the problem started around 37 hours and 27 minutes. I rebooted it a minute or so after it happened.

Attachments (2)

VBox.log.1 (134.6 KB ) - added by Stéphane Charette 9 years ago.
VBox.log (93.2 KB ) - added by Stéphane Charette 9 years ago.

Download all attachments as: .zip

Change History (29)

by Stéphane Charette, 9 years ago

Attachment: VBox.log.1 added

by Stéphane Charette, 9 years ago

Attachment: VBox.log added

comment:1 by Stéphane Charette, 9 years ago

(I'm not sure if the log file for the guest instance that was rebooted would be vbox.log or vbox.log.1, so I've attached both.)

comment:2 by Michael Thayer, 9 years ago

Hello Stephane, I will take a look at this as soon as I have time, but in the mean-time it would be great if you could do a bit of investigation yourself. I set up a wiki page some time ago about how to investigate mouse input problems in VirtualBox<1>, so perhaps you could take a look at that and use it to find out more about what is going wrong. You could also tell me if (and then how) the page needs to be improved to be more useful to users!



comment:3 by Stéphane Charette, 9 years ago

OK, will run with VBOX_RELEASE_LOG and see what I can come up with.

comment:4 by Stéphane Charette, 9 years ago

I rebooted my host about a week ago, and wasn't running with VBOX_RELEASE_LOG after the reboot. Sorry. But in the meantime, my Linux 15.10 guest did it again after 3 days of uptime. All mouse clicks disappear in the guest.

I'm not in a situation where I can reboot my guest right now, so I tried a few things, like toggling mouse integration, resizing the guest size, etc. Nothing worked. Until I ran this:

sudo killall -HUP VBoxClient

This killed the 8 clients (two each of clipboard, display, seamless, draganddrop) but the mouse has begun working again.

Next time it happens I'll kill just the draganddrop one to see if that fixes it.

comment:5 by Stéphane Charette, 9 years ago

Happened again tonight. I was dragging the mouse with mouse button 1 pushed down to select a block of text in the guest when all of a sudden the mouse stopped working in the guest. Uptime for the guest was 7 days 5 hours.

One particular VBoxClient process (drag-and-drop) has a much higher time than the others:

> ps axjf
    1  1424  1423  1423 ?           -1 S     1000   0:00 /usr/bin/VBoxClient --clipboard
 1424  1426  1423  1423 ?           -1 Sl    1000   0:00  \_ /usr/bin/VBoxClient --clipboard
    1  1434  1433  1433 ?           -1 S     1000   0:00 /usr/bin/VBoxClient --display
 1434  1436  1433  1433 ?           -1 Sl    1000   0:00  \_ /usr/bin/VBoxClient --display
    1  1439  1438  1438 ?           -1 S     1000   0:00 /usr/bin/VBoxClient --seamless
 1439  1441  1438  1438 ?           -1 Sl    1000   0:00  \_ /usr/bin/VBoxClient --seamless
    1  1444  1443  1443 ?           -1 S     1000   0:00 /usr/bin/VBoxClient --draganddrop
 1444  1445  1443  1443 ?           -1 Sl    1000  45:29  \_ /usr/bin/VBoxClient --draganddrop

I killed process 1444, which didn't make a difference.

I killed process 1445, and the mouse started working again in the vm guest.

comment:6 by Stéphane Charette, 9 years ago

Just happened. Two days of uptime. I was selecting a block of text from a terminal window.

This time I went directly to the drag-and-drop vbox client process, and once killed, the mouse (or in my case my Wacom tablet) immediately started to work again.

> ps axf
 1589 ?        S      0:00  \_ (sd-pam)         
 1607 ?        S      0:00 /usr/bin/VBoxClient --clipboard
 1608 ?        Sl     0:00  \_ /usr/bin/VBoxClient --clipboard
 1617 ?        S      0:00 /usr/bin/VBoxClient --display
 1619 ?        Sl     0:00  \_ /usr/bin/VBoxClient --display
 1622 ?        S      0:00 /usr/bin/VBoxClient --seamless
 1624 ?        Sl     0:00  \_ /usr/bin/VBoxClient --seamless
 1627 ?        S      0:00 /usr/bin/VBoxClient --draganddrop
 1628 ?        Sl     7:31  \_ /usr/bin/VBoxClient --draganddrop
 2059 ?        Ssl    0:00 /usr/lib/upower/upowerd
> sudo kill 1628

comment:7 by Stéphane Charette, 9 years ago

This just happened to me again in VB 5.0.14 r105127. Same workaround as before: kill the drag-and-drop VBoxClient and the mouse starts working again.

comment:10 by Stéphane Charette, 8 years ago

I've been using a mouse lately instead of my usual Wacom tablet, and haven't seen the problem. Don't know if there is a link between those two things, or if I've just been lucky.

To those of you also experiencing this problem, are you using a tablet or something other than a "typical" mouse? Maybe we can narrow down the cause.

in reply to:  10 comment:11 by Stéphane Charette, 8 years ago

Replying to StephaneCharette:

Nevermind. I forgot that the last time this happened, I completely disabled Drag and Drop in the VM settings. So I guess I could mention that as another possible workaround if someone wants to ensure they don't run into this issue.

comment:13 by emtezet29, 8 years ago

I am still facing this issue in 5.0.16. It is very annoying and happens when I select text (at least several times per day). In order to return mouse functionality I need to drag&drop text from Host machine. The issue exists since 5.X branch. Apart of that when I drag&drop file (or link from web browser) the operation takes ages, it is not possible to cancel it, machine freezes and the only way is to kill VB.

More info:

I work with two screens, using only mouse, laptop is connected to dock station. Windows 7 Professional 64b is Host, Ubuntu 14.04 is Guest. Installed guest pack.

comment:16 by Tim van Dijk, 8 years ago

Confirmed for V 5.1.4 r110228

comment:18 by Michael Thayer, 8 years ago

Summary: mouse clicks stop working in linux guestsX11 guests: Invisible drag-and-drop window blocks mouse interaction
Version: VirtualBox 5.0.6VirtualBox 5.1.6

I am afraid that due to lack of resources we are not likely to be able to look at this in the foreseeable future. Since this is something that should be debuggable and hopefully fixable by someone with reasonable X11 programming experience I would suggest that someone affected take a look at the problem. I do not know this particular area of our code, but I am generally familiar with how our X11 and Linux Additions work, so I would be able to provide any necessary background knowledge as long as I do not have to invest too much time. Sorry about that, but let's make this an opportunity to get more people involved in VirtualBox development.

comment:19 by amoff, 8 years ago

Replying to StephaneCharette:

I can confirm this issue still exists in 5.1.6 and workaround of rebooting the guest OS is still the best option. For anyone working on this issue privately, my observations:

There does not seem to be a temporal relationship to this glitch. My shortest time before loss of mouse is around 5 minutes and my longer times go days or weeks. I have noticed that loss of mouse "clicking" interaction always comes after a prolonged period of selecting text. I don't know whether it is the act of holding the left mouse button, or of holding the left shift key, of holding the left ctrl key, or some combination of the above, but after around 8-10 seconds of holding these keys/buttons while selecting and manipulating text with the Libre Office spreadsheet program (Ubuntu 16.04 guest on Windows 7 host; quad core laptop, 16 GB RAM) the guest OS ceases responding to my mouse (the Virtualbox machine environment continues to function normally). The problem cannot be remedied by utilizing a USB mouse in place of the touchpad.

Good luck, I hope someone figures this out!

comment:20 by Delorien84, 8 years ago

I can confirm that this happened also on my Linux Guest (Gentoo with KDE5). currently I am on Virtulbox 5.1.10. Fro me it happened sometimes when I select text in terminal, and possible I move the mouse with pressing left mouse button a little (or pressing left control button - start pressing CTRL+C to copy). It seems to me, that it triggers D&D of text, but seems to never complete.

It is very hard to reproduce, and for me it happened randomly. It seems that the bug is triggered by some combination of selecting text, moving mouse and pressed mouse button or keyboard button.

killing following process will free the mouse, again. Then I start the process manually, to get back the drag and drop functionality.

/usb/bin/VBoxClient --draganddrop

comment:21 by _Delorien84, 8 years ago

Ok I am able to reproduce the bug.

  1. I am running Gentoo Linux on Windows 10 hosts. I have three monitor setup, two running Linux guest, one windows. (from left to right, windows M1 - linux M2 - linux M2)
  2. I have KDE konsole running inside Yaukake (on central monitor - M2)
  3. Open some text file inside nano ( As see it is simple bash file with color highlight (may be related)
  4. Select text by mouse holding the left button. Select the text from right to left, and when still holding the left mouse button, move cursor to the M1 monitor where is the host Windows 10.
  5. After that mouse click does not work. Cursor also change.

See for video how to reproduce the bug.

Last edited 8 years ago by _Delorien84 (previous) (diff)

comment:23 by Michael Thayer, 8 years ago

Unfortunately the people on the team who would be able to investigate this are all taken up with higher priority tasks. It would really make sense for someone affected to build the Guest Additions themselves<1> on an affected guest so that they can debug the issue (using the wiki instructions<2> and running VBoxClient in gdb).


comment:24 by Michael Thayer, 8 years ago

Cc: MCon neplatny.udaj markh cbennett frareinif dabeah JasonWhitener darthMuzo Sam Morris dobesv fsv sancelot added

Added MCon, neplatny.udaj, markh, cbennett, frareinif, dabeah, JasonWhitener, darthMuzo, yrro, dobesv, fsv, sancelot to the CC list.

comment:25 by jonver, 8 years ago

I'm experiencing this problem too.

As a temporary fix, I'm changing the display settings (dual-monitor -> single-monitor and back), which unlocks the mouse.

comment:26 by sancelot, 8 years ago

I setted up dnd debug in my linux guest . I have not setted up in my host, since it is described how to set it up, but it would be useful knowing how to remove it too.

the vboxclient.log is : DnD: Proxy window=0xe00001, root window=0x17b ... 16:14:30.088086 00007fe2f13e3780 main DnD: Started 16:14:30.088092 00007fe2f13e3780 main DnD: 5.1.10r112026 08:08:59.971628 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:00.072680 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:00.177858 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:00.281360 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:00.382084 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:00.486533 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:00.589088 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:00.925818 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:01.025877 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:01.126074 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:01.227321 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:01.328363 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:01.433286 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>') 08:09:01.534940 00007fe2f13e3780 main DnD: New guest source window 0x3400003 ('<No name>')

comment:27 by Nils, 7 years ago

$ sudo apt-get install gcc g++ bcc iasl xsltproc uuid-dev zlib1g-dev libidl-dev \

libsdl1.2-dev libxcursor-dev libasound2-dev libstdc++5 \ libhal-dev libpulse-dev libxml2-dev libxslt1-dev \ python-dev libqt4-dev qt4-dev-tools libcap-dev \ libxmu-dev mesa-common-dev libglu1-mesa-dev \ linux-kernel-headers libcurl4-openssl-dev libpam0g-dev \ libxrandr-dev libxinerama-dev libqt4-opengl-dev makeself \ libdevmapper-dev default-jdk python-central \ texlive-latex-base \ texlive-latex-extra texlive-latex-recommended \ texlive-fonts-extra texlive-fonts-recommended

Reading package lists... Done Building dependency tree Reading state information... Done Note, selecting 'acpica-tools' instead of 'iasl' Note, selecting 'linux-libc-dev' instead of 'linux-kernel-headers' Package python-central is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Unable to locate package libhal-dev E: Package 'python-central' has no installation candidate

...if someone can help me build it, I'm willing to debug. Just ran into this with a win7 host, debian stretch guest, and a page where Firefox keeps hanging. Killing VboxClient --draganddrop made the mouse work again.

VB 5.1.26

Last edited 7 years ago by Nils (previous) (diff)

comment:28 by Segfault, 6 years ago

This bug is still around. I'm running Linux guest on Linux host and the mouse comes completely unusable. Unlike other users here the mouse will not work on outside of VM window nor does it work on the second screen. The only way to restore mouse functionality is Ctrl+Alt+F8 followed by Ctrl+Alt+F7. (X is running on tty7)

comment:29 by pentagonik, 6 years ago

Can you please try with the latest test build for VirtualBox 5.2? You can get the latest test builds on the Testbuilds page.

Please note that also the Guest Additions of this test build need to be installed on the guest, followed by a guest reboot.

Let me know if this fixes the issue for you. Thank you!

comment:30 by dimanne, 6 years ago

Virtual box 6.0.0 - the issue is still here.

comment:31 by Socratis, 6 years ago


Please do not open long dead threads. It's usually better and faster, if issues get first addressed in the VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of.

For all I know, you posted in two tickets (#14903 and #14743) with "mouse interaction" in the title. Maybe you're seeing the effects of ticket:

  • #18124: Mouse only usable within single application after mouse click on RHEL 7.6.

which is actually a RedHat kernel issue.

comment:32 by Jonas D., 4 years ago

Confirming the issue is still in 6.1.0

@socratis: I'm sure it's this issue, verified with xprop that the blocked area reports as a VBoxClientWndDnD

XdndAware(ATOM) = BITMAP WM_NAME(STRING) = "VBoxClientWndDnD"

The issue seems to be appearing more and more, breaking workflow on a desktop as it's always residing in the top-left, blocking a significant chunk of the screen.

On a widescreen 4k (21:9) screen, in-VM resolution: 3768x1492 (maximized within ubuntu)

edit: note that the issue appears at random intervals; without any pointable root cause so far

Last edited 4 years ago by Jonas D. (previous) (diff)

comment:33 by HelloFriend, 3 years ago

Windows 10 host VirtualBox Version 6.1.22 r144080 (Qt5.6.2) XUbuntu 18.04 client

This has been happening for a long time. But recently I forgot to not drag & drop so hit it again.

This happens to me after a drag and drop sometimes. It's happened for drag and drops within the client and from the client to the host.

Until the drag and drop operation, I'm able to use the mouse as expected clicking on windows in the client with both left and right mouse buttons the clicking behavior is as expected. After the drag and drop, the left half of the client window doesn't receive mouse clicks. I'm unable to drag windows, change focus using the mouse, and right clicks don't bring up a menu. The right half of the screen behaves as normal: dragging windows, changing window focus, and right clicking to bring up a context menu all work.

To fix this I shutdown the VM and start it up again.

comment:34 by Jörg Skottke, 3 years ago

CC me

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use