VirtualBox

Ticket #14469 (closed defect: duplicate)

Opened 22 months ago

Last modified 21 months ago

VERR_CFGM_NODE_EXISTS Error When Exporting than Importing Appliances on VirtualBox 5 => fixed in SVN/5.0.x

Reported by: asayler Owned by:
Priority: major Component: other
Version: VirtualBox 5.0.2 Keywords: VERR_CFGM_NODE_EXISTS export
Cc: Guest type: other
Host type: other

Description

Whenever I export a VM from VirtualBox 5, and then import it via VirtualBox 5, I get the following error when I try to boot the newly imported VM:

--- A new node couldn't be inserted because one with the same name exists. (VERR_CFGM_NODE_EXISTS).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed} ---

I have confirmed the issue on the following systems:

Ubuntu 14.04 w/ VirtualBox 5.0 Ubuntu 15.04 w/ VirtualBox 5.0.2r102096 Windows 10 w/ VirtualBox 5.0.2r102096

I have also confirmed it with a range of guest and dummy (e.g. no loaded OS VMs). Importing VMs created in VirtualBox 4.X still works fine. So it seems to be a problem in the VirtualBox 5 export code. Currently, I am unable to create a working export using VirtualBox 5.

I've attached the log from two of the failure, but as I mention above, this happens regardless of the type/size/OS of VM I am exporting. I'll also try to attach a copy of one of the broken ova exports.

Attachments

test1.ova Download (83.0 KB) - added by asayler 22 months ago.
VirtualBox 5 Broken OVA Export
VBox.log Download (2.3 KB) - added by asayler 22 months ago.
Log from Failed Boot post Import
VBox.2.log Download (2.4 KB) - added by asayler 22 months ago.
Log from another failed boot post-import

Change History

Changed 22 months ago by asayler

VirtualBox 5 Broken OVA Export

Changed 22 months ago by asayler

Log from Failed Boot post Import

Changed 22 months ago by asayler

Log from another failed boot post-import

comment:1 Changed 22 months ago by asayler

Issues also occurs on Windows 10 w/ Virtualbox 5.0.3r102166

comment:2 Changed 22 months ago by asayler

Exporting the same VMs from VirtualBox 4.3 and then importing them into VirtualBox 5 works fine, so this definitely seems to be an isue with teh VirtualBox 5 export process.

Last edited 22 months ago by asayler (previous) (diff)

comment:3 Changed 22 months ago by aeichner

  • Summary changed from VERR_CFGM_NODE_EXISTS Error When Exporting than Importing Appliances on VirtualBox 5 to VERR_CFGM_NODE_EXISTS Error When Exporting than Importing Appliances on VirtualBox 5 => fixed in SVN/5.0.x

Will be fixed in the next maintenance release, please try the latest testbuild from https://www.virtualbox.org/wiki/Testbuilds

comment:4 Changed 21 months ago by lavanchy

workaround:

  1. Open VirtualBox GUI
  2. go to the the new VM (imported appliance)
  3. select USB tab
  4. disable USB
  5. enable USB
  6. start the new VM (imported appliance)

comment:5 Changed 21 months ago by EricK

Still getting error below:

Failed to open a session for the virtual machine vagrant-test_default_1440543598198_19718.

A new node couldn't be inserted because one with the same name exists. (VERR_CFGM_NODE_EXISTS).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Using latest test build VirtualBox VM 5.0.3 r102322 darwin.amd64 (Aug 25 2015 02:07:36) release log

comment:6 Changed 21 months ago by aeichner

The error will still happen with appliances exported before the fix. You have to re export the VM with the fixed build in order to get rid of the error.

comment:7 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Closing this as duplicate of #14462 as it's the same issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use