VirtualBox

Ticket #14462 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Duplicate OHCI controller in OVF export => fixed in SVN/5.0.x

Reported by: mayfiecs Owned by:
Priority: major Component: OVF
Version: VirtualBox 5.0.2 Keywords: OHCI, VERR_CFGM_NODE_EXISTS
Cc: Guest type: other
Host type: other

Description

For some reason, when exporting an appliance the following line gets duplicated in the OVF file:

<Controller name="OHCI" type="OHCI"/>

Steps to reproduce:

  1. Create a new VM (default options; any type)
  2. Export Appliance to OVF 1.0 (test.ova file)
  3. Import Appliance (the file you just exported)
  4. Try to start the imported VM...error message:

A new node couldn't be inserted because one with the same name exists. (VERR_CFGM_NODE_EXISTS). Result Code: NS_ERROR_FAILURE (0x80004005) Component: ConsoleWrap Interface: IConsole

You can work around this bug by extracting the ova file, removing the duplicate OHCI line, and re-creating the ova file using tar. It's not possible to remove the extra OHCI using the GUI.

(No VBox.log file attached, because there was no session.)

Attachments

2015-08-17 17_35_58-Oracle VM VirtualBox Manager.png Download (8.3 KB) - added by ripleymj 2 years ago.

Change History

Changed 2 years ago by ripleymj

comment:1 Changed 2 years ago by ripleymj

The bug is subtly shown in the GUI. If you toggle the OHCI controller, it will rewrite the configuration correctly.

comment:2 Changed 2 years ago by aeichner

  • Summary changed from Duplicate OHCI controller in OVF export to Duplicate OHCI controller in OVF export => fixed in SVN/5.0.x

Thanks for the report, will be fixed in the next maintenance release.

comment:3 Changed 2 years ago by lavanchy

workaround:

  1. Open VirtualBox GUI
  2. go to the the new VM (imported appliance)
  3. select USB tab
  4. disable USB
  5. enable USB
  6. start the new VM (imported appliance)

comment:4 Changed 2 years ago by nghianja

The workaround by lavanchy does not work for me but a variation of it does:
i.e. switch the version of USB, e.g. I switched from usb 2.0 to usb 3.0 and it boots.

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.4.

comment:6 Changed 2 years ago by nunnsby

Workaround: Additional info (I am running v5.0.4r102546, x64, vanilla (no ext-pack) and still had the problem)

  1. Select usb 3.0
  2. Check error (wants you to install extension pack (I don't have it, and did NOT install it yet)
  3. Select usb 1.1
  4. Restart
  5. Should work (did for me - without installing extension pack)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use