VirtualBox

Ticket #14411 (reopened defect)

Opened 2 years ago

Last modified 5 months ago

mini-toolbar is missing when guest VM is set to full screen.

Reported by: Neldogz Owned by:
Priority: major Component: guest control
Version: VirtualBox 5.0.0 Keywords: mini-toolbar missing
Cc: Guest type: Windows
Host type: Linux

Description

Both the mini-tool bar and bottom bar are unavailable when the guest VM is set to full screen. I have tested on both Ubuntu 15.04 and a Windows 7 64-bit professional guests.

I tried resinstalling the guest additions and rebooting but this did not fix the issue. I have also tried removing the option for 3d acceleration from both guests and rebooting but the same problem persists. Virtualbox extensions are also installed.

Host details:

Linux computer1 4.1.4-1-ARCH #1 SMP PREEMPT Mon Aug 3 21:30:37 UTC 2015 x86_64 GNU/Linux GNOME Shell 3.16.3 Virtualbox version 5.0.0_OSE r101573

Cycling into and out of fullscreen using Ctrl+F does not restore the mini-toolbar. It is important to note that the mini-tool bar does appear in seemless mode.

Ctrl+home key brings up an alternate mini-toolbar menu which is a workaround until this bug is fixed.

There have been others who reported similar issues with the mini-toolbar ranging back 10 months to 3 years ago but no fix was provided.

Reference:

https://www.virtualbox.org/ticket/9775 https://www.virtualbox.org/ticket/10599

Attachments

VBox.log Download (100.5 KB) - added by Neldogz 2 years ago.
Vbox.log

Change History

Changed 2 years ago by Neldogz

Vbox.log

comment:1 Changed 2 years ago by Neldogz

This issue is confirmed to be fixed within test build release Linux 64-bit 5.0.x revision 101939

Reference: https://www.virtualbox.org/wiki/Testbuilds

The tool bar works perfectly in this test build on the following system:

Linux computer1 4.1.4-1-ARCH #1 SMP PREEMPT Mon Aug 3 21:30:37 UTC 2015 x86_64 GNU/Linux GNOME Shell 3.16.3 VirtualBox Version 5.0.1 r101939

Last edited 2 years ago by Neldogz (previous) (diff)

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for letting us know! The fix is part of VBox 5.0.2.

comment:3 Changed 2 years ago by brenth

If missing mini toolbar issue was fixed in VirtualBox 5.0.2 I can confirm absolutely that it is now un-fixed ... again ... in 5.0.8. VirtualBox host is 64-bit (POS) Windows 10 Pro, guest is virgin 64-bit Ubuntu 15.10 and mini toolbar is certainly missing. However, an existing Lubuntu 15.04 guest on same Windows host with identical VirtualBox settings mini toolbar is present. Does this make sense?

comment:4 Changed 2 years ago by codex22

I'm having the same problem as brenth - VirtualBox 5.0.8, Windows 10 Pro 64 bit host, Ubuntu 15.10 guest, mini toolbar only showing on the login screen.

I sometimes get some screen flicker as well, during which I can spot the mini toolbar sometimes.

comment:5 Changed 2 years ago by codex22

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:6 Changed 2 years ago by mikebranski

The mini toolbar doesn't show up at all (including login) in Virtualbox 5.0.10 on Windows 10 Pro 64-bit, using an Ubuntu Server 14.04 VM.

In addition, I could get the mini toolbar menu to appear like @Neldogz mentioned, but I had to hit Ctrl + [Host Key] + Home.

comment:7 Changed 20 months ago by Amarsanaa

Mine as well in full screen mode. Virtual Box Version 5.0.17 r106155, Windows 10 Pro 64-Bit, Ubuntu 14.04 LTS. I've installed the test build but nothing is changed. Please help me.

comment:8 Changed 19 months ago by John A.

This seems to have regressed again in 5.0.20. Windows 10 Pro 64-bit Host, Fedora 23 (GNOME 3.18).

When booting, during the standard terminal phase, and when GDM is displayed for login, the mini-toolbar is present. When gnome proper starts up, the tool bar disappears.

There's a bit more info than this though. I think it has something to do with how gnome is handling an X windows session. I don't use graphical sessions a lot, but I seem to recall that when using them, tty0 is where GDM (the login screen) is displayed. After logging in to the windows manager, the desktop manager *replaced* GDM on tty0, and your session continued from there. Now, however, on Fedora 23, when I login to GDM on tty0, a new Xorg/GNOME session spawns on tty1, and the terminal switches there. At this point, the mini-toolbar dissapears. However, if I <ctrl>-<alt> F1, I go back to tty0, and GDM, and I see the mini-toolbar. If I then <ctrl>-<alt> F3, I go to a normal getty login prompt on tty2, and I can see the mini-toolbar. When I <ctrl>-<alt> F2, back to tty1, the mini-toolbar is missing. This may have something more to do with gnome than VBox, but I don't know much about how VBox handles switching between ttys. It could also be that I somehow misconfigured Xorg when I was trying to get acceleration working (or perhaps this is how 3D acceleration is handled)?

Do any other users experience this behavior when switching TTYs in their Linux guest? For now my workaround will just be to switch to tty0 when I need to use the toolbar. Also of note, if I start the VM in detachable mode, I do not have this problem.

Last edited 19 months ago by John A. (previous) (diff)

comment:9 Changed 19 months ago by John A.

After further testing it appears as though the tty allocation thing isn't related. It's just how Fedora handles user desktop switching. The real culprit appears to be that the mini-toolbar isn't "on top" of the desktop.

It's rendered behind the desktop. If I go into full screen mode, and then adjust my display size to be smaller than my monitor resolution, I can access the mini toolbar. I have a black border around my Xorg screen, but the mini toolbar is there.

When 3D acceleration is disabled, this problem completely disappears and the mini-toolbar is always on top of the console. So I think maybe it's a rendering problem?

comment:10 Changed 17 months ago by JAResearch

I observe the disappearing mini-toolbar as well.

I have a 64-bit Windows 7 Professional Guest running on a Fedora 23 host.

I can confirm John A's observation that adjusting the screen resolution reveals the mini-toolbar. I have similar results if I simply toggle out of and back into full screen mode.

For me, the mini-toolbar is visible as long as the guest remains visible on the host. It's there when I boot the guest and remains after I toggle out of/into full screen mode. If I minimize the guest or switch virtual desktops on the host (thus hiding the guest), the mini-toolbar disappears.

This behavior occurs whether the mini-toolbar is "pinned" or not, and whether the mini-toolbar is placed at the top or bottom of the guest screen.

comment:11 Changed 17 months ago by Baobab33

I'm running Ubuntu 16.04 brand new install as host, and Windows 7x64 as guest (old but well working image on my previous Ubuntu 14.04 host) and i'm running VirtualBox Version 5.0.24 r108355 (needless to say that the VM extension pack is installed and the guest additions too)

i have the same issue and it is connected with the KEYBOARD CAPTURE

if keyboard capture is on (either in general parameters or through the host key x 1 push) then the mini-toolbar disappears, otherwise it is present, even in full screen

My issue is also linked with another problem : i'm using Compiz and I need the borders to remain sensitive to my mouse so that i can go back to my other desktops (cube rotation). Now it is not possible anymore when i'm in full screen (so i first have to come back to another screen mode before being able to rotate my cube)

Moreover, before the keyboard capture was always on and I could use the Alt+Tab switching inside Windows when I was working in windows automatically. Now I have to deactivate the kb for being able to get the mini-toolbar, so i'm loosing the alt+tab feature

other bugs :

  • in integrated (host + L) screen mode, i'm loosing the background of MS-Windows
  • there are some text information bubbles on the top of my screen and there is no way to make them disappear (the check box for closing it does not work)
  • when the mini-toolbar is present in fullscreen is it often in the bottom of a 640x380 windows (i mean floatting in the middle of nowhere instead of being in the bottom of my full screen)
Last edited 17 months ago by Baobab33 (previous) (diff)

comment:12 Changed 5 months ago by JustDebian

Post deleted here so as not to double post.

Last edited 5 months ago by JustDebian (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use