VirtualBox

Ticket #1353 (closed defect: wontfix)

Opened 6 years ago

Last modified 6 years ago

Problems when discarding snapshots without enough free disk space on the host

Reported by: Boxster Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.6 Keywords: snapshot
Cc: Guest type: other
Host type: other

Description

When the hard disk of the host has not enough free space left to perform discarding an older snapshot, the action aborts with an error when the disk is completely full.

The problem is, that the merge of the image to the next is not completed yet. The "old" image is not deleted, but the entry in the xml file (and therefore in the GUI manager) of the virtual machine is gone. So the system is in an invalid state.

It seems that the guest still runs normally.

Change History

comment:1 in reply to: ↑ description Changed 6 years ago by Bolderbast

Replying to Boxster:

I noticed the same. Seems like the XML is altered before the discarting starts, or after the discarting finishes even if it fails.

This should be changed so that the XML is only altered after de discarting was SUCCESFUL...

When you manually enter the snapshot info back into the XML, the snapshot CAN be re-discarted.

comment:2 Changed 6 years ago by dmik

  • Status changed from new to closed
  • Resolution set to wontfix

The problem is that the current code is organized so that discarding (and other similar operations) is done in several irreversible steps (for example, the diff being discarded is merged right into its child diff, not to a separate file). Therefore if it fails at one of such steps, the XML and the diffs (except some rare cases) become inconsistent. The fact that you can restore XML manually and re-discard is just your good luck in some particular case.

Anyway, the new hard disk implementation is being worked on which will be more flexible and fail-tolerant in this regard. The current implementation is not going to be fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use