VirtualBox

Ticket #11467 (closed defect: worksforme)

Opened 15 months ago

Last modified 5 months ago

BSOD when Win8 x64 goes to Hybrid Shutdown

Reported by: piotrb Owned by:
Priority: major Component: network
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: all
Host type: Windows

Description

Host OS: Windows 8 Pro AMD64

VirtualBox's 4.2.6 VboxNetFlt driver causes BSOD 0x9F (DRIVER_POWER_STATE_FAILURE). See minidump and analyze log of memory.dmp.

Attached is the WinDbg log of the crash dump with !analyze -v and !irp <blocked_IRP> commands executed.

Attachments

minidump.zip Download (93.2 KB) - added by piotrb 15 months ago.
log.txt Download (9.5 KB) - added by piotrb 15 months ago.
Windbg log

Change History

Changed 15 months ago by piotrb

Changed 15 months ago by piotrb

Windbg log

comment:1 Changed 14 months ago by anshul makkar

Hi,

We have been unable to reproduce the crash in the lab.

Please can you share the exact details of what all operations you performed when the crash is observed and what is the guest that you are using. Is it repetitive and reproducible?

comment:2 Changed 14 months ago by frank

Also, how often do you see this BSOD -- on every shutdown of the host?

comment:3 Changed 14 months ago by anshul makkar

And also please can you let us know if the guest network was configured in bridged or NAT mode. ?

comment:4 Changed 14 months ago by frank

Is anybody else experiencing the same problem and can answer the above questions?

comment:5 Changed 14 months ago by piotrb

„1) Please can you share the exact details of what all operations you performed when the crash is observed and what is the guest that you are using. Is it repetitive and reproducible? 2) Also, how often do you see this BSOD -- on every shutdown of the host? 3) And also please can you let us know if the guest network was configured in bridged or NAT mode. ?”

Crash happened at hybrid shutdown of host. Guests: Windows XP, Debian Wheezy, Fedora 19. All were turned off at least a few minutes before turning off the computer. Crash happened often(but not every time) at hybrid shutdown. Guest network was bridged. On the same network adapter runs Qbik Wingate7 NAT. Solution for me was:

  1. Remove VirtualBox Bridged Networking Driver from network connections
  2. Switch virtual machines to Host only adapter
  3. Make bridge in system between host only adapter and adapter connected to home LAN.

Since then, this bsod didn't occur.

comment:6 Changed 14 months ago by anshul makkar

Even with the above steps, crash is not reproducible in the lab.

Working on the issue to find a fix.

comment:7 Changed 13 months ago by anshul makkar

The reporter of the issue has informed that the issue is not reproducible after updating the NIC driver. So , if facing this issue, please update your NIC driver. If, still facing the issue, please update the bug with the error report.

comment:8 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use