VirtualBox

Ticket #1076 (closed enhancement: fixed)

Opened 6 years ago

Last modified 4 years ago

error message not helpful when machine description file was opened with newer release of VBox

Reported by: ugemkow Owned by:
Priority: trivial Component: GUI
Version: VirtualBox 1.5.4 Keywords: error handling, error messages
Cc: Guest type: other
Host type: other

Description

I created a VM with 1.5.0 and later opened this VM with 1.5.4. When trying to open this vm with 1.5.0 again, an error message is printed and the start fails because 1.5.4 has added tags to the machine description which the old release does not understand. This has two aspects IMHO:

  • It should IMHO be possible to exchange VMs in the same release (1.5.x) series without an error in case of regressions
  • The printed error message is rather long but not very helpful. At least the tag on which the reading fails, should be printed.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

As of version 3.1.0, VBox changed the handling of the VM settings. XML format changes are now handled more tolerant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use