VirtualBox

Ticket #1075 (closed enhancement: wontfix)

Opened 6 years ago

Last modified 4 years ago

Invalid snapshot because of parent modification not detected

Reported by: ugemkow Owned by:
Priority: minor Component: VM control
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

We are using a configuration, which is not really "standard" on Linux host with Windows XP guest:

We are using a shared VDI which is used readonly used by several client, which create their own snapshot derived from this VDI, so each user has his own "virtual installation" based on this common base vdi.

When modifying this common vdi (installation of a changed base install), VBox does not detect that the snapshots derived from the old install are invalid.

The could be prevented by a simple timestamp in the vdi and its snapshots.

I know, this problem will not occur when using VBox "as designed" so please close this ticket when appropiate

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to VM control

comment:2 Changed 4 years ago by Technologov

Due to a total rewrite of Snapshot feature in VBox 3.1, this bug seems no longer relevant. Please close it.

ugemkow: If you want to reopen it, please take a look at v3.1 first.

-Technologov

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to wontfix

Works as designed. If you change the parent image behind our back, then all snapshots become invalid. The only options you have is to delete all snapshots or to pass the modification to all snapshots.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use