VirtualBox

Ticket #10753 (closed defect: duplicate)

Opened 22 months ago

Last modified 18 months ago

Taking snapshot of running system produces assertion error

Reported by: EdMcMan Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.1.18 Keywords: crash snapshot
Cc: Guest type: Linux
Host type: Linux

Description

I am running VirtualBox 4.1.18 on a Linux host, with a Linux guest.

If I try to take a snapshot from the command line when the VM is running, I get the following assertion errors:

Message from syslogd@localhost at Jul 12 10:58:05 ...
 kernel:[6742275.026319] 

Message from syslogd@localhost at Jul 12 10:58:05 ...
 kernel:[6742275.026320] !!Assertion Failed!!

Message from syslogd@localhost at Jul 12 10:58:05 ...
 kernel:[6742275.026321] Expression: <NULL>

Message from syslogd@localhost at Jul 12 10:58:05 ...
 kernel:[6742275.026322] Location  : /home/vbox/vbox-4.1.18/src/VBox/VMM/VMMAll/PGMAllBth.h(1458) void pgmR0BthAMD64AMD64SyncPageWorkerTrackDeref(VMCPU*, PGMPOOLPAGE*, RTHCPHYS, uint16_t, RTGCPHYS)

Message from syslogd@localhost at Jul 12 10:58:05 ...
 kernel:[6742275.026489] HCPhys=0000000127ae6000 wasn't found!

If the VM is not running, I can take the snapshot without a problem.

I am running from VBoxHeadless.

Change History

comment:1 Changed 22 months ago by frank

Are you talking about life snapshots, that is, does VBoxManage snapshot VM_NAME take SNAPSHOT_NAME --pause work? If so then this is a duplicate of #9255.

comment:2 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use