VirtualBox

Ticket #9255 (closed defect: fixed)

Opened 3 years ago

Last modified 8 months ago

live snapshot broken, Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION)

Reported by: ctr Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

After upgrading to VirtualBox 4.1, I can no longer take snapshots of some virtual machines while they are running.

The VBox.log file attached is for a test with a Windows XP guest running on a Windows 7 x64 host.

(P.S. For a Fedora 14 guest running on the same host, taking a snapshot while running is taking ages to complete (>10 min so far) although there is not yet an error message.)

Attachments

VBox.log Download (217.5 KB) - added by ctr 3 years ago.
VBox.2.log Download (199.2 KB) - added by Zium 3 years ago.
VBox-Fedora14Guest.log Download (54.0 KB) - added by ctr 3 years ago.
VBox_RHEL6.log Download (262.6 KB) - added by go3mon 3 years ago.
Trying to take snapshot on running guest RHEL6
VBox.3.log Download (273.5 KB) - added by tnurkkala 3 years ago.
Failure when attempting to snapshot a live VM (Ubuntu 11.04) on a Mac OS X Lion host

Change History

Changed 3 years ago by ctr

Changed 3 years ago by Zium

comment:1 Changed 3 years ago by Zium

After upgrade to VirtualBox 4.1, if host memory is low VM crashes.

Host is Windows XP SP2, guest is ubuntu or Windows XP.

The VBox.2.log attached is for a Windows XP guest.

comment:2 Changed 3 years ago by ctr

That Fedora 14 guest snapshot took > 1h (I went home), but this morning it had failed with an error VERR_SSM_TOO_MANY_PASSES. I am attaching the log file as VBox-Fedora14Guest.log.

Changed 3 years ago by ctr

Changed 3 years ago by go3mon

Trying to take snapshot on running guest RHEL6

Changed 3 years ago by tnurkkala

Failure when attempting to snapshot a live VM (Ubuntu 11.04) on a Mac OS X Lion host

comment:3 Changed 3 years ago by klaus

  • Guest type changed from Windows to other
  • Summary changed from Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION) with a Windows XP guest in a Windows 7 x64 host to live snapshot broken, Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION)

comment:4 Changed 3 years ago by klaus

This apparently is a generic breakage of taking live snapshots. It is actually unintentional that the GUI is capable of taking live snapshots (it should only take online snapshots for running VMs), however it is possible using the "Camera" icon in the snapshot tree view.

So the workaround is to avoid this way of taking snapshots of running VMs. Use only the menu item Machine->Take Snapshot... as this works reliably.

comment:5 Changed 3 years ago by phr33k

The same problem appears when taking online snapshots via the VBoxManage snapshot command. Different VMs with Windows and Linux crashes. They all have the latest GuestAdditions installed. Hostsystem is a Debian Squeeze.

comment:6 Changed 3 years ago by bauner

same error on ubuntu 11.04 64bit host with 32bit xp and s2k3 guests.

vboxmanage snapshot w2k3 take "snapshot vom $(date "+%Y-%m.%d %H:%m")" gives Guru Meditation -2701 error if the VM is running

for me snapshots working with menu machine -> Take Snapshot and with vboxmanage on paused vm vboxmanage snapshot w2k3 take "snapshot vom $(date "+%Y-%m.%d %H:%m")" --pause

comment:7 Changed 3 years ago by frank

Correct, the --pause parameter is the proposed workaround.

comment:8 Changed 3 years ago by DHughes

I have the same issue since upgrading to 4.1 I get a pop-up with: NS_ERROR_FAILURE (0x80004005)

comment:9 Changed 3 years ago by frank

Zium, your problem is a duplicate of #9373.

comment:10 Changed 3 years ago by vega

Is there any chanсe to get a fix?

comment:11 Changed 3 years ago by frank

  • Version changed from VirtualBox 4.1.0 to VirtualBox 4.1.4

Yes, we are working on it but unfortunately it will take more time. I will get you informed when this issue is fixed.

comment:12 Changed 2 years ago by robert@…

Seeing this issue also with Win 7 guest on 50GB dynamic HD, running on Fedora 15 host. Version 4.1.4. Strikingly, Save State works fine for a Win XP guest on a 20 GB dynamic disk on the same linux host.

comment:13 Changed 2 years ago by rage

Same issue with an Ubuntu 10.04 server guest on an Ubuntu 10.04 server host. The guest works fine on other similarly configured hosts, it seems to occur only on this one machine.

comment:14 Changed 2 years ago by chrulri

Still not working in 4.1.6

comment:15 Changed 2 years ago by freeformz

I am experiencing this error as well. Really frustrating because I was able to do snapshots just fine while building the base image that I'm using. But now that I'm using a copy of that image it bombs.

comment:16 Changed 2 years ago by ox11

unfortunately still there in 4.1.8

comment:17 Changed 2 years ago by si458

is this still an on going issue?

im having no problems with snapshots in 4.1.12 (Host: server 2008 r2, Guest: Windows XP Pro)

and everytime i try to take a snapshot using the phpvirtualbox, it wont let me because of this ongoing issue

comment:18 follow-up: ↓ 19 Changed 2 years ago by icemanoich

Still not working in 4.1.14. Ubuntu 11.10 as a host and Ubuntu 10.10 as a guest. Work only if I safe state of VM (auto power off) and then I can take snapshot.

When this bug will be fixed?

comment:19 in reply to: ↑ 18 Changed 2 years ago by frank

  • Description modified (diff)

Replying to icemanoich:

Still not working in 4.1.14. Ubuntu 11.10 as a host and Ubuntu 10.10 as a guest. Work only if I safe state of VM (auto power off) and then I can take snapshot.

That's not true. It should be sufficient if you pause the VM (VBoxManage snapshot VM_NAME take SNAPSHOT_NAME --pause. If the VM is not paused then this is a live snapshot, which does not work, but taking a snapshot from a paused VM should work (and it works here).

We will eventually fix the live snapshot problem but currently there are other higher-priority items.

comment:20 Changed 2 years ago by gcc

If the real fix is difficult, please could you at least stop it from crashing the virtual machine if you forget to use --pause? E.g. refuse to take a snapshot if the system is running?

comment:21 Changed 20 months ago by alphapapa

I just lost an hour of work because I thought that if a command was in vboxmanage it would work, rather than crashing the entire VM for no reason--how silly of me. If it doesn't work, REMOVE THE COMMAND!

What is a higher priority than DATA LOSS CRASH BUGS? What is so hard about disabling broken code??

comment:22 follow-up: ↓ 23 Changed 17 months ago by klausthorn

still there with 4.2.0r80737, Ubuntu 12.04 64bit Host and 32bit Client. The Host has the extension pack installed (providing RDP etc.).

I used "VBox... snapshot ..." with the running VM.

So for 16 months there have been worse issues than this, preventing a fix? It seems I overestimated the stability dramatically.

Last edited 17 months ago by klausthorn (previous) (diff)

comment:23 in reply to: ↑ 22 Changed 17 months ago by klausthorn

to manually recover, I had to

  • replace the new NAME.vbox with the old NAME.vbox-pre file
  • edit this recovered NAME.vbox file to remove the line(s) Harddisk (ABC-123.vdi) created by the snapshot
  • remove the Snapshots/ABC-123.vdi (may be optional, but it is confusing to leave it there)

comment:24 Changed 17 months ago by frank

I admit that this is an annoying behavior. We will work on that bug soon as there is customer demand but in the mean time it's indeed the right fix to disable that functionality until this bug is fixed. The workaround to pause the VM still works but I think we should always pause the VM, even if the user didn't specify that.

comment:25 Changed 17 months ago by ...don

But, it is not just with running VMs. I have a similar problem with restoring an earlier snapshot and deleting an intervening one. I would end up with multiple Harddisk lines and a corrupt VM. This has also been a long running bug, although it has been happening less with more recent releases. However, it was impacting my testing environment to such an extent, that I have given up on using VirtualBox snapshots, and have, instead, started using btrfs filesystem snapshots.

comment:26 Changed 11 months ago by thewinelake

Can I, as a customer, say that I have a demand for this?

I'm slightly surprised that working live snapshots is seeingly considered such an esoteric request!

Or maybe it's fixed, but you forgot about this thread?

Last edited 11 months ago by thewinelake (previous) (diff)

comment:27 Changed 11 months ago by frank

As a customer you should go through your Oracle support channel.

comment:28 Changed 8 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 4.2.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use