VirtualBox

Ticket #10338 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

Unable to close/resume virtual machine after it fails to save it's state

Reported by: Olek Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords: Save
Cc: Guest type: Windows
Host type: Linux

Description

Steps:

  • Run VM (WinXp)
  • Click File/close then choose "save machine state" option
  • you should have low disk space on your HDD to get popup with Error: "SOME_UNABLE_TO_WRITE_ERROR"
  • Click OK to close popup

Actual:

Machine unresponsive. Unable to Close/Kill/Restore it from menu

Expected:

Be able to finish work with VM somehow.

Attachments

Screenshot-34.png Download (130.9 KB) - added by Olek 2 years ago.
VBox.log.2 Download (49.3 KB) - added by Kissaki 2 years ago.

Change History

Changed 2 years ago by Olek

comment:1 Changed 2 years ago by frank

This information is not sufficient. It can only happen in certain cases that the VM cannot be terminated properly. A VBox.log file is missing which would show the actual error message.

Changed 2 years ago by Kissaki

comment:2 Changed 2 years ago by Kissaki

I was able to reproduce the issue – or rather, it happened to me as well.

I attached a log file. The last lines:

00:58:04.672 Changing the VM state from 'SUSPENDED' to 'SAVING'.
00:58:04.876 ssmR3StrmWriteBuffers: Write failed with rc=VERR_DISK_FULL at offStream=0x4bbc1
00:58:04.876 SSM: Execute save failed with rc=VERR_DISK_FULL for data unit 'pgm'/#1.
00:58:04.879 SSM: Failed to save the VM state to 'F:\VirtualBox\VM\Ubuntu 64Snapshots\2012-05-06T17-58-53-933371300Z.sav' (file deleted): VERR_DISK_FULL
00:58:04.879 Changing the VM state from 'SAVING' to 'SUSPENDED'.
00:58:39.889 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={Cannot resume the machine as it is not paused (machine state: Saving)}, preserve=false

comment:3 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

In that case it's a duplicate of #6189 and will be most likely fixed in the next maintenance release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use