VirtualBox

Ticket #9995 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

Taking snapshot freezes running guest OS

Reported by: CKukuchka Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.1.6 Keywords: snapshot take
Cc: Guest type: other
Host type: other

Description

Using VirtualBox 4.1.6r74727 on RedHat Enterprise Server release 5.7, when I "take" a snapshot on a running guest OS, it the guest OS gets permanently frozen. To resume, I must poweroff the VM and start it fresh.

The guest OSes are RHEL 5.7 and Windows Server 2K3.

The version of VirtualBox I am using was downloaded from www.virtualbox.org. This is the version information reported by rpm:

VirtualBox-4.1-4.1.6_74727_rhel5-1

The host OS kernel info as reported by "uname -a" is this:

Linux seqvhs 2.6.18-238.el5 #1 SMP Sun Dec 19 14:22:44 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

I have tried "vboxmanage controlvm {name} resume" and it does not restart the guest OS.

Attached are the VBox.log files for the two guest VMs.

From what I can see, taking the snapshot on the RHEL machine results in a "state" of running. However, the guest OS itself is not responding. The W2K3 guest acts differently in that it gets stuck in a "Guru Meditation" state.

Attachments

VBox_RHEL.log Download (109.7 KB) - added by CKukuchka 2 years ago.
Guest VM log for RHEL system
VBox_W2K3.log Download (254.0 KB) - added by CKukuchka 2 years ago.
Guest VM log for W2K3 system

Change History

Changed 2 years ago by CKukuchka

Guest VM log for RHEL system

Changed 2 years ago by CKukuchka

Guest VM log for W2K3 system

comment:1 Changed 2 years ago by Perryg

Adding name to track

comment:2 Changed 2 years ago by CKukuchka

Verified problem still happens using newly released version (4.1.8) which was installed via this RPM:

VirtualBox-4.1-4.1.8_75467_rhel5-1.x86_64.rpm

comment:3 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

This is actually a duplicate of #9255. Don't do a live snapshot but use the --pause parameter with VBoxManage.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use