VirtualBox

Ticket #9989 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Segfault 4.1.6 on Fedora 16

Reported by: px Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

I have: Fedora 16 i686 kernel 3.1.4

After upgrading VB to 4.1.6, he crashes with a segmentation fault.

$ VBoxManage startvm centos Waiting for VM "centos" to power on... VBoxManage: error: The virtual machine 'centos' has terminated unexpectedly during startup because of signal 11 VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine, callee

$ VirtualBox Segmentation fault

$ dmesg [ 1967.350534] VBoxTestOGL[11888]: segfault at bbe18315 ip 00a3edb4 sp bffa4b70 error 6 in ld-2.14.90.so[a32000+21000] [ 2755.533576] VirtualBox[15510]: segfault at bfc69315 ip 00891db4 sp bfd57c10 error 6 in ld-2.14.90.so[885000+21000]

I removed VirtualBox via yum, removed config dirs, vms, other VB files via find, then reboot. Reinstalled VB but the problem is still there - segfault.

Attachments

VBoxSVC.log Download (2.7 KB) - added by px 2 years ago.
VBox.log.1 Download (74.2 KB) - added by px 2 years ago.

Change History

Changed 2 years ago by px

comment:1 follow-up: ↓ 2 Changed 2 years ago by frank

Please provide a VBox.log file from such a VM session (VBoxSVC.log is not sufficient).

Changed 2 years ago by px

comment:2 in reply to: ↑ 1 Changed 2 years ago by px

Please.

comment:3 Changed 2 years ago by frank

There is no segmentation fault visible in the VBox.log file. The segfault of the VBoxTestOGL binary is expected on some platforms as this is a simple test if 3D works at all and the possible crash was actually the reason for moving this test into a separate process rather than executing the test in the VM process. If you don't see any other crash except the VBoxTestOGL crash then this is no bug at all.

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use