VirtualBox

Ticket #988 (closed defect: worksforme)

Opened 6 years ago

Last modified 4 years ago

SpeedFan problem when starting Virtual Box

Reported by: stitch10925 Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 1.5.2 Keywords: SpeedFan
Cc: Guest type: other
Host type: other

Description

When I start VirtualBox, SpeedFan does not work anymore. SpeedFan does not show any temperatures anymore and fans are not adjusted. Restart is required in order to get SpeedFan working again.

This problem happens as soon as VirtualBox shows the XP boot logo. (I think this might be because of USB integration or so).

When SpeedFan stops working and I close it, then start it new, I get an error message saying that it could not read the memory. (I do not know the error message exactly. Will post later).

Change History

comment:1 Changed 6 years ago by frank

Please provide more info: Which host system (OS, hardware), which guest (WinXP?)

comment:2 Changed 6 years ago by stitch10925

I'm sorry, I forgot to mention this. Here are the specs:

The PC:

  • Mobo: Asus P5B-Deluxe WIFI With 2 GB RAM
  • OS: Windows XP Pro (32-Bit)
  • Anti-Virus: NOD32
  • CPU: Intel E6700 (Core 2 Duo)

The VB:

  • Tiny XP Rev 5 (32-Bit)
  • Shared folders enabled and Guest Additions Installed
  • USB Support Enabled
  • ACPI, I/O APIC and VT-x/AMD-V Enabled

I also checked out the error message that I get when restarting SpeedFan after it stoped working after I booted the VB:

"Access violation at address 00620EF2 in module 'speedfan.exe'. Read of address FFFFFFFF."

This only seems to happen when I enable the VT-x/AMD-V feature (Even though my processor supports virtualization technology).

I do not have the problem when enabling either I/O APIC or ACPI and have VT-x/AMD-V disabled.

Hope this is enough info _

comment:3 Changed 6 years ago by Soldermelons

This is happening with me too, and I suspected it was VT-x related as well. I'm running WinVista Business (32bit) on an Intel Q6600. Any suggestions?

comment:4 Changed 6 years ago by sandervl73

So you can confirm the problem goes away when you don't enable VT-x in VBox? If that's the case, then Speedfan must be incompatible with this mode for some reason. Not much we can do about it.

comment:5 Changed 6 years ago by stitch10925

I have an Asus P5B Deluxe, Soldermelons, what system do you have?

comment:6 Changed 6 years ago by Soldermelons

I have an MSI P6N SLI-FI, so it doesn't seem to be a mobo issue.

Just checked VirtualBox 1.6 and the problem still seems to occur.

comment:7 Changed 6 years ago by stitch10925

I don't think this is a speedfan, nor a virtualbox problem, I think this is more a memory collision, because both programs work fine when the other isn't running.

comment:8 Changed 6 years ago by kensiko

Exactly the same problem here.

I don't think the problem is a conflict between virtualization and speedfan because I have been using VMware with virtualization (32 and 64 bits on a 32 bits host) and speedfan did not have any problem.

comment:9 Changed 6 years ago by frank

Again, can all of you confirm that this problem goes away if you disable VT-x/AMD-V for this VM session? Did all of you check if this problem is still an issue with 1.6.4?

comment:10 Changed 6 years ago by stitch10925

Hello Frank,

Yes, this only happens when the VT-x/AMD-v is enabled. Speedfan gave me the following information in a thread i opened there:

Ok. I installed VirtualBox 1.6 on my Windows Vista Business. I have an Asus P5B Deluxe with an Intel E6420 and 2GB RAM. I installed Windows XP Pro in VirtualBox and enabled VT-x/AMD-V. I've seen the access violation. The solution is to stop GIVEIO.SYS service. SpeedFan 4.35 beta will include a new command line parameter (/NOGIVEIO) to start SpeedFan without any access to the GIVEIO service.

The NOGIVEIO switch from speedfan worked in the beta, but does not seem to work anymore in the new beta, so the problem still still is not solved.

comment:11 Changed 6 years ago by frank

  • Component changed from other to VMM/HWACCM

Did you really install VirtualBox 1.6.4? VirtualBox 1.6 sounds like 1.6.0 ...

comment:12 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Please retry with 2.1.4 and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use