VirtualBox

Ticket #987 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

vboxwebsrv crashed after calling IMachine_attachHardDisk (backtrace attached)

Reported by: fireline Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords: vbox webservice: vboxwebsrv crashed
Cc: Guest type: other
Host type: other

Description

Hi!

I'am using PHP 5 with Fedora 7.

Scenario: 1.) Open SOAP connection to vboxwebsrv with SOAPClient() 2.) Call IWebsessionManager_logon() 3.) Call IVirtualBox_createMachine() 4.) Call IVirtualBox_openVirtualDiskImage() 5.) Call IVirtualBox_registerHardDisk() 6.) Call IMachine_attachHardDisk()

Attachment contain gdb output. thanks.

7.) vboxwebsrv crashed with Segmentation fault

Attachments

vbox_webservice_bug_attachHardDisk_19.12.txt Download (3.2 KB) - added by fireline 6 years ago.
gnu debugger output

Change History

Changed 6 years ago by fireline

gnu debugger output

comment:1 Changed 6 years ago by klaus

This looks like a buffer overrun somewhere. The pointers/object references in the last libstdc++ method calls are simply invalid. It would help greatly hunting this down if you could provide a standalone program which reproduces this bug, it'd save much debug time creating a testcase first. Worst case would be that my testcase would work fine and yours still wouldn't.

comment:2 Changed 6 years ago by umoeller

  • Status changed from new to closed
  • Resolution set to fixed

Crash was caused by a NULL error message string, which apparently wasn't liked by the text conversions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use