VirtualBox

Ticket #9690 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Hitting full screen twice garbled screen -> duplicate of #9536

Reported by: tlundqvist Owned by:
Priority: minor Component: GUI
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi, I've had a problem for ages (many versions back). I usually use a linux guest in full screen (Host-F). If I leave full screen and reenter again, the screen gets completely garbled (see attached photo). If I resize or move the window slightly before I enter full screen again, it works alright.

When the screen gets garbled I have no problem leaving full screen and go back to windowed mode again - but then, the window always gets resized to cover the whole desktop area. My solution for several years now have been to always do a slight window resize before entering full screen. Safe, but a bit annoying.

Same behavior in Windows 7 (64 bit) and Windows XP (32 bit) as host. Still a problem in VirtualBox 4.1.4. Had it for several years.

Forum:  https://forums.virtualbox.org/viewtopic.php?f=6&t=44229

Attachments

garbled_screen.jpg Download (82.8 KB) - added by tlundqvist 3 years ago.
ant64-2011-10-04-16-14-31.log Download (56.3 KB) - added by tlundqvist 3 years ago.
Full screen garbled and the ctrl-f again before saving log

Change History

Changed 3 years ago by tlundqvist

Changed 3 years ago by tlundqvist

Full screen garbled and the ctrl-f again before saving log

comment:1 follow-up: ↓ 2 Changed 3 years ago by michael

Do you think this is the same issue as #9536?

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 3 years ago by tlundqvist

Replying to michael:

Do you think this is the same issue as #9536?

It seems to be related but I'm using a windows host. That might mean that it's an X11 problem. However, for me it is fairly predictable (not the 1 in 3 chance). I can invoke the behavior by: 1. resize window slightly, 2. crtl-f to fullscreen (works alright), 3. ctrl-f out of fullscreen (works alright but windows placement differ - yet another bug?), 4. ctrl-f to enter fullscreen again gets garbled, 5. ctrl-f out of fullscreen works ok but window is then maximized.

However, now when I continue testing by hitting ctrl-f over and over again (from the window maximized position), it is fairly unpredictable. Fullscreen worked 3 times and then got garbled. Also, I saw one case where the window-mode (not fullscreen) got garbled (rare but can obviously happen as well, same pattern). So, X11 screen driver problem maybe and then probably the same as #9536.

comment:3 in reply to: ↑ 2 Changed 3 years ago by tlundqvist

It seems to be related but I'm using a windows host. That might mean that it's an X11 problem.

A note: If it is an X11 problem, I'm running Debian stable with a slightly old X: "X.Org X Server 1.7.7".

comment:4 Changed 3 years ago by michael

I'm assuming it is a problem with the VirtualBox guest driver for X11, which is the same for all versions of X.Org Server from 1.3 to 1.11. I will upload a couple more test drivers to #9536 - perhaps you could give them a try and attach the Xorg.0.log file with the additional information to that ticket?

comment:5 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Hitting full screen twice garbled screen to Hitting full screen twice garbled screen -> duplicate of #9536

I will close this as a duplicate of #9536 and we can continue there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use