VirtualBox

Ticket #9536 (closed defect: fixed)

Opened 3 years ago

Last modified 7 months ago

Screen corruption when switching to full screen mode => Fixed in SVN

Reported by: srd Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.2 Keywords:
Cc: Guest type: X11
Host type: Mac OS X

Description (last modified by frank) (diff)

When switching a guest to full screen mode, I have a 1 in 3 chance of the guest screen becoming corrupted. Switching back to windowed mode, clicking on maximize and switching to fullscreen mode again is needed to fix the corruption (although very annoying as a workaround because the window positions in the guest are all moved together, requiring a manual 'cleanup').

Host is MacOS X SnowLeopard Guest Ubuntu 11.04 (also happened with 10.10)

This has also happened with the 4.0.x releases of virtualbox.

This happens with 3D acceleration both enabled and disabled.

Auto-resize Guest display is enabled.

Attachments

main64-2011-08-31-14-15-56.log Download (74.4 KB) - added by srd 3 years ago.
Screen shot 2011-08-31 at 14.15.41 .png Download (257.6 KB) - added by srd 3 years ago.
Xorg.0.log.before Download (31.5 KB) - added by tlundqvist 3 years ago.
Xorg just after start up of X before hitting ctrl-f
Xorg.0.log.after Download (71.0 KB) - added by tlundqvist 3 years ago.
Xorg after hitting ctrl-f 6 times. Garbled screen after 5th ctrl-f (third fullscreen entry).
Xorg.0.log Download (374.8 KB) - added by srd 3 years ago.

Change History

comment:1 Changed 3 years ago by michael

Could you please attach a log file from the host and a screenshot of a corrupt screen?

Changed 3 years ago by srd

Changed 3 years ago by srd

comment:2 Changed 3 years ago by srd

Hi, the corruption in the screenshot happened within 2 minutes of my saving the logfile.

comment:3 Changed 3 years ago by michael

Sorry that I left this for a while. I was unable to see much in the log file, so I uploaded two debug builds of the X.Org video driver to virtualbox.org that you might like to try out. They should work on Ubuntu 11.04 and 11.10 guests and will print out a lot more information to /var/log/Xorg.0.log (on the guest) than the standard builds do. You can download them as

https://www.virtualbox.org/download/testcase/vboxvideo_110_32bit_20111004.zip
https://www.virtualbox.org/download/testcase/vboxvideo_110_64bit_20111004.zip

for 32bit and 64bit guests. Just replace the existing X.Org video driver (in /opt/VBoxGuestAdditions*/lib/VBoxGuestAdditions) with the right one and upload the resulting Xorg.0.log along with the matching VM log. Thanks.

comment:5 Changed 3 years ago by tlundqvist

Just for completeness - I posted a duplicate of this: #9690 (which is now closed). I have the same problem for windows hosts... I will try out the debug drivers...

Changed 3 years ago by tlundqvist

Xorg just after start up of X before hitting ctrl-f

Changed 3 years ago by tlundqvist

Xorg after hitting ctrl-f 6 times. Garbled screen after 5th ctrl-f (third fullscreen entry).

comment:6 Changed 3 years ago by tlundqvist

I added a debug-Xorg.log. The after-file includes a garbled screen. It behaved a bit differently now. Normally, screen gets garbled every second entry to fullscreen. Now, I had 2 fullscreen looking ok (4 ctrl-f presses) but the third one (5th ctrl-f press) becoming garbled. I also exited fullscreen by ctrl-f (6th press) before copying the Xorg.log-file. The exit after a screen garble takes a bit longer time and then window becomes maximized.

Changed 3 years ago by srd

comment:7 Changed 3 years ago by srd

Added my Xorg.0.log file.

Booted up in windowed mode, logged in in windowed mode and then toggled full screen until screen corruption occurred (when entering the fullscreen mode the 3rd time). Left fullscreen mode to restore the screen by maximizing.

This is on the 64bit ubuntu 11.04 running virtualbox 4.1.2.

comment:8 Changed 3 years ago by michael

I think that I have fixed this problem, but in the host code, not the Guest Additions. Here is a test build which contains the fixes for Mac OS X host, in case you would like to give it a try. Be aware that this is a snapshot of VirtualBox development code, so please do not use it for anything mission-critical!

https://www.virtualbox.org/download/testcase/VirtualBox-2011-10-21-16-23-38-mac2-rel-4.1.51-r74506.dmg

comment:10 Changed 3 years ago by tlundqvist

I installed the windows version now and tried ctrl-f a couple of times. Seems to be solved. Works perfectly! I will continue to use this version for a while and report if any problems arise.

I'm a bit suprised it was the host code. What was the problem? Well, I can maybe read the patch sometimes in the future...

comment:11 Changed 2 years ago by frank

  • Summary changed from Screen corruption when switching to full screen mode to Screen corruption when switching to full screen mode => Fixed in SVN

This fix will be included in the next minor release.

comment:12 Changed 2 years ago by frank

Sorry, my fault. The fixes will not go yet into 4.1.6.

comment:13 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use