VirtualBox

Ticket #9615 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

All VDIs lost (not physically): create and delete snapshot after creating VM, restart VirtualBox

Reported by: virtualboxbug Owned by:
Priority: critical Component: VMM
Version: VirtualBox 4.1.2 Keywords: VDI, lost, snapshot, Virtual Media Manager
Cc: Guest type: Windows
Host type: Windows

Description

I create a VM. OS disk is Multi-attach. (Immutable freezes when resuming.) Data disk is Writethrough. I take a snapshot using the UI of the VM while it's powered off in order to create a differencing disk. I delete the snapshot to get rid of the differencing disk but it still leaves a differencing disk, because it's Multi-attach . This is what I wanted. I don't know how to get it otherwise. I restart VirtualBox.

I see this on the VM:

A differencing image of snapshot {e533c43c-588b-4447-a42e-184097602f56} could not be found. Could not find an open hard disk with UUID {b7de1b6d-ddd7-4367-86a5-2d1391a1c910}. Result Code: E_FAIL (0x80004005) Component: SnapshotMachine Interface: IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}

I took the snapshots using VBoxManage with the same results.

All disks have disappeared from Virtual Media Manager.

Please test creating, configuring, starting, stopping, deleting multiple VMs only with VboxManage you'll run into BSODs. They weren't there before 4.x.

Don't take this wrong, I'm just wondering - justifiably, I think: This is 4.x? Really? NO version 4 has this many simple and critical bugs. Do you test these things at all? Does anyone use this actually? I'm feeling like I'm alpha testing some 0.1 version. I hope you can fix all these bugs I've reported immediately, because they are true show-stoppers - I can't use your product while they're there.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Most probably fixed with VBox 4.1.4. Please reopen if still reproducible.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use