VirtualBox

Ticket #9474 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

GURU MEDIATION during snapshotting a running openSUSE12.1MS3->factory tested state

Reported by: maninred2 Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I´ve made a fresh installation of openSUSE12.1 MS3 and brought it to  http://download.opensuse.org/factory-tested/repo/... (all repros there) , so it´s more to the upcoming milestone4.

The problem is that during snapshotting the running guest, GURU MEDIATION occured and the guest shut down with it.

I´am still on Virtualbox 4.1.0, because the packages of 4.1.2 are not ready from openSUSE repros.

I attach the log; the automated screenshot is useless, because the machine was in background and nothing doing(only dolphin and yast2 are running idle)

Attachments

openSUSE12.1 MS3 fresh-2011-08-20-12-40-32.log Download (387.0 KB) - added by maninred2 3 years ago.

Change History

Changed 3 years ago by maninred2

comment:1 Changed 3 years ago by maninred2

Console output:

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.826376]

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.826378] !!Assertion Failed!!

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.826380] Expression: (null)

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.826381] Location : /usr/src/packages/BUILD/VirtualBox-4.1.0_OSE/src/VBox/VMM/VMMAll/PGMAllBth.h(1458) void pgmR0BthAMD64ProtSyncPageWorkerTrackDeref(VMCPU*, PGMPOOLPAGE*, RTHCPHYS, uint16_t, RTGCPHYS)

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.826442] HCPhys=00000001e67c2000 wasn't found!

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.846902]

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.846904] !!Assertion Failed!!

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.846905] Expression: (null)

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.846906] Location : /usr/src/packages/BUILD/VirtualBox-4.1.0_OSE/src/VBox/VMM/VMMAll/PGMAllBth.h(1458) void pgmR0BthAMD64ProtSyncPageWorkerTrackDeref(VMCPU*, PGMPOOLPAGE*, RTHCPHYS, uint16_t, RTGCPHYS)

Message from syslogd@linux-9aw6 at Aug 20 12:37:50 ...

kernel:[ 6071.846940] HCPhys=00000001b5762000 wasn't found!

comment:2 Changed 3 years ago by maninred2

Kernel-log(relevant part):

Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.826376] Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.826378] !!Assertion Failed!! Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.826380] Expression: (null) Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.826381] Location : /usr/src/packages/BUILD/VirtualBox-4.1.0_OSE/src/VBox/VMM/VMMAll/PGMAllBth.h(1458) void pgmR0BthAMD64ProtSyncPageWorkerTrackDeref(VMCPU*, PGMPOOLPAGE*, RTHCPHYS, uint16_t, RTGCPHYS) Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.826442] HCPhys=00000001e67c2000 wasn't found! Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.846902] Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.846904] !!Assertion Failed!! Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.846905] Expression: (null) Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.846906] Location : /usr/src/packages/BUILD/VirtualBox-4.1.0_OSE/src/VBox/VMM/VMMAll/PGMAllBth.h(1458) void pgmR0BthAMD64ProtSyncPageWorkerTrackDeref(VMCPU*, PGMPOOLPAGE*, RTHCPHYS, uint16_t, RTGCPHYS) Aug 20 12:37:50 linux-9aw6 kernel: [ 6071.846940] HCPhys=00000001b5762000 wasn't found!

The same as from console.

comment:3 Changed 3 years ago by npyowell

I'm seeing the same issue on CentOS 5.6 (2.6.18-274.el5), virtual box 4.1.2. Whenever i take a snapshot, this happens, i then have to remove the guest and re-create it using the existing harddisk to get the system back. Problem didn't occur until i upgraded from 4.0.12 to 4.1.2.

Aug 29 05:50:14 mothra kernel: M Aug 29 05:50:14 mothra kernel: !!Assertion Failed!^M Aug 29 05:50:14 mothra kernel: Expression: <NULL>M Aug 29 05:50:14 mothra kernel: Location : /home/vbox/vbox-4.1.2/src/VBox/VMM/VMMAll/PGMAllBth.h(1458) void pgmR0BthAMD64ProtSyncPageWorkerTrackDeref(VMCPU*, PGMPOOLPAGE*, RTHCPHYS, uint16_t, RTGCPHYS)M Aug 29 05:50:14 mothra kernel: HCPhys=00000000a2ba6000 wasn't found!

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9255.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use