VirtualBox

Ticket #9294 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

Kernel oops on VBox VM startup leading to total networking fault (reproducible)

Reported by: birdie Owned by:
Priority: blocker Component: network
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm running vanilla Linux kernel 3.0, i686.

On startup of a VM with a bridged networking I get a kernel oops and networking becomes unusable from this point.

The whole OS also becomes unusable and semi-dead at this point. I can close some applications, but I cannot even reboot normally.

ifconfig hangs on invocation (entering the Zombie state).

Attachments

startup.png Download (42.6 KB) - added by birdie 3 years ago.
A VBox window
ooops.txt Download (3.7 KB) - added by birdie 3 years ago.
kernel oops message
VBox.log Download (36.5 KB) - added by birdie 3 years ago.
VBox.log

Change History

Changed 3 years ago by birdie

A VBox window

Changed 3 years ago by birdie

kernel oops message

Changed 3 years ago by birdie

VBox.log

comment:1 Changed 3 years ago by birdie

This seems like a duplicate of bug 8712, but I was using GCC 4.2.4 for building the kernel and the VBox modules.

I'm now rebuilding everything using GCC 4.5.2, let's see if it helps.

comment:2 Changed 3 years ago by birdie

With GCC 4.5.2 everything works just fine.

comment:3 Changed 3 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use