VirtualBox

Ticket #9260 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

vbox* modules breaks suspend (hang or reboot)

Reported by: eugenesan Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Loading kernel modules from 4.1 breaks suspend functionality on Ubuntu 11.04. Attempt to suspend usually hangs but sometimes restarts the machine.

Issues existed also in 4.1 beta versions. 4.0 works perfectly.

Attachments

failedsuspend-kern.log Download (1.6 KB) - added by martin.heimes 3 years ago.
HP 625 Debian Squeeze

Change History

comment:1 Changed 3 years ago by wonder

related to this #9253 ?

comment:2 Changed 3 years ago by eugenesan

#9253 doesn't look related. I am experiencing issues only when trying to suspend. Shutdown/Reboot and Loading/Unloading modules works fine. In addition I am using different kernel version.

comment:3 Changed 3 years ago by supercompman

I'm having the same issue with Ubuntu 10.04 (32-bit) as the host OS. Sleep and hibernate hang if the vboxdrv module is running. If I stop the vboxdrv module before trying to hibernate or sleep, everything works fine. Sleep and hibernate worked fine when I was using VirtualBox 4.0.12 and and several previous versions.

comment:4 Changed 3 years ago by suboptimist

Same issue here. I'm also running VirtualBox 4.1.0 on Ubuntu 11.04. Trying to sleep or hibernate results in a black but not turned off screen and the capslock and "arrow-down" LED synchronously blinking. Only chance is reboot.

comment:5 Changed 3 years ago by suboptimist

Adding the following line in /etc/pm/config.d/unload_modules fixes the problem for me:

SUSPEND_MODULES="$SUSPEND_MODULES vboxdrv vboxnetflt vboxnetadp vboxpci "

comment:6 Changed 3 years ago by wonder

still,that is a workaround. the proper way is fixing the actually bug in vboxdrv

comment:7 Changed 3 years ago by suboptimist

Of course it is. I just thought it might save time for inexperienced users like me if I post the workaround I found.

comment:8 Changed 3 years ago by bikehead

I have the same problem with Fedora 15 (32bit)

comment:9 Changed 3 years ago by frank

Sometimes after suspending + resuming the host I see timing problems and reloading the modules makes these problems away. Do all of you agree that your problems are 4.1 regressions? What happens if you only unload the vboxpci module before suspending?

comment:10 Changed 3 years ago by frank

Oh, and could you attach /var/log/kern.log from your host kernel right before you suspend the host?

comment:11 Changed 3 years ago by bikehead

I unloaded all the vbox* modules and then loaded up vboxdrv and suspend failed. With all the modules loaded when I removed only vboxpci.

btw: on fedora the /etc/pm/config.d/unload_modules trick didn't work for me.

Changed 3 years ago by martin.heimes

HP 625 Debian Squeeze

comment:12 Changed 3 years ago by martin.heimes

HP 625 notebook, Debian Squeeze 32bit: suspend/resume works with VBox 3.2 and 4.0 ... but 4.1 no workie.

vbox 4.1 and suspend/resume works on two other machines, both Debian Wheezy

attached file is detail from /var/log/kern.log starts with vbox update to 4.1.0 and has failed suspend short time after

comment:13 Changed 3 years ago by davescafe

I am also affected by this defect using VirtualBox 4.1.

I have an HP Compaq 8510w.

Stopping the vboxcrv service solves the problem, but of course without the service, VirtualBox won't start.

comment:14 Changed 3 years ago by LpSolit

This happened to me too, with Mageia 1. When shutting down my PC, a kernel panic occurs, with the call trace shown in this  screenshot (you can read the  full article). This problem didn't happen with VirtualBox 4.0.12.

comment:15 Changed 3 years ago by tshann

I have an HP DV6000 laptop. I'm running Crunchbang Linux with Debian Squeeze - kernel 2.6.32-5-686. I have this same effect. Whether a VM is running or not, 4.1 fouls suspend or hibernate. With suspend, I can go into suspend. But when I try to resume, I just have a black unresponsive screen. I just went back to 3.18 and now have a functioning suspend/hibernate. So for this lappie, the same problem is reproducible every time with 4.1.

On a separate note, I went back to 3.18 because it USED to allow me to actually suspend or hibernate my Linux host, and my Windows XP guest would not be harmed when I resumed. I didn't even have to pause the VM, it just worked. But now, after re-installing 3.18, that capability is no longer functioning. The VM is just gone after resuming. Oh well, at least 3.18 doesn't hose suspend and resume in general.

comment:16 Changed 3 years ago by callegar

I think that it only happens on 32 bit systems. My 64 bit systems are not affected, the 32 bit one is.

comment:17 Changed 3 years ago by joemburgess

This bug has also been reported in the Ubuntu bug tracker at  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/814323. Hopefully that helps you out.

comment:18 Changed 3 years ago by grayfox

Suspend is broken on Fedora 15 with the last 3 PAE kernels, the most recent is

2.6.38.8-35.fc15.i686.PAE

I am running an up to date Fedora 15 on an i7 based laptop with the nouveau driver.

comment:19 Changed 3 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to duplicate

Please see #9305 for the solution. Closing this as a duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use