VirtualBox

Ticket #9205 (closed defect: fixed)

Opened 4 years ago

Last modified 8 weeks ago

Could not initialize DirectSoundCapture

Reported by: dark_overload Owned by:
Priority: major Component: audio
Version: VirtualBox 4.0.10 Keywords: HostAudioNotResponding
Cc: Guest type: Linux
Host type: Windows

Description (last modified by sunlover) (diff)

I have tried everything to get virtualbox to stop giving me this error, but nothing works. Below is the relevant section of the log for a test VM I created with all default settings just to test this bug.

00:00:00.765 Audio: Trying driver 'dsound'. 00:00:00.810 DSound: Could not initialize DirectSoundCapture 00:00:00.812 Audio: set_record_source ars=0 als=0 (not implemented) 00:00:00.812 AC97: WARNING: Unable to open PCM IN! 00:00:00.812 AC97: WARNING: Unable to open PCM MC! 00:00:00.812 VM: Raising runtime error 'HostAudioNotResponding' (fFlags=0x0) 00:00:00.812 Console: VM runtime error: fatal=false, errorID=HostAudioNotResponding message="Some audio devices (PCM_in, PCM_mic) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem"

Change History

comment:1 Changed 4 years ago by dark_overload

Further testing shows that using HD audio causes only PCM_in to fail, and SB16 doesnt give errors.

comment:2 Changed 4 years ago by dark_overload

Scratch that, the log still shows "Could not initialize DirectSoundCapture"

comment:3 Changed 23 months ago by Tomer

The following website seems to explain this issue and provide a solution to the problem:  http://amindlost.wordpress.com/2012/02/08/virtualbox-hostaudionotresponding/

Last edited 23 months ago by Tomer (previous) (diff)

comment:4 Changed 5 months ago by sunlover

  • Description modified (diff)

We think we fixed this problem. Here is a test build: https://www.virtualbox.org/download/testcase/VirtualBox-4.3.21-97032-Win.exe

comment:5 Changed 5 months ago by BugRep0rt3r

The problem is NOT solved with 4.3.21-97032 - indeed the popup message is gone but sound is still out. See my: #13491

Last edited 5 months ago by BugRep0rt3r (previous) (diff)

comment:6 Changed 2 months ago by frank

Still present with VBox 4.3.22?

comment:7 Changed 2 months ago by BugRep0rt3r

Yes. The problem is still there.
Right after the installation (clean) the sound in guest had been working OK - until Host restart. After host restart no sound in Guest. Once, when playing with sound settings it caused the blue screen in Guest and Audio failure in Host. After closing "blued" guest and running troubleshooting on Host it resurrected in Host.
Sorry.

Last edited 2 months ago by BugRep0rt3r (previous) (diff)

comment:8 Changed 2 months ago by BugRep0rt3r

There is a progress. It was strange to me it was stopping working after host restart. I have run VirtualBox-4.3.22-98236-Win.exe in Repair mode. It finished repairing and asked to reboot. I ignored the message and VMManager started. I started the guest and it failed with some 2 errors. I confirmed them, then I closed VMManager and rebooted. Surprisingly, after reboot it worked OK - I have sound in guest. So, now it looks like the installer-package problem.

Last edited 2 months ago by BugRep0rt3r (previous) (diff)

comment:9 Changed 2 months ago by sunlover

  • Status changed from new to closed
  • Resolution set to fixed

BugRep0rt3r, thanks for feedback. Actually 4.3.21-97032 did not have all relevant fixes. If you will still get the error with VirtualBox 4.3.22 then please get debug log:

1) Open 'Control Panel/System/Advanced system settings/Environment Variables' on the host and create a new system variable with name VBOX_RELEASE_LOG and value +dev_audio.e.f.l2

2) start the VM, try to play and record audio in the VM, then shutdown the guest.

3) attach VBox.log to this ticket (or to #13491). The log should contain more "DSound: ..." lines.

I'll close this ticket, because the original "runtime error 'HostAudioNotResponding'" problem has been fixed in VirtualBox 4.3.22. Thanks!

comment:10 Changed 2 months ago by crazymumu

I got sound in gust os but still have "HostAudioNotResponding" warning? is that ok?

comment:11 Changed 2 months ago by sunlover

crazymumu, please attach VBox.log of the VM with enabled debug logging (see comment 9).

comment:12 Changed 8 weeks ago by mjsr

Good afternoon, I'm receiving the same problem of "HostAudioNotResponding". Some Audio devices(PCM_in, PCM_mic) could not be opened. Host: mac osx 10.10.2 (mac mini) Guest: mac os 10.9 The host doesnt have an audio input device. Could this be the problem?

I could provide the vm log where it shows more explicetely the failure to open the device (again the mac mini doesn't have an audio input device, is this a requirement to even open a vm?).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use