VirtualBox

Ticket #916 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Dragonflybsd does not work, it hangs when the bootloader is loading => Fixed in SVN

Reported by: aldorgan Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: BSD
Host type: other

Description

Dragonflybsd does not work, it hangs when the bootloader is loading. i have tried to reboot virtual box and tried several times but dragonflybsd won't boot it just comes to the bootloader and then it hangs.

Attachments

pit.patch Download (1.2 KB) - added by ni81036 5 years ago.
PIT pacth to fix boot hang.

Change History

comment:1 Changed 6 years ago by hircus

comment:2 Changed 6 years ago by tuxillo

This is being handled in DragonFlyBSD bugtracker. For more details please look here:

 http://bugs.dragonflybsd.org/issue995

comment:3 Changed 6 years ago by frank

Confirmed. We will look at this problem.

comment:4 Changed 6 years ago by frank

  • Guest type changed from other to BSD

comment:5 Changed 5 years ago by mneumann

As of VirtualBox 2.0.6 DragonFlyBSD still does not boot.

comment:6 Changed 5 years ago by tuxillo

Some more information that can help out with this issue:

DragonFlyBSD source code available at:  http://gitweb.dragonflybsd.org/dragonfly.git

Exact part of the code which is is related to the issue:  http://gitweb.dragonflybsd.org/dragonfly.git/blob/HEAD:/sys/platform/pc32/isa/clock.c

DragonFlyBSD Latest ISO Images at:  http://chlamydia.fs.ei.tum.de/pub/DragonFly/snapshots/i386/

comment:7 Changed 5 years ago by ni81036

  • Status changed from new to closed
  • Resolution set to fixed

Fix is available in SVN, unfortunately we cannot include it into 2.1.2 release due to lack of testing. Will also attach the patch, so you can apply it yourself.

Changed 5 years ago by ni81036

PIT pacth to fix boot hang.

comment:8 Changed 5 years ago by ni81036

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:9 Changed 5 years ago by tuxillo

This evening I've compiled lastest SVN trunk with this patch applied on a Gentoo x86_64 (Athlon64x2 3800+) as host.

I've successfully booted DragonFlyBSD and installed it on a small 4GB HDD. The VM has been compiling during 4 hours without any problems, it seemed to be stable. Nevertheless, I will let you know any issue I may encounter.

I would like to thank all the VBox team helping us in this issue.

Kind regards. Antonio Huete

comment:10 Changed 5 years ago by hircus

Has this been applied to 2.1.4? The Changelog does not mention this bug.

comment:11 Changed 5 years ago by frank

That fix is in the SVN version but not in 2.1.4. The reason is that this fix is not entirely approved yet.

comment:12 Changed 5 years ago by hircus

For those of us who use the non-OSE edition of VirtualBox, could the VirtualBox team provide us with test binaries?

comment:13 Changed 5 years ago by tuxillo

Hi,

Is there any plans to include this change on next VBox release, or it will be kept only for OSE?

Thanks Antonio

comment:14 Changed 5 years ago by frank

  • Summary changed from Dragonflybsd does not work, it hangs when the bootloader is loading. to Dragonflybsd does not work, it hangs when the bootloader is loading => Fixed in SVN

The fix is applied to current OSE and will be part of the next release.

comment:15 Changed 5 years ago by tuxillo

Hi

I can't find this fix committed in 2.2.0. Is it committed but not posted on Changelog, or just not committed?

Regards, Antonio

comment:16 Changed 5 years ago by ni81036

Yes, it is commited. but not mentioned. Does it work for you (I've seen some problems with raw mode)?

comment:17 Changed 5 years ago by tuxillo

Hi again,

I've been successful in installing/booting the systems. Thank you very much for your support.

I think this ticket can be closed.

Cheers, Antonio

comment:18 Changed 5 years ago by tuxillo

Btw, what do you mean with raw mode?

comment:19 Changed 5 years ago by ni81036

  • Status changed from reopened to closed
  • Resolution set to fixed

Raw == no VT-X/AMD-V. Nevermind.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use