VirtualBox

Ticket #915 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Keyboard key repeat issue on Linux hosts => fixed in svn

Reported by: lothas Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords: usb keyboard
Cc: Guest type: other
Host type: other

Description

I used the common USB solution to get to use my USB camera under windows. I also have a USB wireless keyboard and mouse. When I add those to the virtual machine, I get proper input for windows (e.g.: keys stay pressed instead of being repeatedly pressed). The problem is that I'm loosing keyboard support for Ubuntu.

So, under the present configuration I can have a proper keyboard in windows at the cost of loosing it for Ubuntu (while XP is running) or I can have seamless Ubuntu+XP but without proper keyboard support.

Change History

comment:1 Changed 6 years ago by michael

I'm sorry, but your report seems slightly confusing to me. Of course your USB keyboard will no longer be available to the host if you assign it to the guest (USB devices can not be shared, it is always an either or thing). However, you indicate that you have other problems with keyboard input when you don't assign the USB keyboard to the guest. Perhaps you could explain what they are?

comment:2 follow-up: ↓ 3 Changed 6 years ago by frank

And apart from this you should describe your setup in detail at first. Am I assuming right that you are using a WinXP guest on an Ubuntu host?

comment:3 in reply to: ↑ 2 Changed 6 years ago by lothas

Yes, I'm using a Windows guest on Ubuntu Host. What I found out about the keyboard was while trying a simple game. I opened Windows' Pinball right after installation but when I tried to fire the ball, by holding <space>, I noticed that I couldn't do it. So I pressed and hold <z>, which activates the left flipper. The flipper was activated and produced the proper sound but after holding <z> for a moment, it started to "tremble" as if <z> was being released and pressed again constantly at a very high rate. That also explained the fact that I couldn't launch the ball. So, summing up, when I don't give the USB keyboard to windows, I can't really press and hold any key.

I've also noticed that after shutting windows down, the usb devices don't get re-mounted for Ubuntu so I have to re-mount them myself (so far by unplugging and plugging again)

comment:4 Changed 6 years ago by michael

  • Summary changed from USB keyboard getting "grabbed" to Keyboard key repeat issue on Linux hosts

comment:5 Changed 6 years ago by gaure

Hi lothas I having the same issue with the keyboard map when the host owns the USB Keyboar. Does anyone answered you with the fix ?

comment:6 Changed 6 years ago by 6uest

I can confirm this bug on my "logitech" wireless USB keyboard.

comment:7 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Keyboard key repeat issue on Linux hosts to Keyboard key repeat issue on Linux hosts => fixed in svn

#1296 was a duplicate of this. This should be fixed in version 2.1 (not in future 2.0 versions though).

comment:8 Changed 6 years ago by achalella

Does anybody know the revision number that brought this fix?

comment:9 Changed 6 years ago by achalella

Got it: r12652.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use