VirtualBox

Ticket #9092 (new defect)

Opened 3 years ago

Last modified 3 years ago

Linux host Windows XP guest virtual drive gets corrupted when installing service pack

Reported by: myersmarkl Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am using Ubuntu 11.04 as the host and I am trying to install Windows XP as the guest and then using windows update to install all the updates. I have 2 Win XP CDs, one does not include any service pack the other includes service pack 2.

The installs works fine from both CDs in that their are no errors. Windows update seems to work fine in that there are no errors. When service pack 2 or 3, depending upon which CD I started with, is applied Windows update says the service pack was successfully installed and requires a reboot. When the guest starts to boot I get a message that Windows cannot be found. When I boot the guest with the CD and select repair and run chkdsk on drive c:, chkdsk finds file after file that is corrupt and cannot be fixed.

I have tried this many times now with the same result. I have tried installing and not installing the 4.0.8 extensions before using the Windows update. The virtual drive is defined as IDE master. I have even managed to corrupt the virtual drives of Windows XP that were created under VirtualBox version 3.

Attachments

VBox.log Download (65.0 KB) - added by myersmarkl 3 years ago.
VBox.log.1 Download (74.7 KB) - added by myersmarkl 3 years ago.
VBox.log.2 Download (72.4 KB) - added by myersmarkl 3 years ago.

Change History

comment:1 Changed 3 years ago by frank

Please attach a VBox.log file of such a VM session. Which version of VirtualBox did you use to create the virtual disk? Was that VBox 4.0.8 as well or an older version?

Changed 3 years ago by myersmarkl

Changed 3 years ago by myersmarkl

Changed 3 years ago by myersmarkl

comment:2 Changed 3 years ago by myersmarkl

Yes I created virtual disks using version 4.0.8 and I had a virtual disk that was created under version 3.x. that had worked fine under under 3.x. However, when I did a windows update in version 4.0.8 the virtual disk became corrupted.

There are 3 log files because I have tried to many times to get this to work.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use