VirtualBox

Ticket #9093 (closed defect: fixed)

Opened 3 years ago

Last modified 18 months ago

Fatal Error in Recompiler CPU (MINIX 3.1.9 exp.)

Reported by: pikpik Owned by:
Priority: minor Component: other
Version: VirtualBox 4.0.8 Keywords: recompiler minix
Cc: Guest type: other
Host type: Mac OS X

Description (last modified by frank) (diff)

Hi,

I was installing packages inside the guest and operation was normal, until I saw strange messages filling the guest's screen and then a message from VirtualBox appeared.

Basic transcript

Install image

Shutdown

Remove image

Start

# pkgin update

# pkgin install scmgit-base-1.7.3.4nb3

Normal operation: packages download and several install

Later, this line repeats many times:

WARNING wrong user pointer 0x7ffff9bc from process sh*F / 146430

After several moments, the following message appeared from VirtualBox:

A critical error has occurred while running the virtual machine and the machine execution has been stopped. [...]

I found this short log file (2011-06-21-11-33-21.051-VirtualBoxVM-527.log) in the Applications folder on the host system:

Log created: 2011-06-21T11:33:21.516747000Z
Executable: /Applications/VirtualBox.app/Contents/MacOS/../Resources/VirtualBoxVM.app/Contents/MacOS/VirtualBoxVM
fatal error in recompiler cpu: Trying to execute code with memory type
    addr_code=00000000000a0020 addend=0000000026632000 at 00000000000a0000. (iHandlerMemType=0x38 iMMIOMemType=0x30)

Other information

Guest: MINIX 3.1.9 (experimental image) Image:  http://www.minix3.org/download/minix3_1_9_ide_r9618.iso.bz2

This hasn't happened before for me for several versions of MINIX and VirtualBox. Because this is very rare (it occurred only once in about a year of frequent use), I'm listing this with a minor priority.

Thank you, pikpik

Attachments

VBox.log Download (133.2 KB) - added by pikpik 3 years ago.
Automatically generated error log
VM - Error.png Download (52.6 KB) - added by pikpik 3 years ago.
User-taken screenshot; VirtualBox's automatically generated screenshot was blank and black.

Change History

Changed 3 years ago by pikpik

Automatically generated error log

Changed 3 years ago by pikpik

User-taken screenshot; VirtualBox's automatically generated screenshot was blank and black.

comment:1 Changed 3 years ago by pikpik

Hi,

I realized I left some important facts out. First, the specific problem is caused by running MINIX 3.1.9 in 128 MB or memory. Second, here are more detailed steps.

To set up the system

  1. Create a new virtual machine for MINIX, settings: "other" OS, 128 MB of memory, & 2 GB for HD
  2. Download, decompress, and attach the MINIX 3.1.9 experimental image in VirtualBox
  3. Start the virtual machine
  4. Log in as "root"
  5. Type "setup" and install the system
  6. Type "shutdown" to return to the boot prompt
  7. Release the MINIX image in VirtualBox
  8. Type "exit" to restart the system and start the installed MINIX system

To reproduce the problem

In MINIX,

  1. Type "pkgin update" to set up the package system
  2. Type "cat > crash.sh," press enter/return once, and then type following:
    #!/bin/sh -x
    pkgin -f clean
    pkgin -f update
    pkgin -y remove readline
    pkgin -y install scmgit-base-1.7.3.4nb3
    
    Press Control + D to save.
  1. Type "chmod u+x crash.sh" to allow the script to execute
  2. Type "./crash.sh" to begin

This will remove certain packages and then install them again, eventually leading to a low memory situation that is not handled well by MINIX.

Note: Sometimes the downloads timeout indefinitely. If this happens, then just cancel (Control + C) and run the script again.

The problem occurs when the screen is filled with messages in the form of:

WARNING wrong user pointer 0x7ffff9bc from process sh*F / 146430

Then in VirtualBox,

  1. Wait for at least one minute
  2. Choose to "reset" (not shutdown) the virtual machine

The error message / "Guru Meditation" message should appear, as well as a log file from VirtualBox in the Applications folder, if running on Mac OS X.

Thank you, pikpik

comment:2 Changed 3 years ago by frank

  • Description modified (diff)

comment:3 Changed 22 months ago by frank

  • Description modified (diff)

Most probably fixed in VBox 4.1.18. Could you verify?

comment:4 Changed 22 months ago by frank

Please reopen if still relevant.

comment:5 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use